Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Sreekanth S Nair
    @sreekanthsnair
    [Vasanth KG, eGov] Yes, only when if you have Public Ip
    Zidabouvitch
    @Zidabouvitch
    @sreekanthsnair ok. thank
    Zidabouvitch
    @Zidabouvitch

    @sreekanthsnair I deploy egov but I have to homepage (172.16.2.164:8080/egi/) a mistake , my page
    contains this message :
    Error Page
    Powered by eGovernments
    There was a problem serving the requested page

    Powered by eGovernments Foundation

    what is the possible source of the error ?

    James Peru Mmbono
    @jmsperu
    Hi
    I am looking for a URL to the EGov demo
    Sreekanth S Nair
    @sreekanthsnair
    @Zidabouvitch you must be either missing -b 0.0.0.0 while starting the server or your eg_city not updated with your IP address in domainurl column
    hope i already shared the same with you
    Zidabouvitch
    @Zidabouvitch
    @sreekanthsnair afres analysis of the problem. posgresql data base migration has not been done. after correction of the problem egov run correctly
    Zidabouvitch
    @Zidabouvitch

    @sreekanthsnair Thank you !! Now I want to change mobile numer parameters for egov all module. a updte application-config.properties fil with parameters :
    default.country.code=251
    default.mobile.number.length=6

    But if I deploy or restart egov
    mobile number remains with those set by default
    (default.country.code=91
    default.mobile.number.length=10)
    My config don't apply
    How can resolve this and fix my country monais refilling countries ?

    Sreekanth S Nair
    @sreekanthsnair
    @Zidabouvitch as of now, label change and validation logic based on default.mobilr.number.length and default.country.code is not done. You can modify the the respective jsp files for now, we will be adding updates for the same sooner.
    Zidabouvitch
    @Zidabouvitch
    @sreekanthsnair I can modify jsp file okey! I try the suggestion
    Sreekanth S Nair
    @sreekanthsnair
    @Zidabouvitch :+1:
    simendipeter
    @simendipeter
    Hie dont you have a virtualised server for egov please
    simendipeter
    @simendipeter
    births &deaths, building plan approval, inventory and document management modules are not available
    Sreekanth S Nair
    @sreekanthsnair
    @simendipeter didn understand your first question, virtualised server for egov means ?
    @simendipeter building plan approval not available in main branch but you can get it from https://github.com/egovernments/eGov/tree/egov-bpa, birth &death and document management will take some more time for release.
    simendipeter
    @simendipeter
    okay thanks
    James Peru Mmbono
    @jmsperu
    Hi, how do I get around the following error in centos 7: [ INSTALL ] - Install PHOENIX Stack
        ###### WARNING ######
    
        This Script must be executed on Ubuntu/Fedora/CentOS/RedHat Flavor's Only.
    Vasanth KG
    @vasanth-egov
    @jmsperu : Installer tested only on Ubuntu flavor. You can modify the script content as said below to run the installer on CentOS.
    https://github.com/egovernments/eGov/blob/master/dev-utils/ansible/install.sh
    #!/bin/bash
    
    #WORKING_DIR="${HOME}/PHOENIX"
    WORK_DIR=$1 
    CURDIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
    
    txtrst=$(tput sgr0) # Text reset
    txtred=$(tput setaf 1) # Red
    txtgrn=$(tput setaf 2) # Green
    txtylw=$(tput setaf 3) # Yellow
    txtblu=$(tput setaf 4) # Blue
    txtpur=$(tput setaf 5) # Purple
    txtcyn=$(tput setaf 6) # Cyan
    txtwht=$(tput setaf 7) # White
    txtbld=$(tput bold) # bold    
    
    chk_user()
    {
        if [ "$(id -u)" != "0" ];
        then
            echo -e "\n\t\033[44;37;5m###### WARNING ######\033[0m"
            echo -e "\t${txtylw}${txtbld}Sorry ${txtgrn}$(whoami)${txtrst}${txtylw}${txtbld}, you must login as root user to run this script.${txtrst}" 
            echo -e "\t${txtylw}${txtbld}Please become root user using 'sudo -s' and try again.${txtrst}"
            echo
            echo -e "\t${txtred}${txtbld}Quitting Installer.....${txtrst}\n"
            sleep 1
            exit 1
        fi
    }
    
    apt_installer()
    {
        echo "Installing ANSIBLE ...!"
        sudo apt-get install software-properties-common -y && \
        sudo apt-add-repository ppa:ansible/ansible -y && \
        sudo apt-get update && sudo apt-get install ansible -y
        run_ansible_playbook ${WORK_DIR};
    }
    
    yum_installer()
    {
        sudo yum install ansible -y
        run_ansible_playbook ${WORK_DIR};
    }
    
    run_ansible_playbook()
    {
    
        if [ ! -z $1 ]
        then
            WORK_DIR="-e ANSIBLE_WORKSPACE=$1"
        else
            WORK_DIR=""
        fi
        echo "Running ANSIBLE Playbook to setup the PHOENIX stacks ...!"
        ansible-playbook -K -i ${CURDIR}/egov.phoenix/hosts ${CURDIR}/egov.phoenix/main.yml ${WORK_DIR}
    }
    
    ####### MAIN PROGRAME #############
    #chk_user
    if [ ! -d ${WORKING_DIR} ]
        then
            mkdir ${WORKING_DIR}
        fi
    
    # Os Specifc tweaks do not change anything below ;)
    if [ -f /etc/issue ]
    then
        OSREQUIREMENT=`cat /etc/issue | awk '{print $1}' | sed 's/Kernel//g' | sed '/^\s*\$/d'`
    else
        OSREQ=`cat /etc/redhat-release | awk '{print $1}' | sed 's/Kernel//g' | sed '/^\s*\$/d'`
    fi
    ###    
    yum_installer;
    James Peru Mmbono
    @jmsperu
    I have removed the apt installer declaration. but still not working. Is there something else I can change?
    James Peru Mmbono
    @jmsperu
    @vasanth-egov , Have you done similar before? It seems my changes do not have any effect on the process
    Vasanth KG
    @vasanth-egov
    @jmsperu : Can you replace the content of install.sh (dev-utils/ansible/install.sh) which is in prev comment and execute the auto installer steps.
    Vasanth KG
    @vasanth-egov
    or replace the content of install.sh (dev-utils/ansible/install.sh) from https://gist.github.com/vasanth-egov/ee487db04f2cc212cff3d5e09c5ec1b2
    James Peru Mmbono
    @jmsperu

    @vasanth-egov Hi, thanks for the temp fix, however, I still got the following error:
    TASK [redis : install Redis server latest] *
    fatal: [localhost]: FAILED! => {"changed": false, "cmd": "apt-get update", "msg": "[Errno 2] No such file or directory", "rc": 2}
    to retry, use: --limit @/root/egovgithub/eGov/dev-utils/ansible/egov.phoenix/main.retry

    PLAY RECAP *
    localhost : ok=4 changed=3 unreachable=0 failed=1

    make: * [install] Error 2

    Ashok
    @agupta3304_twitter
    hi
    i install the project
    can anyone help me how to run it?
    i have done this part

    Setup with auto installer

    Clone the eGov repository (development is done on the develop branch).

    $ mkdir -p ${HOME}/egovgithub && cd egovgithub
    $ git clone -b develop --single-branch https://github.com/egovernments/eGov.git

    First time setup which will install the stacks, build the source code, and deploys the artifact to Wildfly

    $ cd ${HOME}/egovgithub/eGov && make all

    To install the prerequisites Phoenix stacks

    $ cd ${HOME}/egovgithub/eGov && make install

    To build the source code base

    $ cd ${HOME}/egovgithub/eGov && make build

    To deploy the artifact to WILDFLY

    $ cd ${HOME}/egovgithub/eGov && make deploy

    after this what to do?
    James Peru Mmbono
    @jmsperu
    Hi, does this support Car parking payment
    James Peru Mmbono
    @jmsperu
    An exception occurred during task execution. To see the full traceback, use -vvv . The error was: ProgrammingError: role "phoenix" does not exist
    fatal: [localhost]: FAILED! => {"changed": false, "msg": "Database query failed: role \"phoenix\" does not exist\n"}
    How do I solve thit
    Sreekanth S Nair
    @sreekanthsnair
    [Sreekanth Nair, eGov] No, it doesn't have Car parking payment.
    [Sreekanth Nair, eGov] @jmsperu we are not sure about the error you have mentioned here, probably its Postgres role related.
    James Peru Mmbono
    @jmsperu
    @sreekanthsnair Thanks. It would be lovely if it had
    Sreekanth S Nair
    @sreekanthsnair
    [Sreekanth Nair, eGov] @jmsperu sorry, unfortunately, we don't have any requirement from ULB for the same so at present, it's not in our roadmap.
    mritusingh93
    @mritusingh93
    hi, does this support egov-smartcity-suit
    mritusingh93
    @mritusingh93
    hello sir
    Sreekanth S Nair
    @sreekanthsnair
    [Sreekanth Nair, eGov] @mritusingh93 yes this channel is for egov-smartcity-suite support
    mritusingh93
    @mritusingh93
    sir , i am successfully deploy this application using ecalips , elasticsearch and wildfly server . but problem comes when i make small changes in code then after i have to again repeat the same process to generate the .ear file and replace it with previously existing .ear file in wildfly server under deployment folder.
    if i run mvn install command from ecalips then it can only changes reflect in local repository war file under .ear file.
    there in no any changes at war file under ear file in wildfly server under deployment folder
    mritusingh93
    @mritusingh93
    i have to replace it with new ear file again and again after every changes
    please help me to get rid of it
    Sreekanth S Nair
    @sreekanthsnair
    @mritusingh93 By default your changes won't get reflected immediately, you have to use either Eclipse hot deployment or install plugin called JRebel, it will help in rid of redeployment
    mritusingh93
    @mritusingh93
    ok sir
    thank you sir