Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 14:40
    NicolasCARPi labeled #3962
  • 04:21

    NicolasCARPi on 4.4.0-beta7

    (compare)

  • 04:21
    NicolasCARPi closed #29
  • 04:21
    NicolasCARPi closed #3954
  • 04:21

    NicolasCARPi on master

    update actions for latest add comment on SITE_URL descrip… fix issue with api query parame… and 3 more (compare)

  • 04:20

    NicolasCARPi on next

    update actions for latest add comment on SITE_URL descrip… fix issue with api query parame… and 1 more (compare)

  • 04:20

    NicolasCARPi on 4.4.0-beta7

    (compare)

  • 04:00

    NicolasCARPi on master

    fix blank value on duplicate fu… (compare)

  • 04:00

    NicolasCARPi on next

    fix blank value on duplicate fu… (compare)

  • 03:59

    NicolasCARPi on demo

    fix blank value on duplicate fu… Merge branch 'hypernext' into d… (compare)

  • 03:48

    NicolasCARPi on hypernext

    fix blank value on duplicate fu… (compare)

  • 03:07
    NicolasCARPi closed #3919
  • 03:07
    NicolasCARPi closed #3927
  • 03:07
    NicolasCARPi closed #3932
  • 03:07

    NicolasCARPi on master

    make pdfs smaller by removing h… add doc link for @page add documentation link on api p… and 45 more (compare)

  • 03:07

    NicolasCARPi on next

    make pdfs smaller by removing h… add doc link for @page add documentation link on api p… and 45 more (compare)

  • 01:25

    NicolasCARPi on demo

    change php max memory comment update actions for latest add comment on SITE_URL descrip… and 3 more (compare)

  • 01:24

    NicolasCARPi on demo

    make pdfs smaller by removing h… add doc link for @page add documentation link on api p… and 46 more (compare)

  • 01:22

    NicolasCARPi on hypernext

    upgrade tinymce (compare)

  • 01:21

    NicolasCARPi on hypernext

    fix items patch apidoc (compare)

alexander-haller
@alexander-haller
what does "docker logs --details mysql" say now?
besselfunct
@besselfunct
 2022-07-12 19:13:51+02:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 8.0.29-1.el8 started.
 2022-07-12 19:13:51+02:00 [Note] [Entrypoint]: Switching to dedicated user 'mysql'
 2022-07-12 19:13:51+02:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 8.0.29-1.el8 started.
 2022-07-12 19:13:52+02:00 [Note] [Entrypoint]: Initializing database files
 2022-07-12T17:13:52.042553Z 0 [Warning] [MY-010918] [Server] 'default_authentication_plugin' is deprecated and will be removed in a future release. Please use au                thentication_policy instead.
 2022-07-12T17:13:52.042567Z 0 [System] [MY-013169] [Server] /usr/sbin/mysqld (mysqld 8.0.29) initializing of server in progress as process 42
 2022-07-12T17:13:52.054078Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
 2022-07-12T17:13:53.238893Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
 2022-07-12T17:13:56.404692Z 6 [Warning] [MY-010453] [Server] root@localhost is created with an empty password ! Please consider switching off the --initialize-in                secure option.
 2022-07-12 19:14:02+02:00 [Note] [Entrypoint]: Database files initialized
 2022-07-12 19:14:02+02:00 [Note] [Entrypoint]: Starting temporary server
 2022-07-12T17:14:02.872144Z 0 [Warning] [MY-010918] [Server] 'default_authentication_plugin' is deprecated and will be removed in a future release. Please use au                thentication_policy instead.
 2022-07-12T17:14:02.872163Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.29) starting as process 91
 2022-07-12T17:14:02.890474Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
 2022-07-12T17:14:03.087866Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
 2022-07-12T17:14:03.441798Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
 2022-07-12T17:14:03.441865Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channe                l.
 2022-07-12T17:14:03.480641Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Socket: /var/run/mysqld/mysqlx.sock
 2022-07-12T17:14:03.480764Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.29'  socket: '/var/run/mysqld/mysqld.sock'  po                rt: 0  MySQL Community Server - GPL.
 2022-07-12 19:14:03+02:00 [Note] [Entrypoint]: Temporary server started.
 '/var/lib/mysql/mysql.sock' -> '/var/run/mysqld/mysqld.sock'
 Warning: Unable to load '/usr/share/zoneinfo/iso3166.tab' as time zone. Skipping it.
 Warning: Unable to load '/usr/share/zoneinfo/leapseconds' as time zone. Skipping it.
 Warning: Unable to load '/usr/share/zoneinfo/tzdata.zi' as time zone. Skipping it.
 Warning: Unable to load '/usr/share/zoneinfo/zone.tab' as time zone. Skipping it.
 Warning: Unable to load '/usr/share/zoneinfo/zone1970.tab' as time zone. Skipping it.
 2022-07-12 19:14:05+02:00 [Note] [Entrypoint]: Creating database elabftw
 2022-07-12 19:14:05+02:00 [Note] [Entrypoint]: Creating user elabftw
 2022-07-12 19:14:05+02:00 [Note] [Entrypoint]: Giving user elabftw access to schema elabftw

 2022-07-12 19:14:05+02:00 [Note] [Entrypoint]: Stopping temporary server
 2022-07-12T17:14:05.792537Z 13 [System] [MY-013172] [Server] Received SHUTDOWN from user root. Shutting down mysqld (Version: 8.0.29).
 2022-07-12T17:14:08.130313Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.29)  MySQL Community Server - GPL.
 2022-07-12 19:14:08+02:00 [Note] [Entrypoint]: Temporary server stopped

 2022-07-12 19:14:08+02:00 [Note] [Entrypoint]: MySQL init process done. Ready for start up.

 2022-07-12T17:14:09.053252Z 0 [Warning] [MY-010918] [Server] 'default_authentication_plugin' is deprecated and will be removed in a future release. Please use au                thentication_policy instead.
 2022-07-12T17:14:09.053270Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.29) starting as process 1
 2022-07-12T17:14:09.060015Z 1 [System] [MY-013576]
alexander-haller
@alexander-haller
and elabctl status
besselfunct
@besselfunct

      _          _     _____ _______        __
  ___| |    __ _| |__ |  ___|_   _\ \      / /
 / _ \ |   / _| | '_ \| |_    | |  \ \ /\ / /
|  __/ |__| (_| | |_) |  _|   | |   \ V  V /
 \___|_____\__,_|_.__/|_|     |_|    \_/\_/


Using elabctl configuration file: using default values (no config file found)
Using elabftw configuration file: /etc/elabftw.yml
---------------------------------------------
 Name                Command                  State                      Ports
----------------------------------------------------------------------------------------------
elabftw   /init                            Up (healthy)   0.0.0.0:443->443/tcp,:::443->443/tcp
mysql     docker-entrypoint.sh --def ...   Up             3306/tcp, 33060/tcp
alexander-haller
@alexander-haller
now try elabctl initialize ?
besselfunct
@besselfunct
elabctl initialize was successful this time, but I'm not sure if it's because I removed zfsutils-linux
I retried the installation with zfsutils-linux installed and it was successful again, using the default data locations
alexander-haller
@alexander-haller
the default data locations are on ext4 I assume?
besselfunct
@besselfunct
Yes
alexander-haller
@alexander-haller
well my guess is you hit the above bug with zfs - not 100% sure since I do have little experience with zfs myself
besselfunct
@besselfunct
Yeah, it looks like this is a ZFS issue.
I'm not certain how to proceed from here though. I like using ZFS because of the redundancy, and expanding a zpool is trivial
If I can't use ZFS, I'm going to have to figure out another file system, or hunt down a hardware raid solution
alexander-haller
@alexander-haller
there seems to be a bugfix:
because this is does affect mysql on zfs I would assume it will get pushed quickly for ubuntu
besselfunct
@besselfunct
Yeah, it looks like 2.1.5 will fix the issue and I'm running 2.1.4
alexander-haller
@alexander-haller
I'm off for today - if you have more infos note them here. It's always good for the community to have this feedback
besselfunct
@besselfunct
@alexander-haller Many many thanks for helping me nail down this issue. I'm familiar with *NIX systems, but docker and containerization technologies are a complete black box to me. I just need to get this working so I can finish my PhD thesis
Nicolas CARPi
@NicolasCARPi
I love it when community takes over support and I can just sit back and watch issues get resolved. Thanks @alexander-haller ;)
nmontua
@nmontua
Hi. I tried to update to the most current version, but I get an error about incorrect time format that is not covered by any Github issue etc. as far as I have found. The db:update command throws the following error: SQLSTATE[22007]: Invalid datetime format: 1292 Incorrect datetime value: '0
000-00-00 00:00:00' for column 'datetime' at row 1
Is there a way to roll back to a previous version?
nmontua
@nmontua
I did that, thank you for the link, however not when I run docker exec -it elabftw bin/console db:update, I get a different error :(
SQLSTATE[42S02]: Base table or view not found: 1146 Table 'elabftw.notifications' doesn't exist
nmontua
@nmontua
I have rolled back for now. Maybe I will have time to play around some more at a later date
Nicolas CARPi
@NicolasCARPi
the notifications table is created in schema70.sql, I don't see how it could have been skipped
also if you want support please open a proper github issue with all information so it's easier to debug
nmontua
@nmontua
Absolutely, if on my next attempt this occurs again, I will make a proper github issue. Thank you for your time.
nmontua
@nmontua
Okay, I tried again and this time everything worked fine. Again, I followed the instructions you linked, only this time I did not do "After, manually run the last lines of schema71:". Thats the only thing I did differently really. In any case, happy it worked and thank you for the troubleshooting guide.
Nicolas CARPi
@NicolasCARPi
ok cool
HClO4
@HClO4
I'm just trying to set up a elabftw instance on a Kubuntu VM to test the utf8 stuff prior to the update to 4.3.x. Did elabctl install and elabctl start but all I get is "ERROR: The Compose file '/etc/elabftw.yml' is invalid because:
services.web.depends_on contains an invalid type, it should be an array" with the last command. What is wrong?
Nicolas CARPi
@NicolasCARPi
@HClO4 you are asking what is wrong but you are not showing that part of your config file! So it's hard to say. Does it look exactly like this? https://github.com/elabftw/elabimg/blob/1338801d49fdd3c4ac8e71f58cc5b64b04799235/src/docker-compose.yml-EXAMPLE#L26-L28 If yes, upgrade your docker-compose version.
Nicolas CARPi
@NicolasCARPi
also note that it's perfectly fine to simply remove this part that is causing problem
taitlab
@taitlab
Hello! Silly question - how can I resize a picture in Markdown mode? I think I've done it before, but I forgot the syntax :)
Nicolas CARPi
@NicolasCARPi
You can't (AFAIK)
4 replies
plasmapper
@plasmapper
Hello everyone! I don't know if anyone here is using LabVIEW, but just in case I've made a LabVIEW client library for eLabFTW using API v1 documentation and testing it on https://demo.elabftw.net.
Nicolas CARPi
@NicolasCARPi
@plasmapper that's super cool! I'll add the link to the README once my tree is clean ;)
plasmapper
@plasmapper
@NicolasCARPi By the way. There is one thing that I couldn't do when I played with the API. When I try to set the experiment date using POST experiments/id with date=YYYYMMDD it always changes to current day. I tried other datetime formats with the same result. Changing body and title however works just fine. Do you know what the issue might be?
Nicolas CARPi
@NicolasCARPi
@plasmapper interestingly, this issue has been reported to me this morning and fix shortly after: elabftw/elabftw@8d778e5
it will be part of the next patch release
plasmapper
@plasmapper
Great! Thanks.
Nicolas CARPi
@NicolasCARPi
alexander-haller
@alexander-haller
I did the update to 4.3.9 but it still shows "Installed version: 4.3.8"
elabctl update said "Found latest release: 4.3.9" and pulled the images
in the logs I find "d41elabimg: info: eLabFTW version: 4.3.8"
any idea?
Nicolas CARPi
@NicolasCARPi
my bad, fault in the release process