Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 06:09
    MarcelBolten opened #3837
  • 05:57

    MarcelBolten on marcel-search-enum

    use enum for fileds update comment (compare)

  • Oct 01 10:03

    NicolasCARPi on hypernext

    more apidoc (compare)

  • Oct 01 02:04
    CLAassistant commented #3836
  • Oct 01 02:04
    dependabot[bot] labeled #3836
  • Oct 01 02:04
    dependabot[bot] labeled #3836
  • Oct 01 02:04
    dependabot[bot] opened #3836
  • Oct 01 02:04

    dependabot[bot] on npm_and_yarn

    Bump @typescript-eslint/eslint-… (compare)

  • Oct 01 02:03
    CLAassistant commented #3835
  • Oct 01 02:03
    dependabot[bot] labeled #3835
  • Oct 01 02:03
    dependabot[bot] labeled #3835
  • Oct 01 02:03

    dependabot[bot] on npm_and_yarn

    Bump eslint from 8.23.0 to 8.24… (compare)

  • Oct 01 02:03
    dependabot[bot] opened #3835
  • Oct 01 02:03
    CLAassistant commented #3834
  • Oct 01 02:03
    dependabot[bot] labeled #3834
  • Oct 01 02:03
    dependabot[bot] labeled #3834
  • Oct 01 02:03

    dependabot[bot] on npm_and_yarn

    Bump stylelint from 14.11.0 to … (compare)

  • Oct 01 02:03
    dependabot[bot] opened #3834
  • Oct 01 02:03
    CLAassistant commented #3833
  • Oct 01 02:03
    dependabot[bot] labeled #3833
nmontua
@nmontua
Okay, I tried again and this time everything worked fine. Again, I followed the instructions you linked, only this time I did not do "After, manually run the last lines of schema71:". Thats the only thing I did differently really. In any case, happy it worked and thank you for the troubleshooting guide.
Nicolas CARPi
@NicolasCARPi
ok cool
HClO4
@HClO4
I'm just trying to set up a elabftw instance on a Kubuntu VM to test the utf8 stuff prior to the update to 4.3.x. Did elabctl install and elabctl start but all I get is "ERROR: The Compose file '/etc/elabftw.yml' is invalid because:
services.web.depends_on contains an invalid type, it should be an array" with the last command. What is wrong?
Nicolas CARPi
@NicolasCARPi
@HClO4 you are asking what is wrong but you are not showing that part of your config file! So it's hard to say. Does it look exactly like this? https://github.com/elabftw/elabimg/blob/1338801d49fdd3c4ac8e71f58cc5b64b04799235/src/docker-compose.yml-EXAMPLE#L26-L28 If yes, upgrade your docker-compose version.
Nicolas CARPi
@NicolasCARPi
also note that it's perfectly fine to simply remove this part that is causing problem
taitlab
@taitlab
Hello! Silly question - how can I resize a picture in Markdown mode? I think I've done it before, but I forgot the syntax :)
Nicolas CARPi
@NicolasCARPi
You can't (AFAIK)
4 replies
plasmapper
@plasmapper
Hello everyone! I don't know if anyone here is using LabVIEW, but just in case I've made a LabVIEW client library for eLabFTW using API v1 documentation and testing it on https://demo.elabftw.net.
Nicolas CARPi
@NicolasCARPi
@plasmapper that's super cool! I'll add the link to the README once my tree is clean ;)
plasmapper
@plasmapper
@NicolasCARPi By the way. There is one thing that I couldn't do when I played with the API. When I try to set the experiment date using POST experiments/id with date=YYYYMMDD it always changes to current day. I tried other datetime formats with the same result. Changing body and title however works just fine. Do you know what the issue might be?
Nicolas CARPi
@NicolasCARPi
@plasmapper interestingly, this issue has been reported to me this morning and fix shortly after: elabftw/elabftw@8d778e5
it will be part of the next patch release
plasmapper
@plasmapper
Great! Thanks.
Nicolas CARPi
@NicolasCARPi
alexander-haller
@alexander-haller
I did the update to 4.3.9 but it still shows "Installed version: 4.3.8"
elabctl update said "Found latest release: 4.3.9" and pulled the images
in the logs I find "d41elabimg: info: eLabFTW version: 4.3.8"
any idea?
Nicolas CARPi
@NicolasCARPi
my bad, fault in the release process
alexander-haller
@alexander-haller
I suspected the branch in elabimg was strange - thanks for the quick fix @NicolasCARPi
Nicolas CARPi
@NicolasCARPi
FYI: it's this line that needs to be changed for a new version: https://github.com/elabftw/elabimg/blob/master/Dockerfile#L114
alexander-haller
@alexander-haller
and happy sysadminday to all of us ;-)
Nicolas CARPi
@NicolasCARPi
oh yeah it's today! :)
alexander-haller
@alexander-haller
we got ice cream - that's how I noticed
Nicolas CARPi
@NicolasCARPi
ahah
make sure to share some with the hardware!
alexander-haller
@alexander-haller
:ice_cream: --> :computer:
Nicolas CARPi
@NicolasCARPi
@MarcelBolten I think this would be nice to implement once the link to experiment stuff is merged: https://github.com/elabftw/elabftw/issues/539#issuecomment-833675094
alexander-haller
@alexander-haller
elabctl update still says "Found latest release: 4.3.8" it however correctly identifies itself as "Latest version: 4.3.9"
Nicolas CARPi
@NicolasCARPi
ok it's fixed
the release was a draft on github/elabimg
so curl -s https://api.github.com/repos/elabftw/elabimg/releases/latest | jq -r ".tag_name" would return incorrect release
alexander-haller
@alexander-haller
:+1:
besselfunct
@besselfunct
Trying to install with elabctl today and I get an error manifest not found and it's trying to pull 4.3.10
I edited the /etc/elabftw.yml so that it's pulling 4.3.9, and it seems to have worked
Sorry, the error is manifest unknown
besselfunct
@besselfunct
Also, big thanks to @alexander-haller. I had to swap distros to get zfsutils-linux 2.1.5, but it's now working for me.
Nicolas CARPi
@NicolasCARPi
okay, got it, that's because I pushed the tag BEFORE pushing the commit, so it grabbed the wrong version!
probably some room for improvement in the workflow... anyway, new one is building: https://github.com/elabftw/elabimg/runs/7662749205?check_suite_focus=true
alexander-haller
@alexander-haller
@besselfunct thanks and glad to hear that :-)
alexander-haller
@alexander-haller
@NicolasCARPi root@elabftw-dev:~# curl -s https://api.github.com/repos/elabftw/elabimg/releases/latest | jq -r ".tag_name"
4.3.8
Marcel
@MarcelBolten
@NicolasCARPi, @alexander-haller 4.3.9 and 4.3.10 are drafts
Nicolas CARPi
@NicolasCARPi
fixed!
btw apiv2 is really taking shape, it'll be great once it's done, it allows deleting a lot of old ugly working code and replace it with fancy buggy code ^^
also, now you can directly access /api/v2/experiments/42 and get the json back in the browser
once I get things sorted out a bit better I'll post on the github discussion the current design