These are chat archives for elemental/chat

18th
Nov 2016
Jack Poulson
@poulson
Nov 18 2016 05:15
all of those routines seem to be calling El::Display
what is the OTHER_FAULT error and is it reproducible?
Ryan H. Lewis
@rhl-
Nov 18 2016 05:43
its something with Qt5
and I can’t figure it out
and its repro. in the sense that it keeps happening on the build slave
but I cant make these errors occur locally.
its something about the DISPLAY
i pasted the stacktrace above
Jack Poulson
@poulson
Nov 18 2016 15:47
I vote that we disable Qt5 for that build
it isn't all that important
AH, I know the problem
SimpleSVD is the only driver that isn't propagating the command-line flags into El::Initialize
I had written that example specifically so that it would fit on one slide
it would be pretty safe to just delete that example driver
Jack Poulson
@poulson
Nov 18 2016 16:00
I went ahead and deleted it
Ryan H. Lewis
@rhl-
Nov 18 2016 16:22
thats cool.
Jack Poulson
@poulson
Nov 18 2016 16:39
pdebuild now makes substantial progress within the trunk (assuming there are no build subdirectories)
Ryan H. Lewis
@rhl-
Nov 18 2016 16:45
:)
can you check the error messages in the tests
"
142: deltaLower=0.5
142: Process 0 caught error message:
142: Deep insertion requires delta > 1/2 for handling dependence"
that failure is before your removal of SimpleSVD
but im not sure what these timeouts are all about
hm. it seems that one actualyl passed..
142/142 Test #134: Examples/matrices/Walsh ...............................*Timeout 1500.01 sec
Optional arguments:
--order [int,4,4,NOT found]
generate 2^k x 2^k matrix
--binary [bool,0,0,NOT found]
binary data?
--display [bool,1,1,NOT found]
display matrix?
--print [bool,0,0,NOT found]
print matrix?
Out of 0 required arguments, 0 were not specified.
Out of 4 optional arguments, 4 were not specified.
whats with that
is that all Qt5 ?
Ryan H. Lewis
@rhl-
Nov 18 2016 16:50
oh, do I need to pass —display=False ?
i think —display should default to False
walsh has it defaulted to true.
Jack Poulson
@poulson
Nov 18 2016 16:52
I just modified examples/number_theory/ZDependenceSearch.cpp to not default to using deep insertion LLL
Ryan H. Lewis
@rhl-
Nov 18 2016 16:53
it looks like all the timeouts are because of Qt5
the —display = True thing is set
im going to set —display = False and —print = True
and issue a PR
is that ok?
Jack Poulson
@poulson
Nov 18 2016 16:54
yes, though the question is whether or not the Qt5 actually works
Ryan H. Lewis
@rhl-
Nov 18 2016 16:54
:)
someone can submit a bug then!
Jack Poulson
@poulson
Nov 18 2016 16:54
...
Ryan H. Lewis
@rhl-
Nov 18 2016 16:54
id rather fix it :)
im interested in that..
Jack Poulson
@poulson
Nov 18 2016 16:56
I have to run, but I have pdebuild running after:
  1. Checking out a fresh copy of Elemental
  2. Renaming the folder to elemental_0.87.orig and then deleting the .git subfolder
  3. creating elemental_0.87.orig.tar.gz
  4. cd'ing into the folder and running pdebuild (followed by needing to type sudo password)
Ryan H. Lewis
@rhl-
Nov 18 2016 16:57
elemental/Elemental#194
if you dont mind merging this PR before you run
@poulson that sounds like a good start. we can setup a PPA team thing and try and run it on the ubuntu slaves and see what happens
Jack Poulson
@poulson
Nov 18 2016 16:59
sigh, the MPI compilers weren't properly found, but that should be an easy fix (assuming there is an easy way to distinguish the OpenMPI and MPICH compiler wrappers)
also, merged
Ryan H. Lewis
@rhl-
Nov 18 2016 17:15
great, thanks
im hoping we can finish off the RPM review today..
Ryan H. Lewis
@rhl-
Nov 18 2016 23:32
The latest rpm spec is looking great!