Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    andre-lx
    @andre-lx
    Oh ok then, I was actually expecting that answer ahah I will try the make. But without the istio solved, maybe I need to downgrade to kubeflow 1.3.1 for now, and wait for the fixes. Thank you so much for all the help and for your work
    Patrick Titzler
    @ptitzler
    Just confirmed that the auth fix will be included
    Alan Chin
    @akchinSTC
    Hello!
    Elyra 3.2.1 has just been published to PyPi.
    Change log with bug fixes available here: https://elyra.readthedocs.io/en/stable/getting_started/changelog.html#release-3-2-1-10-18-2021
    Container images to follow shortly...
    andre-lx
    @andre-lx
    Hey guys, trying to install the 3.1.1 version , but I always get this error as soon I open the jupyterlab: Endpoint elyra/schemaspace not found.I already installed the elyra[all]==3.1.1 , and made the jupyterlab build and verify all with the jupyter commands that the extensions are installed and enabled. I have a previous docker image, and that image is working, this is only failing in new builds
    andre-lx
    @andre-lx

    https://github.com/elyra-ai/elyra/compare/v3.1.1...v3.2.1#diff-d0e5e5d4b31372d3dad3a0c68e167de16dd4c10ce9bd340631d4503bacd55c20R42

    looks like, even with the installation of old versions, he pull the server from the most recent versions. In this example the error talks about schemaspace where in version 3.1.1 is namespace

    Kevin Bates
    @kevin-bates
    Hi @andre-lx - I agree with your analysis. Schemaspaces were not introduced until 3.2. This sounds like a packaging/configuration SNAFU with the frontend packages. Had you installed 3.2* prior to this? Perhaps these things are cached somehow, somewhere? Sorry, I don’t know the frontend deployment specifics enough to help here. cc: @ajbozarth
    Patrick Titzler
    @ptitzler
    @andre-lx can you please open an issue? @kevin-bates 3.2.x is causing authentication issues in his environment and we are currently troubleshooting
    Kevin Bates
    @kevin-bates
    :+1:
    andre-lx
    @andre-lx
    yes I will do that later on. Thanks
    andre-lx
    @andre-lx
    issue is open. thanks guys.
    Alex Bozarth
    @ajbozarth
    @andre-lx I just followed up on the issue you opened
    Patrick Titzler
    @ptitzler
    The issue has been resolved for 3.0 and 3.1 releases and patches are now available.
    Lucas A. Bonini
    @lbonini94

    Hello guys,

    Is there any way to authenticate ml-pipeline via Elyra's UI running inside GCP (kubeflow full deployment)? (client_id, other_client_id, other_client_secret)

    https://www.kubeflow.org/docs/distributions/gke/pipelines/authentication-sdk/#connecting-to-kubeflow-pipelines-in-a-full-kubeflow-deployment

    Attempting to connect via kubernetes service (http://ml-pipeline.kubeflow:8888) is returning api header errors.

    Patrick Titzler
    @ptitzler
    Hi Lucas, unfortunately this is currently not possible. Starting with Elyra 3.3 (available soon) we are geadually adding support for more authentication providers
    Alan Chin
    @akchinSTC
    Hello All!
    Elyra 3.3.0 RC0 has just been published to PyPi.
    Change log with new features and bug fixes available here: https://elyra.readthedocs.io/en/latest/getting_started/changelog.html#release-3-3-0rc0-11-17-2021
    Piotr
    @pplonski
    Hi! I just found Elyra, looks very cool! Are there any plans to release it as desktop app?
    Do I need to install JUpyterlab first, and then Elyra extensions?
    Alan Chin
    @akchinSTC
    @pplonski - Hi, we currently dont have any plans to release Elyra as a desktop app atm, but please feel free to open up a discussion or issue for it! To install Elyra you dont need to have JL installed first, we pull it in as a dependency, installation instructions are here: https://github.com/elyra-ai/elyra#installation
    Patrick Titzler
    @ptitzler
    Piotr
    @pplonski
    Thank you!
    Alan Chin
    @akchinSTC
    Hello All!
    Elyra 3.3.0 RC1 has just been published to PyPi.
    Change log with new features and bug fixes available here: https://elyra.readthedocs.io/en/latest/getting_started/changelog.html#release-3-3-0rc1-11-30-2021
    harish-gaggar-infra
    @harish-gaggar-infra
    Hi, Trying Elyra in Jupyterlab first time, Is there any document how to use Google Cloud Object Storage in Apache Airflow Runtime Configuration in Elyra?
    20 replies
    Patrick Titzler
    @ptitzler
    Work has started for the 3.4 release with a tentative release date of 12/17/21. This should be the last release of the year
    Alan Chin
    @akchinSTC
    Hello All!
    Elyra 3.3.0 has just been published to PyPi.
    Change log with new features and bug fixes available here: https://elyra.readthedocs.io/en/latest/getting_started/changelog.html#release-3-3-0-12-03-2021
    Patrick Titzler
    @ptitzler
    Yaaaay
    lucasbmiguel
    @lucasbmiguel
    Hi all, I am trying to add my own pipeline components repository to elyra, via jupyter lab. I cloned the base source and tried to configure it with the Directory option. Things are not working as expected and I am having a hard time finding the logs, could someone point me where I can see elyra logs?
    Luciano Resende
    @lresende
    @lucasbmiguel what version of Elyra are you using?
    the new 3.3.0 has the ability to bring your own catalog and is much easier to implement this
    lucasbmiguel
    @lucasbmiguel
    3.2.3
    I can upgrade to 3.3.0 if that's the case
    Luciano Resende
    @lresende
    lucasbmiguel
    @lucasbmiguel
    thanks a ton
    Luciano Resende
    @lresende
    let us know if you still have problems after that… but I just configured one in 3.3.0 yesterday and it worked ok right on the first time.. :)
    lucasbmiguel
    @lucasbmiguel
    it worked! :)
    Luciano Resende
    @lresende
    great
    Patrick Titzler
    @ptitzler
    awesome! Are you using Kubeflow Pipelines or Apache Airflow?
    Patrick Titzler
    @ptitzler
    The version 3.3 blog post is now live at https://medium.com/ibm-data-ai/elyra-3-3-pipelines-custom-components-and-catalogs-74cf198fdf48?source=friends_link&sk=ef91a56fbbae97bbaea77ff169d549dd (only this "friends" link guarantees free access on medium)
    Alexis Canizares
    @alexisc67
    Hello! Found this community, hope to exchange some comments and questions.
    Patrick Titzler
    @ptitzler
    Welcome!
    Alexis Canizares
    @alexisc67
    This message was deleted
    We are trying out Elyra v3.3.0 in Azure Kubernetes Service (AKS), running on Kubeflow Notebook Server and Argo. Our storage is minio. It looks great:
    Two things we had to do, which may be related to our environment but want to share:
    1. We had to make sure environment variables exist in the environment for the storage, so, variables AWS_ACCESS_KEY_ID and AWS_SECRET_ACCESS_KEY
    2. Argo client was failing to get proper cookies here https://github.com/elyra-ai/elyra/blob/master/elyra/pipeline/kfp/processor_kfp.py#L133-L139.
      We have patched this part to use
      client = ArgoClient()
      which works. We will do more testing and add notes in Github Issues if necessary.
    7 replies
    Patrick Titzler
    @ptitzler
    We are aiming for a 3.4.0 release candidate build on Wednesday 12/15
    3 replies
    Alexis Canizares
    @alexisc67
    Great!
    Alan Chin
    @akchinSTC
    Hello All!
    Elyra 3.4.0rc0 has just been published to PyPi. https://pypi.org/project/elyra/3.4.0rc0/
    Change log with new features and bug fixes available here: https://elyra.readthedocs.io/en/latest/getting_started/changelog.html#release-3-4-0rc0-12-15-2021
    3 replies
    Alexis Canizares
    @alexisc67
    Hi, I am migrating some kubeflow kale pipelines to Elyra. For some runtime images I am getting the following error before running the first step in the flow:
    mkdir ./jupyter_work_id/ permission denied.
    Meaning the initial commands can't be executed in the pod. I have not been able to find what is different in these images. If you found something similar please share.
    I am using Kubeflow 1.4 with Kale, Argo and Elyra 3.3.0 running in Kubeflow Notebooks. Running in AKS.
    12 replies
    Karla Spuldaro
    @karlaspuldaro
    Hi all,
    As per today's announcement, Elyra community meetings on Dec 23rd and 30th have been cancelled.
    Happy Holidays!
    Alan Chin
    @akchinSTC
    Hello All!
    Elyra 3.4.0 has just been published to PyPi. https://pypi.org/project/elyra/3.4.0/
    Change log with new features and bug fixes available here: https://elyra.readthedocs.io/en/latest/getting_started/changelog.html#release-3-4-0-12-17-2021
    Thanks to all our internal and external contributors this year!!
    Wishing you all Happy Holidays and a wonderful New Year!!!
    5 replies
    colomblanc
    @colomblanc
    Hi! I am new to using JupyterLab. I wanted to start using it because I read that it allows me to use R if I use Elyra. I tried installing Elyra, but the build failed. The device I am installing it on is a raspberry pi 4 B with Home Assistant. Does anyone know if I need to do anything to make this work? My problem seem to be a general one for anyone using a Home Assistant with Raspberry pi as the Home Assistant is fleshly setup.
    Kevin Bates
    @kevin-bates
    Hi @colomblanc. FWIW, you should be able to use an R kernel directly from Jupyter Lab (w/o Elyra) but I wonder if you’d run into similar issues since you’re using raspberry pi. I don’t have any experience with raspberry pi or Home Assistant, but I suspect @dcmartin might, so I’m including him here.
    2 replies
    Alan Chin
    @akchinSTC
    Hello All!
    Elyra 3.5.0 has just been published to PyPi.
    Change log with new features and bug fixes available here: https://elyra.readthedocs.io/en/latest/getting_started/changelog.html#release-3-5-0-01-21-2022