Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Rob Williams
    @codeslubber_twitter
    I installed ensime into atom and it's there, shows up in packages, but there is no settings button??
    Rob Williams
    @codeslubber_twitter
    wow what a waste of time, installed it, the plugin, got it to generate the .ensime file, then starting it inside Atom failed, as the update failed..
    looks like a lot of other victims: ensime/ensime-atom#286
    Rob Williams
    @codeslubber_twitter
    ensime/ensime-atom#249
    Rob Williams
    @codeslubber_twitter
    wow that 286 bug thread is a treatise on the horrors of open source.. sorry if you fell into our pit and lost a ton of time, but our crappy tests made me scared to push a release 6 months ago is the gist of it.. ?
    strangely, the .ensime file does not have 1.0.0 as the server version.. nutty...
    Rob Williams
    @codeslubber_twitter
    damn the answer was just a few lines up thanks @djoepramono ...
    Rob Williams
    @codeslubber_twitter
    so here's something crazy, had ensime setup on a project, went back to IntelliJ to get some stuff done, and ran analyze, intellij went bananas chewed the CPU for a while then just froze, looked down it was rummaging through the ensime cache.. but it never came out, never showed up as hung.. had to force quit it...
    John Langley
    @langley
    Last week at work, I ran into a problem where I forgot to go into settings and set the ensimeServerVersion to 2.0.... wasted some time because I a) forgot to do this and b) got puzzled about what the "server update" log was telling me. So I decided to "do the right thing" and create a pull request. However, I have a couple of questions related to that.
    John Langley
    @langley
    Never mind, I just created a pull request for the change. Thanks for all the hard work in creating and maintaining ensime-atom
    Simon Kaltenbacher
    @simonkaltenbacher

    Hello,

    can anyone help me with getting ensime to work with cats? Using sbt the project compiles just fine, but ensime is showing some errors for the project.

    There was already some discussion about this topic in issue #1525. However the information provided there did not help me.

    Ghost
    @ghost~540393fe163965c9bc2018ce
    @/all I raised a PR to delete the LSP implementation from the server. Join the discussion here if you are a contributor who agrees, or objects and is willing to maintain this part of the codebase ensime/ensime-server#1918
    Arkadiy Kukarkin
    @parkan_twitter
    hello, I'm having a lot of trouble getting ensime to work with atom: I installed the latest atom package, added the sbt plugin, generated configuration, provided paths, specified ensime server version (2.0.0), etc and Ensime Start does pop up a classpath resolution window followed by "Ensime connected!" green bubble, but then nothing else works
    the weird thing is that it does seem to connect to something -- trying to Ensime Start again gives an error, but you can Ensime Stop and it'll turn off (and trying Ensime Stop again will also generate an error)
    I can't find any instructions for locating the server.log file in the docs
    aha it's in .ensime_cache
    seems to have trouble opening a jar file?
    Arkadiy Kukarkin
    @parkan_twitter
    hmm blew away ivy cache, commons-beanutils-core-1.8.0-sources.jar redownloaded but it's still 0 bytes
    Arkadiy Kukarkin
    @parkan_twitter
    looks like it fails to download some javadocs and source jars and then throws when it tries to open the empty zip?
    Fernando
    @nandotorterolo
    ![alt](https://imgur.com/a/VNQxw)
    Hi, linter shows me an error, and dont know how to report it. could you assist me? (and dont know how to post an image :) )
    matanster
    @matanster
    what are actually my chances of ensime-atom working on an arbitrary project?
    just tried on two projects, in both cases I either got an error message or could not see any of its features operating after starting the ensime server through atom
    just curious

    When starting the ensime server:

    Error: org.ensime:ensime_2.12:1.0.0 not found ....

    matanster
    @matanster
    Whereas in the other project, it starts without errors, but none of the features seem to make themselves evident
    matanster
    @matanster
    My project's scala version is 2.12.4
    sbt ensimeConfig went fine
    matanster
    @matanster
    Oh well, fiddling the ensime server version to 2.0.0 in atom settings solved it
    Thanks for maintaining this very useful package!
    matanster
    @matanster
    Hey thanks for ensime-atom, it's really nice ā€• easy to stop/start when there's small bugs, and not a huge monolith like ScalaIDE and stuff
    Jean-Julien ALVADO
    @jjalvado
    Hello everyone. Juste installed and configure ensime for atom
    typechecking is iworking great
    but I have problme with auto import and completion
    with completion, the name of the availables methods are displayes but the method sighature is not
    and when I ubknown object
    no import is proposed to me
    any idea why?
    thanks a lot for your help
    Ryan Zeigler
    @rzeigler
    Is there anyway to jump across source units for declaration? I.e. to the definition of a type omewhere else?
    I tried cmd clicking like I do for things in the ame file and I get an error banner about no declPos in response.
    Eliot Hills
    @elhil
    hey all, new to scala and ensime šŸ˜… anyone mind sharing their debugging / testing workflow? Iā€™m really resistant to the idea of switching to a full-blown IDE just for one language. and is there an effort I can contribute to for bringing breakpoints to ensime-atom?
    Marcin Mielniczuk
    @marmistrz
    Hi! I can't get ensime working with Atom. I've changed the config to use ensime 2.0.0, it updated successfully. Now I get the following error in developer tools: https://pastebin.com/kHnWMae4
    Marcin Mielniczuk
    @marmistrz
    After nuking .ensime_cache and possibly other output directories the problem is gone ;)
    Benny Thompson
    @bennythomps
    seems like ensime-atom is having a hard time seeing implicits in scope, is this a known problem?
    Harmeet Singh(Taara)
    @harmeetsingh0013
    Hey Team, I am using ensime with Atom, and want to know, what is the short of autoimport statements in scala file like other IDE scala or intellij
    Christopher Xu
    @ChristophorusX
    Hi all, I'm having a weird problem on ensime-atom. After updating the server successfully, the server is not connected by using ensime: start. Literally nothing happens and there is no warning messages. However, the vim version of ensime works just fine on the same project. Anyone knows the potential reason that causes this problem?
    scalaVersion: 2.12.4, ensime server version: 2.0.0-SNAPSHOT
    Tomas Svarovsky
    @fluke777
    Hello. Trying to give it a spin but during the server startup I get the following error. Any idea what it might be? https://pastebin.com/7pKXh79m