These are chat archives for ensime/ensime-atom

1st
Nov 2015
Richard Dallaway
@d6y
Nov 01 2015 10:20
@hedefalk Thanks for the quick turn around on 0.28.1 - working fine.
FYI I used it to search for a Java class (I know, why would I do that?) and managed to get an exciting error:
robots - Atom 2015-11-01 10-21-42.png
Hitting “Check for package updates” shows what I know: pakages are up to date.
Ah… it only seems to be when I search for a Java class file that’s being “managed” via ab SBT lib/ folder (is that unmanaged? Not sure what the phrase is). This is not a problem for me! Just an observation.
Richard Dallaway
@d6y
Nov 01 2015 10:35
I’ve logged what I see as #83 in case it’s of use
Richard Dallaway
@d6y
Nov 01 2015 11:48
I’ve been noodling this morning with fonts and colours :-) I found the errors and warinings a little bit tricky to read, but they are easy to fix.
In Atom > Your Stylesheet, I added the following:
.ensime-status {
  padding          : 0 0.6em 0 0.6em;
  color            : black;
}

.am-panel {
  font-size : larger;
}

.line-message div {
  color: black;
  padding          : 0 0.6em 0 0.6em;
  border-radius    : 3px;
}

.line-message div.highlight-error {
  background-color : red;
  color            : white;
}

.line-message div.highlight-warning {
  background-color : orange;
  color            : white;
}
…and now I get:
robots - Atom 2015-11-01 11-47-31.png
…which for me is better. Obviously I have zero taste in styles, but the above settings might be useful for others who want to tweek the look of Atom Ensime
Viktor Hedefalk
@hedefalk
Nov 01 2015 12:26
Could you PR the css too? Looks good to me.
Viktor Hedefalk
@hedefalk
Nov 01 2015 12:40
@d6y There's an ensime.less where we can put reasonable defaults.
Łukasz Młynik
@lmlynik
Nov 01 2015 13:15
hey all :) Sorry for a noobie question: I'm tinkering with Ensime-atom and the "GETTING STARTED" say Make sure to put path of sbt in settings. Which settings it refers too?
Arnout Engelen
@raboof
Nov 01 2015 13:17
@lmlynik find 'Ensime' under Edit -> Preferences -> packages and click Settings
Łukasz Młynik
@lmlynik
Nov 01 2015 13:20
cheers @raboof
Arnout Engelen
@raboof
Nov 01 2015 13:22
perhaps we should default to taking it from $PATH, though?
Viktor Hedefalk
@hedefalk
Nov 01 2015 15:54
@raboof @lmlynik Problem is node process of Atom doesn't have $PATH on OSX. That's why I had to add that setting.
When started as .app, $PATH doesn't work unfortunately.
Richard Dallaway
@d6y
Nov 01 2015 16:51
:point_up: November 1, 2015 12:40 PM ...done!
Viktor Hedefalk
@hedefalk
Nov 01 2015 17:02
Awesome! Published 0.29 with @d6y's styling.
Richard Dallaway
@d6y
Nov 01 2015 17:07
\o/