These are chat archives for ensime/ensime-atom

22nd
Feb 2016
Matt Feury
@mattfeury
Feb 22 2016 19:58
hi team. i'm trying to get ensime running with atom, and running into a dead end. whenever i run "ensime: start", it appears as if nothing happens. i see no "full typecheck finished" and i see none of the "goodies" in my editor
the first time i did ensime: start, it did do an update, and everything looked fine
Viktor Hedefalk
@hedefalk
Feb 22 2016 21:26
@mattfeury Can you look at [PROJECT]/.ensime_cache/server.log if you find anything interesting? Also, check if you see anything in the atom logs (cmd-shift-L on Mac to bring up chrome dev tools). There are transaction logs there outgoing/incoming messages.
Matt Feury
@mattfeury
Feb 22 2016 21:33
@hedefalk thanks for getting back. this is my entire server.log, which seems interesting to me
Error: Could not find or load main class org.ensime.server.Server
Viktor Hedefalk
@hedefalk
Feb 22 2016 21:33
Yes, seems like Ensime server didn’t start at all.
Matt Feury
@mattfeury
Feb 22 2016 21:34
any idea why that might be?
Viktor Hedefalk
@hedefalk
Feb 22 2016 21:34
Ok, so, then you should look in ~/.atom/packages/Ensime or similar if you’re not on nix after a file called classpath
Matt Feury
@mattfeury
Feb 22 2016 21:35
i see a classpath_2.11.7_0.9.10-SNAPSHOT in there
Viktor Hedefalk
@hedefalk
Feb 22 2016 21:35
Can you open a ticket on github and paste the contents? Easier to track there.
Matt Feury
@mattfeury
Feb 22 2016 21:36
ok sure
here it is @hedefalk: ensime/ensime-atom#184
thanks for the help thus far. let me know if you have any ideas!