These are chat archives for ensime/ensime-atom

27th
May 2017
Ghost
@ghost~540393fe163965c9bc2018ce
May 27 2017 13:58
@ZizhengTai
This is the ensime-atom room
How come you thought the default version is 1.0.0? Is atom still using its own launcher?
2
2.0.0-SNAPSHOT is better than M1
Zizheng Tai
@ZizhengTai
May 27 2017 14:02
Atom's default is still 1.0.0
I'm using the latest sbt-ensime and has set the ensime version in global.sbt but atom won't automatically pick it up
Ghost
@ghost~540393fe163965c9bc2018ce
May 27 2017 14:39
@hedefalk sounds like you need to release that experimental branch with the .ensime launcher :-)
@ZizhengTai remove that customisation, it'll break things later
Matthew Scharley
@mscharley
May 27 2017 22:36
i had to do the same thing - can't just remove it either otherwise nothing works
Ghost
@ghost~540393fe163965c9bc2018ce
May 27 2017 22:44
@mscharley update your sbt-plugin
oh hold on, I'm forgetting that the .ensime is not read by atom... instead bump the version to 2.0.0-SNAPSHOT
(bump the version in atom, however it does it)
have a look for hedefalk's feature branch of the client to see the code that launches the server from the .ensime jars
Matthew Scharley
@mscharley
May 27 2017 23:30
yeah, i did bump the version inside atom, but that's what i was saying - you have to do it there for now, you can't just remove that customisation :frowning: