These are chat archives for ensime/ensime-atom

4th
Sep 2017
Olivier Mélois
@Baccata
Sep 04 2017 10:16
Screen Shot 2017-09-04 at 10.09.07.png
:point_up: Hey guys, I'm trying to have Ensime work on Atom (version 1.19.5). I've generated a .ensime for my (hello-world) project using sbt-ensime 1.12.14, the ensime package in atom is properly configured to point to sbt and the ensime server version is set to 1.0.0. However, when I try to start the ensime-server from atom, this is what I get
Olivier Mélois
@Baccata
Sep 04 2017 10:23
Also followed http://ensime.org/editors/atom/troubleshooting/, I get the same result . Any idea what I'm doing wrong there (or how I could try and figure out what's wrong) ?
Jérémie Fraudeau
@jfraudeau
Sep 04 2017 12:22
Have you tried opening the developer tools in atom ? You could do that an then reload window (in the developer menu)
Olivier Mélois
@Baccata
Sep 04 2017 12:59
Failed to require the main module of 'Ensime' because it requires one or more incompatible native modules (fsevents).
Run apm rebuild in the package directory and restart Atom to resolve.
Tried rebuilding as advised, no luck
Olivier Mélois
@Baccata
Sep 04 2017 13:33
Oh right, figured it out : from Command Palette, opened "Incompatible Packages " view, it detected the faulty package and I could rebuild it from there ... that was rather unclear :/