Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 11:55

    eranif on master

    fixed: combobox: always use GUI… (compare)

  • 11:02
    uffejakobsen commented #2993
  • 10:54

    eranif on master

    fixed ctags for macOS (compare)

  • 10:43

    eranif on master

    fixed macOS to build codelite-c… (compare)

  • 10:12
    uffejakobsen opened #3001
  • 07:40

    eranif on master

    Properties Page: support headers (compare)

  • 05:37
    rlbxku1r edited #3000
  • 03:09
    sss123next commented #2998
  • 03:08
    sss123next commented #2998
  • 03:05
    sss123next commented #2998
  • May 18 19:14
    dghart commented #2998
  • May 18 19:06
    rlbxku1r synchronize #3000
  • May 18 18:57
    rlbxku1r opened #3000
  • May 18 07:52
    sss123next commented #2998
  • May 18 07:32
    sss123next commented #2998
  • May 18 06:43
    sss123next commented #2998
  • May 17 21:37

    eranif on master

    Added API to query a cell type … (compare)

  • May 17 19:38
    eranif commented #2988
  • May 17 17:36
    yzazik commented #2988
  • May 17 15:41
    dghart commented #2998
Piotr Cała
@Pioxis_gitlab
clangd in Language Server Settings are enabled
Eran Ifrah
@eranif
@Pioxis_gitlab have you tried 're-parsing' the workspace?
Piotr Cała
@Pioxis_gitlab
@eranif Yeah, and it's happened for the new one workspace too.
martynwheeler
@martynwheeler
Screenshot from 2021-02-13 22-48-25.png
Hi, I have just started with codelite and wxwidgets. I am having an issue with the generated code when I start a new project for Executable (wxWidgets + XRC Frame). The skeleton code compiles but when it is run it says "cannot load resources from '../gui.xrc'". The file is there and I have not done anything with the project. I am using 3.1.4 build of wxWidgets that I compiled on my machine.
martynwheeler
@martynwheeler
BTW, is XRC a good idea or is it better to create the gui from c++ code? Sorry for simple questions - just begiinng...
dghart
@dghart
@martynwheeler See my answer at https://forums.wxwidgets.org/viewtopic.php?f=19&t=48027&p=204202 You need to remove the '../'
XRC v. C++? It's a matter of personal choice. I've used both successfully.
martynwheeler
@martynwheeler
@dghart - thank you.
Separating code from design seems cleaner. But I guess it's whatever works...
dghart
@dghart
XRC is a distinct advantage for a non-C++ project e.g. wxPython
martynwheeler
@martynwheeler
I'm trying to hone my c++ skills - it is a lockdown project!
dghart
@dghart
and it was a good choice for me 15+ years ago when RADs were much less good
but nowadays it's so easy to generate C++ projects that it matters little.
martynwheeler
@martynwheeler
Yes, i am getting my head around wxcrafter - it is very different from visual studio!
dghart @dghart switched from Windows to Linux in 2003 so visual studio is off the menu
Piotr Cała
@Pioxis_gitlab
@eranif for the fresh installation of CodeLite completon is working fine. It looks like broken configuration. How to fix it without lost my configuration?
Piotr Cała
@Pioxis_gitlab
removing .codelite from home directory has no effect
Piotr Cała
@Pioxis_gitlab
Okay, I installed Ubuntu 20.10 too, and completing code is not working. It's something wrong with version for Ubuntu 20.10.
rraul1
@rraul1
Hey whats up, I have a problem that its getting me mad. When the Setup Wizard tells me to chose a font/them all of them look the same and the font is a normal black font, also when I continue and end the configuration CodeLite restarts and the Setup Wizard pops up again, any clue about how to fix it? Thx
https://i.ibb.co/gV72fns/codelite.png there's a screenshoot of what happens
I have installed MinGW on C:\MinGW and added to path C\MinGW\bin
Eran Ifrah
@eranif
@rraul1 try deleting this folder %appdata%\CodeLite%
rraul1
@rraul1
Still not working
Eran Ifrah
@eranif

@rraul1 this can happen if for some reason CodeLite is unable to write to this folder... you can tell CodeLite to write a different folder all it's settings by running it like this:

  • Open a CMD
  • Type: C:\Program Files\CodeLite\codelite.exe -d \path\to\writable\folder

if the above helps, you can edit the desktop shortcut with this command so you won't have to run it each time from the command line

diaodiao
@rain0706_rainyu_twitter
Hi, I'm wondering if anyone else is using the new Apple Silicon Mac and encountering this problem. I use codelite to code in C and everything works fine except for the Debugger. When I start the debugger it says "LLDB crashed! Terminating debug session." Is there any way to solve the problem?
Eran Ifrah
@eranif
@rain0706_rainyu_twitter is this the mac with the new processors? (arm based iirc)?
diaodiao
@rain0706_rainyu_twitter
@eranif yes that's right!
Eran Ifrah
@eranif
@rain0706_rainyu_twitter well, I am not sure how did you run CodeLite... but we don't provide a build for that processor. In general, code compiled on Intel based mac, can't run on M1 (which is basically an ARM processor). Did you compile CodeLite yourself?
diaodiao
@rain0706_rainyu_twitter
That's interesting... it runs perfectly fine. No, I actually downloaded the pre-built Codelite 15 for OSX 10.15
N.saicharan
@n_nsaicharan61_twitter
Hi all, iam facing an error when i try to debug with codelite --> No executable specified, use 'target exec' could you please help me here
N.saicharan
@n_nsaicharan61_twitter
hello can anyone please help me with the above question I could not able to debug in my codelite
Eran Ifrah
@eranif
@n_nsaicharan61_twitter Right click on your project settings -> program to Run / Debug, and make sure that whatever is in there, exists on your file system
N.saicharan
@n_nsaicharan61_twitter
@eranif : Currenlty i have $(outputfile) in the path you had mentioned, so may I know what does that $outputfile means ?
how can I check whether that is there in my file system
dghart
@dghart
@n_nsaicharan61_twitter Look at your Project Settings. For a simple executable project it will look something like https://img.vim-cn.com/23/79b430cea2020f17274f70658ec0001cf1b00a.png
You can see that $(outputfile) is defined in the 5th row, as $(IntermediateDirectory)/$(ProjectName)
You know what your Project name is. IntermediateDirectory is probably 'debug' or 'release'.
So you can check on your file system to see if there is such a filepath. If so, see if it runs outside CodeLite. If not, try building your project :p
dghart
@dghart
@MV487 Where should those undefined references be? In one of those libs, or somewhere else?
Ghost
@ghost~603e0a7f6da037398464e901
sorry i fixed the issue
dghart
@dghart
Good :)
N.saicharan
@n_nsaicharan61_twitter
@dghart : could you please elloborate more,
N.saicharan
@n_nsaicharan61_twitter
@dghart i can able to build the code but when i try to debug i could not able to debug
You mentioned that to check the path but in thatbscreenshot there is no path mentioned
dghart
@dghart
@n_nsaicharan61_twitter The path is where you stored the Project itself, plus $(IntermediateDirectory)
which for this project is $(ConfigurationName), which is 'SimpleExecutable'
BTW, When you build, the output should include something helpful, like:
Entering directory '/mnt/everythingelse/devel/CLworkspace/Misc/SimpleExecutable'
N.saicharan
@n_nsaicharan61_twitter
I could not solve the issue ... Is there any video presentation that i give to any one who can solve me this prpblem ?
dghart
@dghart
@n_nsaicharan61_twitter No, you need to write some information here:
What operating system are you using? Which CodeLite version?
What sort of project is this? One of the sample ones that CodeLite supplies?
If not, try one of those and see if that works
If it doesn't, what is its Path? Which compiler are you trying to use? Does it exist?
N.saicharan
@n_nsaicharan61_twitter
Iam using windows 10 operating system, Codelite 15 version
I am learning cpp from Udemy so I wanted to debug the compiled code to see the variables and calls