Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jun 16 21:45
    stale[bot] labeled #2710
  • Jun 16 21:45
    stale[bot] commented #2710
  • Jun 16 20:11

    eranif on master

    codelite-terminal: added new st… build warning fix on non linux … (compare)

  • Jun 16 19:22
    eranif labeled #2716
  • Jun 16 19:22
    stale[bot] unlabeled #2716
  • Jun 16 19:22
    eranif reopened #2716
  • Jun 16 17:49

    eranif on master

    fixed build with wxWidgets < 3.… more linux fixes (drawing, them… (compare)

  • Jun 16 16:51
    eranif commented #2758
  • Jun 16 16:26
    eranif commented #2759
  • Jun 16 16:22

    eranif on master

    code cleanup clButtonBase: use the parent's … Auto detech theme changes Make … (compare)

  • Jun 16 16:21
    eranif commented #2760
  • Jun 16 16:20
    eranif commented #2760
  • Jun 16 09:16

    eranif on master

    auto detech external theme chan… (compare)

  • Jun 16 09:12
    freanux opened #2760
  • Jun 16 08:05
    uffejakobsen edited #2759
  • Jun 16 08:05
    uffejakobsen edited #2759
  • Jun 16 08:03
    uffejakobsen opened #2759
  • Jun 16 06:40
    freanux opened #2758
  • Jun 15 15:36

    eranif on master

    updated rls docs (compare)

  • Jun 15 15:31
    eranif commented #2756
dghart
@dghart
Install Linux and live happily ever after ;)
I've not used Windows for a long time
N.saicharan
@n_nsaicharan61_twitter
wait i will try
dghart
@dghart
But I'm sure there is still a way to open a console
N.saicharan
@n_nsaicharan61_twitter
not sure how to run in console
dghart
@dghart
I expect google knows
N.saicharan
@n_nsaicharan61_twitter
You mean to run in the command line?
dghart
@dghart
Yes
N.saicharan
@n_nsaicharan61_twitter
yeah in the debug directory i opend the command prompt and run the .exe file
it is printing output as hello world
dghart
@dghart
Good. Now you are getting somewhere!
N.saicharan
@n_nsaicharan61_twitter
but when i try to keep the break point in the program inside codelite It is not stopping at the debug point
and exiting by no executable target exec
so how to solve inside codelite ?
dghart
@dghart
Are you trying to 'run' or to 'debug'?
N.saicharan
@n_nsaicharan61_twitter
i went to the debugger and slected start debugging
selected*
dghart
@dghart
Do you have a debugger installed? Which, and where?
What happens if you try to debug your program inside a console?
N.saicharan
@n_nsaicharan61_twitter
i installed mingw64 compiler
dghart
@dghart
That is a compiler, not a debugger
N.saicharan
@n_nsaicharan61_twitter
how to check whethere we have debugger ?
because i think the mingw 64 contains a debugger as well
gdb
dghart
@dghart
Ah, gdb is fine
So you need to run your program inside it
When you try to do that inside CodeLite, the Debugger pane should open
Does it? If so, what does it say?
If not, you probably need to tell CodeLite where your gdb.exe (?) can be found
N.saicharan
@n_nsaicharan61_twitter
how to run the program inside the gdb?
dghart
@dghart
But this is Windows stuff, and I cannot help you
N.saicharan
@n_nsaicharan61_twitter
yeah just now i have seen the gdb is configured to x86_64-w64-mingw32
how to inform codelite that this is the debugger?
dghart
@dghart
Look in your main Debugger Settings, or in your Project's Settings > Debugger
N.saicharan
@n_nsaicharan61_twitter
there is nothing present over there
N.saicharan
@n_nsaicharan61_twitter
is there any one who can help me with windows?
dghart
@dghart
There should be something there. Find where your gdb is, and put its filepath there.
N.saicharan
@n_nsaicharan61_twitter
i tried but its still not working
Eran Ifrah
@eranif
@n_nsaicharan61_twitter click the help button in the project settings dialog
N.saicharan
@n_nsaicharan61_twitter
Yeah i have checked
still its not working :(
KodiiSalai
@KodiiSalai
Hi, someone can help me with an issue with the workspace panel?
Piotr Cała
@Pioxis_gitlab

Hi, someone can help me with an issue with the workspace panel?

Describe your problem ;)

iwbnwif
@iwbnwif
Hi, I am getting back into coding after a year or so break and it's good to see all the updates to Codelite / wxCrafter - especially the use of wxDLG_UNIT etc. which has really improved the HiDPI experience.
I'm having a problem with persistence on dialogs and windows created with wxCrafter on Linux. Although a .test config file is being generated correctly, the windows are not restoring to the right size. I seem to remember there was something extra needed to get the instance registered, but can't remember it. Can anyone help?
dghart
@dghart
@iwbnwif Welcome back. When you say "the windows are not restoring to the right size", do you mean in your code, or the CodeLite dialogs etc?
If your code, maybe you need to use something like Plugin/windowattrmanager.h
If CodeLite, that is probably an intentional change made by eranif (I forget why).
iwbnwif
@iwbnwif
Thank you! Sorry for not being clear - it is in my code that is the problem (I haven't noticed in Codelite yet). I think wxWidgets has been buggy regarding persistence and Ubuntu Unity previously, but there have been some changes in the last year that look to have fixed that. The reason why am asking here is because I have one applet that works and one that doesn't and I cannot for the life of me find any difference.
The only point I have got to is that I regenerated the wxCrafter (running man in wxCrafter) output on the one that doesn't. I vaguely remember previously needing to set a name or something inside wxCrafter so that each instance (even a singleton) is uniquely identified. But this all seems to be okay. I have been debugging step by step to try to work this one out, but no luck so far and wanted to check if I am missing something obvious.
iwbnwif
@iwbnwif
Okay, I think I have worked out what is going on. wxCrafter generates some code: if(GetSizer()) {GetSizer()->Fit(this);} The ::Fit method was changed about 11 months ago in 921edd2 to add a ::FitOnShow method which is temporarily bound to wxEVT_SHOW . Because the show event occurs after the persistence ::Restore, the stored size is overwritten by the ::Fit method.
The reason why it was causing a problem on some dialogs but not others is because I was binding wxEVT_SHOW to my own method in those that were unaffected.