Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 17 16:29

    dghart on master

    QuickFindBar: Fix a wxString::F… (compare)

  • Sep 17 09:10
    dghart commented #2405
  • Sep 16 16:37
    KatiePlayz commented #2405
  • Sep 15 08:07
    eranif labeled #2787
  • Sep 15 04:53
    stale[bot] unlabeled #2787
  • Sep 15 04:53
    rozhuk-im commented #2787
  • Sep 14 08:07
    stale[bot] unlabeled #2448
  • Sep 14 08:07
    uffejakobsen commented #2448
  • Sep 14 08:04

    eranif on master

    set the file type as python for… (compare)

  • Sep 14 07:21
    stale[bot] labeled #2779
  • Sep 14 07:21
    stale[bot] labeled #2448
  • Sep 14 07:21
    stale[bot] labeled #2787
  • Sep 14 07:21
    stale[bot] labeled #2788
  • Sep 14 07:21
    stale[bot] commented #2779
  • Sep 14 07:21
    stale[bot] commented #2448
  • Sep 14 07:21
    stale[bot] commented #2787
  • Sep 14 07:21
    stale[bot] commented #2788
  • Sep 13 19:28

    eranif on master

    Compiler: Tweak some default co… Code refactoring for #2823 and … (compare)

  • Sep 13 19:28
    eranif closed #2827
  • Sep 13 17:52
    rlbxku1r edited #2827
DaGiHu
@DaGiHu
These happens in both 15.0.2 and 15.0.3. Thanks!.
Eran Ifrah
@eranif
@DaGiHu I am afraid you misunderstood me last time: you should have clangd always enabled. Having it disabled, gives such problems.
DaGiHu
@DaGiHu
My fault, @eranif ... thank you, my friend.
Matthew Muller
@mwmuni
I've been trying to use the language server but it seems to parse the file after three keystrokes, then refuses to parse again until I save the file. Is this a known issue?
correction, it updates after three characters on any line it has not yet parsed.
Screenshot from 2021-05-13 16-52-39.png
So it'll maintain the error even after deleting it and typing again on a new line.
Aleksandar Pavlovikj
@UltraALeks
hi @eranif
I have a suggesting about functions hint box. Once I start to enter parameters it looses the function hint, and entering , (comma) does not make it show again, which is something that would improve the experience by far.
For functions with more than few params, I literally go to the .h file and copy/past the function declaration next to the entry place so I can enter the params. Which is great inconvenience and waste of energy. Any hopes to have this fixed in near future?
Also one more thing, when I try to access properties of a class (A) within a scope of class (this). I often get list of the properties of "this" instead of "this->A", which also is inconvenience. But this happens like 50% of the time, not always. Sometimes it works.
Matthew Muller
@mwmuni
Is there a way to modify the update interval on the issue I showed before? It's incredibly intrusive to have to save the file every time I type a variable that is more than three characters long.
DaGiHu
@DaGiHu
Hi there. I'm working on C++ and Goto Declaration/Implementation has been working flawlessly until yesterday but now Implementation goes to Declaration and once I'm there, Implementation takes to its correct code location. I've checked Language Server and it's up and running with default parameters. Any hint?. Thank you.
DaGiHu
@DaGiHu
...I've also noted that Goto Implementation first time goes to Declaration (sometimes taking a second or more) but second time it goes finally to the Implementation. I remember Eran wrote about fixing this but I cannot find the entry he did so.
DaGiHu
@DaGiHu
I'd really appreciate some help on this topic. I'm on a sort of dense amount of code and with Goto crippled, coding has became kinda frustrating and unproductive. Thank you.
Eran Ifrah
@eranif
@DaGiHu this is a problem with clangd: it only sees header files (except for the cpp files it already "saw"). so when you ask for impl, it will take you to the only definition it saw: the declaration. but once the cpp file has been loaded and parsed, it will work
I am working on a hack for this
DaGiHu
@DaGiHu
Thank you, Eran. Excuse my eagerness. It's just that worked fine until a couple days ago. Thank you.
Noel Grandin
@grandinj
just done a build on current master - the F4 thing to jump to the next warning doesn't seem to be working?
Eran Ifrah
@eranif
@grandinj I have replaced the build tab to use a control that support terminal colouring, this is one of the last missing features from the old output tab. it will be added before 15.0.5 is released
Gibbon3
@Gibbon3
Yo! Went to try and reset my password for the codelite forums. Get a 404 error.
Eran Ifrah
@eranif
let me try this, we did some forum update recently
Gibbon3
@Gibbon3
Also, upgraded to codelite 15. Now Alt-F S for saving a file no work.
Eran Ifrah
@eranif
@Gibbon3 this sounds like a bug in the switch to the new menu bar
Looks like Alt-F does not open the menu
Gibbon3
@Gibbon3
Not the end of the world for now.
Eran Ifrah
@eranif
How did you try to reset the password? I tried that, and it works for me. Probably because I am the admin of the forum, I get a different view :/
Eran Ifrah
@eranif
looks like a bad virtual host from apache
Gibbon3
@Gibbon3
seems to work.
Noel Grandin
@grandinj
thanks @eranif , F4 working now
also, colors looking nice
PAULBK123
@PAULBK123
HI IN CODELITE WHEN I build the program my build pane is not showing up
can anyone please help me fix it
Eran Ifrah
@eranif
@PAULBK123 which version? in any case, you can make it reappear from the menu bar: view->show output view, if this does not help, from the menu bar: perspective -> reset
Hawkus
@HawkUs-Git
My mac keeps saying it is malware
Is there anyway to go past that?
Gibbon3
@Gibbon3

One hiccup with Codelite: 15.0.4

Sometimes when I try to build I get the following.

C:/MinGW/bin/mingw32-make -j 6 -e -f Makefile
"----------Building project:[ base_tw224_lte_tehama_v1 - Debug ]----------"
The system cannot find the path specified.
mingw32-make: * [All] Error 1
Makefile:4: recipe for target 'All' failed
====1 errors, 0 warnings====

Restarting codelite 'fixes'. I compared the project make files before and after, they are identical.

Eran Ifrah
@eranif
this is really strange, I am using it on Windows on daily basis never saw this one
do you have any anti virus software installed?
Anna
@HumbleDeer
Hey. The support.php page just returns me back to the downloads page every time. Should I make a Github issue?
Eran Ifrah
@eranif
@HumbleDeer yes please
Gibbon3
@Gibbon3

do you have any anti virus software installed?

Computer is a corporate one with who knows what installed. :(

Noel Grandin
@grandinj
current master has a compile error in cc_box_tip_window
this is with wx-3.0, possibly codelite requires a newer one now?
Noel Grandin
@grandinj
Also current master never stops indexing
It has been chewing up two cores for 12+ hours now
Eran Ifrah
@eranif
@grandinj is this on macOS?
(the never ending indexing)
Eran Ifrah
@eranif
@grandinj do you have a folder under /tmp/codelite.<something> ? what is the <something> for you?
Eran Ifrah
@eranif
@grandinj the indexing issue should be fixed now