These are chat archives for esp8266/Arduino

11th
Jul 2015
probonopd
@probonopd
Jul 11 2015 00:09
@me-no-dev i am still working on it; right now my app's client ID is hardcoded
experimenting with different json libraries at the moment but aJson looks promising
give me some time
:)
Rahul Thakoor
@rahul-thakoor
Jul 11 2015 02:43
hello there.. I am trying to use arduino IDE to program ESP-12.. First create an access point with webserver using https://github.com/esp8266/Arduino/blob/esp8266/hardware/esp8266com/esp8266/libraries/ESP8266WiFi/examples/WiFiAccessPoint/WiFiAccessPoint.ino
I want to open a custom index.html page which provides a graphics UI for setting GPIO pins high in in order to turn led on/off.. how to proceed? how to get esp to load a custom index page?
Me No Dev
@me-no-dev
Jul 11 2015 07:43
check the web server examples
probonopd
@probonopd
Jul 11 2015 10:51
@me-no-dev pushed a new version, does it still give the same error? please post the output of the serial console if you can't connect to the emulated bridge
Now I can start setting light colors (although my color algorithm still seems to have a bug)
Me No Dev
@me-no-dev
Jul 11 2015 10:52
will give it a go tomorrow
have a party to go to now
Markus
@Links2004
Jul 11 2015 14:50
This message was deleted
Michael Miller
@Makuna
Jul 11 2015 17:39
Are the examples for the ILI9341 correctly setup for esp8266 use or are they just copies?
Markus
@Links2004
Jul 11 2015 17:40
ther is one
Michael Miller
@Makuna
Jul 11 2015 17:41
I noticed that DC and CS are set to 9 & 10 which don't sound right for esp8266
Michael Miller
@Makuna
Jul 11 2015 17:58
Interesting, that doesn't seem to be the one used in the examples list even when I have the esp8266 board selected.
But it is different and looks correct.
Markus
@Links2004
Jul 11 2015 17:59
strange
Michael Miller
@Makuna
Jul 11 2015 18:05
Ok, the one installed with latest staging is not correct, it looks like an exact copy of the normal one.
located at %AppData%\Roaming\Arduino15\packages\esp8266\hardware\esp8266\1.6.5-804-g2d340c7\libraries\Adafruit_ILI9341\examples\graphicstest
Markus
@Links2004
Jul 11 2015 18:07
%AppData%\Roaming\Arduino15\packages\esp8266\hardware\esp8266\1.6.5-804-g2d340c7\libraries\Adafruit_ILI9341\examples\graphicstest_esp8266 ?
you have the wrong dir
Michael Miller
@Makuna
Jul 11 2015 18:24
ok, the directory exists, but it is not being exposed in the examples menu. This is due to the folder name not matching the ino file name. THEY MUST MATCH TO BE DISPLAYED!
Why have the original there at all? With the Boardmanager, it should expose libraries examples for each board as selected.
Markus
@Links2004
Jul 11 2015 18:28
will correct this. the orginal are there because the library can still be used with an AVR
Links2004/Arduino@9b9f531
Michael Miller
@Makuna
Jul 11 2015 18:33
Yeah, then this is a longer term problem of how does a library expose an example that is specific to a board. I don't think they support that yet.
Markus
@Links2004
Jul 11 2015 18:36
agree on that, for the whole library its possible but not by example base
oO 3 patches for the SDK are out
Michael Miller
@Makuna
Jul 11 2015 19:09
@Links2004 Do you have a wiring diagram to connect the screen that matches that example?
Markus
@Links2004
Jul 11 2015 19:13
no diagram, i connect like this:
TFT         ESP
MISO      12
SCK        14
MOSI      13
DC            4
RESET    5 or 3V3
CS           15
but only MISO SCK and MOSI are fix all other can be configured
Michael Miller
@Makuna
Jul 11 2015 19:23
Now to figure out how to translate my screens (SDA, A0) translate to MISO/MOSI
Markus
@Links2004
Jul 11 2015 19:24
me screen looks like:
blob
Michael Miller
@Makuna
Jul 11 2015 19:26
mine is different, its similar but only 1.8".
Markus
@Links2004
Jul 11 2015 19:27
can you send a picture or link?
may its look like this?
blob
Michael Miller
@Makuna
Jul 11 2015 19:36
nope, trying to get a link to just the picture, but it wont let me get the link, http://www.electrodragon.com/product/eds-tft-lcd-lcm-spi-interface-variable1-82-2/#prettyPhoto, see third photo that both yours and mine
Markus
@Links2004
Jul 11 2015 19:39
the 1.8 has an other chip
ST7735S
Michael Miller
@Makuna
Jul 11 2015 19:44
ah, thanks, will dig into this for a bit
probonopd
@probonopd
Jul 11 2015 20:42
I have the one from your picture @Links2004 and it is working with the ESP