These are chat archives for esp8266/Arduino

27th
Sep 2015
Lstt2005
@Lstt2005
Sep 27 2015 11:00
Dear friends! How compile cool WebServer with html for beginners? - http://www.esp8266.com/viewtopic.php?f=29&t=5686
xbary
@xbary
Sep 27 2015 13:57

Fatal exception (28):
epc1=0x40213b55, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000010, depc=0x00000000

Exception (28):
epc1=0x40213b55 epc2=0x00000000 epc3=0x00000000 excvaddr=0x00000010 depc=0x00000000

ctx: sys
sp: 3ffffd70 end: 3fffffb0 offset: 01a0

stack>>>
3fffff10: 3fff540c 40211ca2 3ff.....

fatal :(
As a router CellPipe it all works, but how do I connect to the DWR-116 Dlink this is the exception teaches moments after activation server.
xbary
@xbary
Sep 27 2015 14:03
Strange this issue, whether one is able to explain it?
Holger Lembke
@holgerlembke
Sep 27 2015 14:20
Hmmm. Moving working code from ESP-12 to a quite old esp-01. All I get is
'''
Chip-ID: 10301990
FLASH: 524288
Verbindung fehlgeschlagen, Config-Modus
Webserver: Starting config mode
192.168.4.1
Running...

 ets Jan  8 2013,rst cause:4, boot mode:(1,6)

wdt reset
Any ideas beside staying with working esp-12?
Markus
@Links2004
Sep 27 2015 14:21
@xbary excvaddr=0x00000010 indicates that it may something with null ptr access .
@holgerlembke have the modules the same flash size?
Holger Lembke
@holgerlembke
Sep 27 2015 14:23
no.
and I changed it in the IDE
Markus
@Links2004
Sep 27 2015 14:24
try Serial.setDebugOutput(true); may we get more info
Holger Lembke
@holgerlembke
Sep 27 2015 14:28
Chip-ID: 10301990
FLASH: 524288
f 0, scandone
Verbindung fehlgeschlagen, Config-Modus
Webserver: Starting config mode
bcn 0
del if1
mode : sta(18:fe:34:9d:32:26)
mode : sta(18:fe:34:9d:32:26) + softAP(1a:fe:34:9d:32:26)
add if1
dhcp server start:(ip:192.168.4.1,mask:255.255.255.0,gw:192.168.4.1)
bcn 100
192.168.4.1
Running...
add 1
aid 1
station: e8:4e:06:17:94:33 join, AID = 1

 ets Jan  8 2013,rst cause:4, boot mode:(1,6)

wdt reset
I don't see something helpful....
Markus
@Links2004
Sep 27 2015 14:31
it open an AP and then the wtd resets.
can you add some print to you loop so we can see if its hags in OS or in the sketch
Holger Lembke
@holgerlembke
Sep 27 2015 14:32
forgot the webserver->handleClient();
I think I will look for a different profession. like häkeln or so.
Holger Lembke
@holgerlembke
Sep 27 2015 14:38
soooooo, will i2c work on an esp1 with gpio0 and gpio2...????
Markus
@Links2004
Sep 27 2015 14:40
yes, pull ups are ok on the GPIOs
but if some I2C IC pull GPIO0 or 2 low at boot time you get problems
Holger Lembke
@holgerlembke
Sep 27 2015 14:41
that's what I'm thinking about....
Markus
@Links2004
Sep 27 2015 14:43
normally they dont do this, it only can happen when you reset the ESP during a I2C transmission
brutzler
@brutzler
Sep 27 2015 14:45
häkeln...LOL....oder Fensterbilder malen.........
Markus
@Links2004
Sep 27 2015 14:46
ui mehr deutsch hier als ich gedacht hätte :)
xbary
@xbary
Sep 27 2015 14:49
@Links2004 ... the worst that exception shows only the D-Link DWR-116 Router ..., could something as they quickly wanted to do?
Markus
@Links2004
Sep 27 2015 14:52
can you do a obj dump to see the function where the error is in code?
lots of potential do fail...
xbary
@xbary
Sep 27 2015 14:53
oki moment @Links2004
brutzler
@brutzler
Sep 27 2015 15:05
ui mehr deutsch hier als ich gedacht hätte :)
gibt ja kein deutsches Board :-(
xbary
@xbary
Sep 27 2015 15:18
yet the moment because I will cut down its code iii check what happens
Markus
@Links2004
Sep 27 2015 15:47
@igrr is it possible to at git tags when you generate a new zip? then its easier to get answers to something like this #826.
xbary
@xbary
Sep 27 2015 16:06

@Links2004 ... But the problem is somewhere in the kernel, I created a new project and I put this example https://github.com/esp8266/Arduino/blob/esp8266/hardware/esp8266com/esp8266/libraries/ESP8266WebServer/examples/HelloServer/HelloServer.ino and after visiting the main page shows a "hello from esp8266!" and after a while I got something on the terminal:

........
Connected to xb-DWR
IP address: 192.168.2.3
MDNS responder started
HTTP server started

ets Jan 8 2013 rst cause: 4, boot mode (1,7)

WDT reset

and the second router is ok CellPipe:
............
Connected to xb-CellPipe
IP address: 10.0.0.68
MDNS responder started
HTTP server started

without reset

xbary
@xbary
Sep 27 2015 16:12
it looks like the D-Link DWR-116 something differently corresponded with ESP and ESP suspended