These are chat archives for esp8266/Arduino

11th
Oct 2015
sticilface
@sticilface
Oct 11 2015 11:50
I'm using El capitan and now I get a "allow incoming network dialog" everytime I try to do an OTA update. The problem is that unless i click it immediately... the update fails. I've added python to firewall, and arduino... (which also asks..) does anyone have a solution... i tried this one... http://stackoverflow.com/questions/19688841/add-python-to-os-x-firewall-options but i get an error about not having Xcode...
Me No Dev
@me-no-dev
Oct 11 2015 12:57
do you have Xcode?
sticilface
@sticilface
Oct 11 2015 13:26
i did but had to remove it as I'm using an air with no hdd space left... having to install all that just for that is a bit of a pain!
think it runs to many gigs... and i've only 128gb ssd.
Me No Dev
@me-no-dev
Oct 11 2015 13:27
yeah... no go then :) need Xcode for signing
sticilface
@sticilface
Oct 11 2015 13:27
got it to work by adding a 2 second delay before the ESP tried to connect back. is long enough to work reliably..
arghhhhh
Me No Dev
@me-no-dev
Oct 11 2015 13:27
lots of new security in El Captain
sticilface
@sticilface
Oct 11 2015 13:28
yeah... to get the serial drivers to work, had to reboot into a mode... do stuff, then install.. total pain in the ass
i guess i can install, sign and uninstall?
Me No Dev
@me-no-dev
Oct 11 2015 13:30
not really
since it's a self-signing thing
sticilface
@sticilface
Oct 11 2015 13:30
mmm...
Me No Dev
@me-no-dev
Oct 11 2015 13:31
you need to have the proper certs and so on services in order for the OS to recognize it as your signature
sticilface
@sticilface
Oct 11 2015 13:31
guess i need to buy a new mac then... with more space! ;)
Me No Dev
@me-no-dev
Oct 11 2015 13:31
unless of course you have a Mac Dev account that has a real certificate for distribution
check google just in case
but i'm pretty sure i'm correct
maybe binary version of the uploader would do
sticilface
@sticilface
Oct 11 2015 13:36
I've defo not got any of those.. I'm downloading Xcode.. all 4Gb..
d-anders
@d-anders
Oct 11 2015 15:55
umm, is D4 very wrong to use on a nodemcu board?
i used it for the echo pin of a ultrasonic sensor and it kept on setting my board in a strange state if it was connected when booting
it would work if i connected it later
then i switched to d6 and no problems
d-anders
@d-anders
Oct 11 2015 16:10
haha, D4 is gpio_2....
sticilface
@sticilface
Oct 11 2015 20:00
This message was deleted
This message was deleted