These are chat archives for esp8266/Arduino

2nd
Dec 2015
Harrison Mclean
@h4rm0n1c
Dec 02 2015 00:37
This message was deleted
frippe75
@frippe75
Dec 02 2015 05:52

Still working on my OTA pull ...

The actual updating is working. I'm having problem with blocking part of the code for getting the status of the update process on my html client.

Tried moving code to loop using firmware upgrade states

loop() {

onkelfunny
@onkelfunny
Dec 02 2015 07:51

hello

Building file: .../Documents/Arduino/hardware/esp8266com/esp8266/cores/esp8266/time.c
Starting C compile
In file included from /Users/waldemar/Documents/Arduino/hardware/esp8266com/esp8266/tools/sdk/include/os_type.h:10:0,
                 from /Users/waldemar/Documents/Arduino/hardware/esp8266com/esp8266/tools/sdk/include/sntp.h:4,
                 from /Users/waldemar/Documents/Arduino/hardware/esp8266com/esp8266/cores/esp8266/time.c:20:
.../Documents/Arduino/hardware/esp8266com/esp8266/tools/sdk/include/ets_sys.h:148:20: error: unknown type name 'size_t'
 void *pvPortMalloc(size_t xWantedSize) __attribute__((malloc, alloc_size(1)));

how i can fix this error. i worked yesterday with eclipse and everything working perfect. after a os x crash and restart i have this error.

onkelfunny
@onkelfunny
Dec 02 2015 08:20
here is the full output: http://pastebin.com/iur3uQgu
xbary
@xbary
Dec 02 2015 09:43
@onkelfunny cześć Waldemar :)
onkelfunny
@onkelfunny
Dec 02 2015 09:51
;)
xbary
@xbary
Dec 02 2015 10:03
the Polish you? because by name
onkelfunny
@onkelfunny
Dec 02 2015 10:05
Born in Russia
xbary
@xbary
Dec 02 2015 10:14
acha
Kiril Zyapkov
@kzyapkov
Dec 02 2015 13:59
nevermind
This message was deleted
This message was deleted
onkelfunny
@onkelfunny
Dec 02 2015 14:55
espcomm_send_command: wrong direction/command: 0x01 0x04, expected 0x01 0x03
warning: espcomm_send_command(FLASH_DOWNLOAD_DATA) failed
    serialport_receive_C0: 6C instead of C0
warning: espcomm_send_command: didn't receive command response
closing boot loader
next error
today i have no luck with the esp :(
onkelfunny
@onkelfunny
Dec 02 2015 15:22
found the issue of the second error... don't trust a pogo pin from china :)
Aditya Tannu
@AdySan
Dec 02 2015 15:48
Anybody seen this kind of esp-wroom-02 dev board on aliexpress/eBay? https://www.switch-science.com/catalog/2500/
Seems smaller than nodemcu, just can't find a way to get this in the US
marksev1
@marksev1
Dec 02 2015 16:24
Anyone od you guys using esp-201?
Hassanbenlebsir
@Hassanbenlebsir
Dec 02 2015 16:34
does anyone has a client server socket example code for esp8266
Steve Nelson
@zenmanenergy
Dec 02 2015 16:39
i do. but I haven’t cleaned it up to post to github. send me your email address
@Hassanbenlebsir I built an extension for scratchX.org using js that uses websockets to talk to a esp robot. it’ll get you started.
Hassanbenlebsir
@Hassanbenlebsir
Dec 02 2015 16:43
Thank you my email address is hassan.benlebsir.2c@gmail.com
Markus
@Links2004
Dec 02 2015 16:44
@Hassanbenlebsir you need a websocket client?
https://github.com/Links2004/arduinoWebSockets
Hassanbenlebsir
@Hassanbenlebsir
Dec 02 2015 16:45
just so you know what i'm trying to is connect an esp8266 to an rfid reader when the card reader scan a card an the id of the card is been sent to a java desktop application
so the esp8266 will be the client and the java application the server that show the IDS
Steve Nelson
@zenmanenergy
Dec 02 2015 16:46
which rfid reader are you using? I was thinking about doing that, but it’s in my “i’ll get to it someday” pile.
Markus
@Links2004
Dec 02 2015 16:47
there are many protocols to communicate with.
if you want bare TCP take a look here: https://github.com/esp8266/Arduino/blob/master/libraries/ESP8266WiFi/examples/WiFiClient/WiFiClient.ino
Hassanbenlebsir
@Hassanbenlebsir
Dec 02 2015 16:47
RFID-RC522
@Links2004 thanx i'll take a look at the links you sent
So the main raison of this is to build a clock in system to know what time people clock in at work
Steve Nelson
@zenmanenergy
Dec 02 2015 16:54
@Hassanbenlebsir I just emailed you some more code to play around with.
Hassanbenlebsir
@Hassanbenlebsir
Dec 02 2015 16:57
@zenmanenergy thanx
Steve Nelson
@zenmanenergy
Dec 02 2015 16:57
you’re welcome
Aditya Tannu
@AdySan
Dec 02 2015 17:03
@marksev1 yes, what about ESP-201?
Me No Dev
@me-no-dev
Dec 02 2015 17:26

I have a case where I have two ESPs connected to each other (one is AP the other STA to it)
And every time the AP is lost and then reconnected, the board wdt resets trying to get IP

no esp8266-uart-srv found, reconnect after 1s
reconnect
f 0, scandone
state: 0 -> 2 (b0)
state: 2 -> 3 (0)
state: 3 -> 5 (10)
add 0
aid 1
pm open phy_2,type:2 0 0

connected with esp8266-uart-srv, channel 11
dhcp client start...

 ets Jan  8 2013,rst cause:4, boot mode:(3,6)

wdt reset
load 0x4010f000, len 1264, room 16 
tail 0
chksum 0x42
csum 0x42
~ld
scandone
state: 0 -> 2 (b0)
state: 2 -> 3 (0)
state: 3 -> 5 (10)
add 0
aid 1
pm open phy_2,type:2 0 0

connected with esp8266-uart-srv, channel 11
dhcp client start...
cnt 
chg_B:-60
ip:192.168.4.2,mask:255.255.255.0,gw:192.168.4.1
chg_B:-120

Is this a known problem?

Markus
@Links2004
Dec 02 2015 17:28
i have seen wtd resets by trying dhcp one or two times (not to an other ESP),
looks like you found a more stabe way to triggering the bug.
Me No Dev
@me-no-dev
Dec 02 2015 17:31
that's encouraging :D will try and live with it, maybe some future version will fix it
Hassanbenlebsir
@Hassanbenlebsir
Dec 02 2015 17:52
warning: espcomm_sync failed
error: espcomm_open failed
guys i get this error when i want to upload my code to the esp
Martin Ayotte
@martinayotte
Dec 02 2015 19:52
There is many things that can produce that : bad wiring, bad USB-TTL serial, etc. You're better sending a post on the forum with details.
brutzler
@brutzler
Dec 02 2015 23:08
Hi guys,
anybody seen this ESP? http://de.aliexpress.com/item/new-ESP8266-MINI-nodemcu/32553700803.html
looks like there is a WS2812 an a LDR on the board. But why is a mini USB at the back of the upper board?
Or do i get only one board? and the other is the same board shown from the back side?
Me No Dev
@me-no-dev
Dec 02 2015 23:23
the one where the ESP is is for power
the one on the other board is for programming
you can see the reset circuit there too
and I thin this is probably RGB and not WS2812
brutzler
@brutzler
Dec 02 2015 23:25
you think both boards are in scope of supply?
Me No Dev
@me-no-dev
Dec 02 2015 23:26
i'm not sure but it looks like only the top gives power, unless there is a build-in regulator in whatever that chip is
there is no regulator on the bottom board and I can only see on trace going from ESP V+ to the UART chip
brutzler
@brutzler
Dec 02 2015 23:30
OK. Regarding to this: If its two times the same board, you wouldn't be able to stack it, because one connector should be male, the other one should be female: -> Two different boards
But why are there two mini-USB plugs....??? power <-> programming. Like you suggested
Me No Dev
@me-no-dev
Dec 02 2015 23:32
so you can power it off the programming board
they might not have been constructed at the same time
who knows...