These are chat archives for esp8266/Arduino

18th
Jan 2017
sticilface
@sticilface
Jan 18 2017 07:04
cheers. I'll point the author in these directions. His lib maintains c compatibility so I'm not sure if that would work. thanks for the ideas though. the bottom line is FLASH_ATTR stuff is kept no matter if it is used or not
Michael Miller
@Makuna
Jan 18 2017 07:16
@sticilface I am not sure that's true in all cases. My library uses it but I am not seeing the methods get included if not used in the template class.
Clemens Kirchgatterer
@everslick
Jan 18 2017 08:55
when i link agains mbedtls.a i run out of iram1 space! AHHHHHHHHHHH! :-(
Butch Anton
@ButchAnton
Jan 18 2017 18:12
Silly question: My ESP8266 NodeMCU dev board has decided that it doesn't want to associate with my AP any more. Any suggestions for tracking down why?
Butch Anton
@ButchAnton
Jan 18 2017 18:26
I updated the firmware, which rebooted it a couple of times, and things seem to be doing better.
On to my next question, which is mostly for @Palatis: I'm trying to use the esp8266-restclient code to POST JSON data to Ubidots via HTTPS. I can post the data using HTTP just fine, but the HTTPS variant fails, and I can't really get any useful debugging information out of the restclient code. I'm also using PlatformIO as my development environment. Any suggestions for how I can debug the SSL issues?
And following up on my previous problem, I'm back to having issues with the ESP8266 associating with the AP. :-(
Michael Miller
@Makuna
Jan 18 2017 20:07
@ButchAnton I had something similar, what I found worked was to force some settings that I didn't think I changed that are stored in flash for the WiFi config. This is what I did...
        WiFi.setAutoConnect(false);
        WiFi.disconnect(true);
        delay(500);

        WiFi.setPhyMode(WIFI_PHY_MODE_11G);
        WiFi.setOutputPower(8); // low power, change to your wanted power level
        WiFi.mode(WIFI_STA);
I put that in a sketch that I run once in a while to help clear things out that I may have tried.
Butch Anton
@ButchAnton
Jan 18 2017 20:08
@Makuna Thank you!
@Palatis I also just got the restclient code working with HTTPS.