Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Markus
@Links2004
next week i have holidays but after that i can check the ESP12 module output :) may the order ESP7 also be there then i can hook an antenna there.
ficeto
@ficeto
beter try esp-201
it does not have an integrated antenna
i imagine that would change things
well... you can cut the trace to the chip antenna and get the same result
Markus
@Links2004
the ESP-07 has an chip antenna and an connector the chip antenna an be solderer easy :)
ficeto
@ficeto
yeah I have those
wonder if the left over trace would matter
maybe unsolder the cap
Markus
@Links2004
yes shut be better
ficeto
@ficeto
good time to check if wifi would crap the PWM
if that works, i see no reason not to hack a quick TX-RX and give it a shot this weekend
btw... why does this fail? Am I stupid?
WiFiClient client;
  if (!client.connect("www.google.com", 80)) {
    Serial.println("client failed");
    goToSleep(10);
    return;
  }
  client.print("GET / HTTP/1.1\r\nConnection: close\r\n\r\n");
  delay(10);
  size_t len = client.available();
  uint8_t buf[len];
  client.read(buf, len);
  Serial.write(buf, len);
  client.stop();
  uint16_t maxWait = 2000;
  while(client.connected() && maxWait--) {
    delay(1);
  }
it goes to client failed every time
Markus
@Links2004
no wifi?
ficeto
@ficeto
i just got NTP before that and it works fine
this runs if wifi is connected only
Markus
@Links2004
is uint8_t buf[len]; really working?
ficeto
@ficeto
it never gets to that
it never connects
Markus
@Links2004
the connect looks ok for me is the dns working, can you try an ip.
ficeto
@ficeto
surely
same
Markus
@Links2004
its the same when you define WiFiClient client; globaly?
ficeto
@ficeto
load 0x40100000, len 29692, room 16 
tail 12
chksum 0x35
ho 0 tail 12 room 4
load 0x3ffe8000, len 1564, room 12 
tail 0
chksum 0x13
load 0x3ffe8620, len 2792, room 8 
tail 0
chksum 0xd8
csum 0xd8

�scandone
scandone
add 0
aid 4
cnt 

connected with nbis-test, channel 11
dhcp client start...
ip:192.168.254.184,mask:255.255.255.0,gw:192.168.254.5
192.168.254.184
NTP:29/05/2015 12:57:35
LmacRxBlk:1
client failed
LmacRxBlk:1
LmacRxBlk:1
Markus
@Links2004
the os has some data but you dont get it strange.
ficeto
@ficeto
same with global client
i never get that it's connected
Markus
@Links2004
can it be some strange interaction with the NTP code?
ficeto
@ficeto
not checking for success yields exception
will kill nTP and try
yup....
with NTP after the client:
�scandone
scandone
add 0
aid 3
cnt 

connected with nbis-test, channel 11
dhcp client start...
ip:192.168.254.184,mask:255.255.255.0,gw:192.168.254.5
192.168.254.184
HTTP/1.1 400 Bad Request
Server: nginx/1.4.6 (Ubuntu)
Date: Fri, 29 May 2015 10:07:49 GMT
Content-Type: text/html
Content-Length: 181
Connection: close

<html>
<head><title>400 Bad Request</title></head>
<body bgcolor="white">
<center><h1>400 Bad Request</h1></center>
<hr><center>nginx/1.4.6 (Ubuntu)</center>
</body>
</html>
NTP:29/05/2015 13:02:09
LmacRxBlk:1
LmacRxBlk:1
LmacRxBlk:1
LmacRxBlk:1
LmacRxBlk:1
LmacRxBlk:1
the NTP code:
udp.begin(localPort);
  sendNTPpacket(timeServer);
  int cb = udp.parsePacket();
  while(!cb){
    sendNTPpacket(timeServer);
    cb = udp.parsePacket();
    yield();
  }
  udp.read(packetBuffer, NTP_PACKET_SIZE);
Markus
@Links2004
some idea: the UDP and TCP share the same event to the "android task" and you still getting UDP packets, what brings the connect to fail.
so may try to close the udp
ficeto
@ficeto
did not expect such behaviour from UDP
Markus
@Links2004
it not a problem of the UDP protokoll its the wifiClient stuff, but have no time to confirm this.
have some other task to do for today.
ficeto
@ficeto
yup
udp.close did it
maybe should be added to the example
as that is what I used
Markus
@Links2004
yes
ficeto
@ficeto
really funky thing with Adafruit_SSD1306
sends the setup packet
and that's it... no more talking to the LCD
Russ Mathis
@RussMathis
Is there a way to sleep but keep pwm running ?