Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 07:12
    dok-net opened #6809
  • 06:27
  • 06:26
    devyte synchronize #6808
  • 06:26
  • 06:03
    devyte milestoned #6725
  • 06:03
    devyte demilestoned #6725
  • 05:54
    devyte milestoned #6797
  • 05:53
    devyte milestoned #6796
  • 05:53
    devyte milestoned #6784
  • 05:45
    devyte synchronize #6790
  • 05:44
    devyte labeled #6794
  • 05:44
    devyte labeled #6794
  • 05:43

    devyte on master

    Only add "l" to XX.htm URLs if … (compare)

  • 05:43
    devyte closed #6794
  • 05:43
    devyte closed #6792
  • 05:42
    earlephilhower edited #6808
  • 05:42
    earlephilhower opened #6808
  • 05:28
  • 05:27
    earlephilhower synchronize #6807
  • 05:26
    earlephilhower milestoned #6807
Þórhallur Sverrisson
@thorhs
ohh, you mean the station oand client?
Markus
@Links2004
yes
Þórhallur Sverrisson
@thorhs
Nope, I’ll try that, I have a few to choose from :)
Hmmm, perhaps I should enable the debug output on the softAP as well… that might give me some ideas
Markus
@Links2004
yes may helps.
a other workaround will be using a chip WiFi router ;)
Þórhallur Sverrisson
@thorhs
yeah, I swithced from my local WLAN to the softAP since my home WLAN was too jittery.. the softAP is working much better in that regards
Markus
@Links2004
I also setup a second Wifi for the IoT stuff to many broadcasts on the normal one.
Openwrt can setup Wifis in parallel.
Þórhallur Sverrisson
@thorhs
ohh, crap, I just realized I can’t use the softAP, it only handles 4 clients :(
hmmm… interesting, I only have airports at home… but one 4G WiFi router that I might hijack :)
I’ll try that
Markus
@Links2004
this can be extended but then you need to communicate by broadcasts/ multicast (socked limitation)
Þórhallur Sverrisson
@thorhs
I am using broadcasts today, so that would not be a problem
Þórhallur Sverrisson
@thorhs
Hmm, FYI, the debug output on the station just says station XXX leave, with rm 1, add 1, aid1, and the station join
I’m going to dig up the other wifi and give it a whirl
br
brb
Þórhallur Sverrisson
@thorhs
First test indicates the 5 minute issue is related to ESP softAP to ESP client
I have not run the same two ESPs through the huawei router for close to 10 minutes now without issues...
kathir51
@kathir51
@Links2004 if i want to build arduino ide from source what are essential tools required ? i have ant , tool.jar
kathir51
@kathir51
Can any one tell essential tool requird to build ARDUINO IDE from source .I have ant and tool.jar installed . Any other tools required such as wget , git
tzapu
@tzapu
git and some java runtime i think would be needed, and i think you just need to try it and fix errors when they show. that s how i did it anyway. it was relatively painless
Markus
@Links2004
@kathir51 the basics are written here: https://github.com/arduino/Arduino/wiki/Building-Arduino
why you want to build the IDE from src?
kathir51
@kathir51
@Links2004 That is only acadamic interest . I encountered a problem while compiling native c code using xtensa tool chain with make file the wifi is in idle condition only . unable to come from that . my basic code is uart_init(BIT_RATE_115200,BIT_RATE_115200);wifi_set_opmode( STATION_MODE );
char ssid[32] = "Benjamin";
char password[64] ="4522641400abc";
struct station_config stationConf;
stationConf.bssid_set = 0; //need not check MAC address of AP
os_memcpy(&stationConf.ssid, ssid, 32);
os_memcpy(&stationConf.password, password, 64);
wifi_station_set_config(&stationConf);
wifi_station_dhcpc_start();
kathir51
@kathir51
int status = wifi_station_get_connect_status(); i am getting always state =0; even for correct and wrong ssid and password I am unable solve what mistake in the code . I made conter verification from ARDUINO source code mine is same as their. compiling is success with make file I used SDK 1.4.0 Even i revert back to SDK 0.9.3 SAME
kathir51
@kathir51
@tzapu Thanks for your information @kathir51
@Links2004 That is only acadamic interest . I encountered a problem while compiling native c code using xtensa tool chain with make file the wifi is in idle condition only . unable to come from that . my basic code is uart_init(BIT_RATE_115200,BIT_RATE_115200);wifi_set_opmode( STATION_MODE );
char ssid[32] = "Benjamin";
char password[64] ="4522641400abc";
struct station_config stationConf;
stationConf.bssid_set = 0; //need not check MAC address of AP
os_memcpy(&stationConf.ssid, ssid, 32);
os_memcpy(&stationConf.password, password, 64);
wifi_station_set_config(&stationConf);
wifi_station_dhcpc_start();int status = wifi_station_get_connect_status(); i am getting always state =0; even for correct and wrong ssid and password I am unable solve what mistake in the code . I made conter verification from ARDUINO source code mine is same as their. compiling is success with make file I used SDK 1.4.0 Even i revert back to SDK 0.9.3 SAME
Markus
@Links2004
this is "normal" the SDK needs some time to connect if it not go really fast you get 0.
have you tried adding a while similar to
https://github.com/esp8266/Arduino/blob/esp8266/hardware/esp8266com/esp8266/libraries/ESP8266WiFi/examples/WiFiClient/WiFiClient.ino#L31-L34
kathir51
@kathir51

@Links2004 here is my function enum status { WL_DISCONNECTED = 0, WL_CONNECTED = 1, WL_NO_SSID_AVAIL = 2, WL_CONNECT_FAILED = 3 , WL_IDLE_STATUS =5 };

//void to_scan(void) { wifi_station_scan(&config,scan_done); }
uint8 status()
{
int status = wifi_station_get_connect_status();

if (status == STATION_GOT_IP)
  return WL_CONNECTED;
else if (status == STATION_NO_AP_FOUND)
  return WL_NO_SSID_AVAIL;
else if (status == STATION_CONNECT_FAIL || status == STATION_WRONG_PASSWORD)
  return WL_CONNECT_FAILED;
else if (status == STATION_IDLE)
  return WL_IDLE_STATUS;
else
  return WL_DISCONNECTED;

} int x=status();
os_sprintf(info1,"state : %d \r\n", x);
putrsUART(info1);
while (status() != WL_CONNECTED) {
for(int i=0;i<10;i++)
os_delay_us(5000);
putrsUART(".");
}
putrsUART("wifi connected");
char kat[40];
wifi_get_ip_info(STATION_IF, &ipconfig);
os_sprintf(kat,"IPaddress: %u %u %u %u",IP2STR(&ipconfig.ip));
putrsUART(kat);

@Links2004 I tried as you said using while as shown above no use I used sameESP8266. begin code IN ARDUINO
@Links2004 I verified the chip with arduino esp libray functioning well
kathir51
@kathir51
@Links2004 I tried same alogritham used in Arduino L:ibrary
Victor Aprea
@vicatcu
hi
anybody home?
xbary
@xbary
Hi, Yes .... working
patjazz
@patjazz
esp12.svg
Markus
@Links2004
@kathir51 have you wifi_station_connect(); in your code?
kathir51
@kathir51

@Links2004 yes .But to the surprise the same code using extern "C" works in arduino ide extern "C" {

include "osapi.h"

include "ets_sys.h"

include "mem.h"

include "os_type.h"

include "user_interface.h"

include "gpio.h"

include "espconn.h"

include "c_types.h"

}

struct ip_info ipconfig,ip;

enum status { WL_DISCONNECTED = 0, WL_CONNECTED = 1, WL_NO_SSID_AVAIL = 2, WL_CONNECT_FAILED = 3 , WL_IDLE_STATUS =5 };

uint8 status()
{
int status = wifi_station_get_connect_status();

if (status == STATION_GOT_IP)
  return WL_CONNECTED;
else if (status == STATION_NO_AP_FOUND)
  return WL_NO_SSID_AVAIL;
else if (status == STATION_CONNECT_FAIL || status == STATION_WRONG_PASSWORD)
  return WL_CONNECT_FAILED;
else if (status == STATION_IDLE)
  return WL_IDLE_STATUS;
else
  return WL_DISCONNECTED;

}
void ICACHE_FLASH_ATTR
user_init(void)
{
Serial.begin(115200);
Serial.print("wifi connecting\r\n");
os_printf("wifi connecting\r\n");
char ssid[32] = "Benjamin";
char password[64] ="4522641400abc";
struct station_config stationConf;
stationConf.bssid_set = 0; //need not check MAC address of AP
os_memcpy(&stationConf.ssid, ssid, 32);
os_memcpy(&stationConf.password, password, 64);
ETS_UART_INTR_DISABLE();
wifi_station_set_config(&stationConf);
wifi_station_connect();
ETS_UART_INTR_ENABLE();
wifi_station_dhcpc_start();
while (status() != WL_CONNECTED) {
//for(int i=0;i<10;i++)
delay(500);
Serial.printf(".");
}
os_printf("wifi connected\r\n");
Serial.print("wifi connected\r\n");
char kat[40];
wifi_get_ip_info(STATION_IF, &ipconfig);
sprintf(kat,"IPaddress: %u %u %u %u",IP2STR(ipconfig.ip.addr);
Serial.print(kat);

}

//Do nothing function

void setup() {
// put your setup code here, to run once:
user_init();
}

void loop() {
// put your main code here, to run repeatedly:
// user_init();
}

sticilface
@sticilface
Is anyone willing to share a web server example with a SPIFFS file manager viewer, and file uploader? not wanting to re-invent the wheel. playing with the SD example, but there is no web front end for it?
Me No Dev
@me-no-dev
there is
:)
it's in the folder were the sketch is
iggr recently shared a rework of my SPIFFS sketch that we had back ago
but you need to get the contents to the spiffs
has a file browser/uploader/editor in one located at http://ip-of-esp/edit
Me No Dev
@me-no-dev
listing files seem to not be working and starting "/" needs to be removed from the path in handleFileRead
the rest seems working
Me No Dev
@me-no-dev