Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 05:00
    laercionit edited #6907
  • 04:54
    laercionit opened #6907
  • 03:27
    Tech-TX synchronize #6898
  • 02:34
    devyte closed #6906
  • 01:13
    Gaus12 opened #6906
  • Dec 12 20:44
  • Dec 12 20:18
    dok-net synchronize #6804
  • Dec 12 19:55
    dok-net synchronize #6047
  • Dec 12 19:51
    dok-net synchronize #6902
  • Dec 12 19:50
    dok-net synchronize #6782
  • Dec 12 19:47
    dok-net synchronize #6857
  • Dec 12 17:56
    devyte labeled #6898
  • Dec 12 17:56
    devyte labeled #6898
  • Dec 12 17:56
    devyte milestoned #6898
  • Dec 12 17:53
    devyte synchronize #6898
  • Dec 12 17:53
    devyte closed #6894
  • Dec 12 17:52

    devyte on master

    fix for #6904: NodeMCU v1.0 boa… (compare)

  • Dec 12 17:51
    devyte closed #6904
  • Dec 12 17:51
    devyte closed #6905
  • Dec 12 17:51
    devyte edited #6905
d-anders
@d-anders
didnt work for my imported project
Ivan Kravets
@ivankravets
@d-anders please check that your file has *.cpp extension. If you want to use *.ino please take a look at http://docs.platformio.org/en/latest/ide/atom.html#smart-code-linter-is-disabled-for-arduino-files
d-anders
@d-anders
aah, it had ino
tzapu
@tzapu
@ivankravets quick question since you are here :P
if you have a sec that is
Ivan Kravets
@ivankravets
@tzapu go :)
tzapu
@tzapu
can i keep working on my projects with both arduino ide and platform io?
or do they step on eachother toes?
Ivan Kravets
@ivankravets
@tzapu of course. Please use Menu: PlatformIO > Import Arduino Project and mark 2 checkboxes for compatibility.
tzapu
@tzapu
and then it doesn t move files, etc
Ivan Kravets
@ivankravets
yes
tzapu
@tzapu
thank you
Ivan Kravets
@ivankravets
what is more
tzapu
@tzapu
nice
Ivan Kravets
@ivankravets
you will be able to use Arduino IDE library manager
tzapu
@tzapu
ah ha
Ivan Kravets
@ivankravets
but I don't recommend
tzapu
@tzapu
ok
well, i m half torn, i m developing a lib, and want to make sure arduino ide users can use it without issues
otherwise i d go only platform ide
d-anders
@d-anders
btw, did you change so that you can build from any file in the project in the latest ver?
Ivan Kravets
@ivankravets
Screen Shot 2016-03-24 at 16.39.42.png
d-anders
@d-anders
when i tried platformio a couple of days ago it wouldnt build if i had the .ino file tab active
but it would build if i had the settings from the project open
Ivan Kravets
@ivankravets
@tzapu no problems, please check "Use Arduino IDE library manager". In this case, you will share libs between to IDEs
tzapu
@tzapu
ok, thank you very much
if i don t use the arduino ide, does it put libs in subfolders of the project?
Ivan Kravets
@ivankravets
@d-anders Please upgrade to PlatformIO IDE 1.1.0. It is huge update since the first release (1 month ago)
d-anders
@d-anders
i have 1.0.5 now
tzapu
@tzapu
sorry, library manager, if i don t use that, and use platform io lib manager, does it make subfolders, or does it have a separate folder somewhere to keep libs for all projects?
Ivan Kravets
@ivankravets
@d-anders :) please upgrade
d-anders
@d-anders
i will upgrade
thought i did yesterday
tzapu
@tzapu
anywya, i will play with it. thanks very much for your answers, much appreciated
Ivan Kravets
@ivankravets
@tzapu if we talk about PlatformIO 2.0 it install libs by default globally to http://docs.platformio.org/en/latest/projectconf.html#lib-dir
tzapu
@tzapu
ok, so couldn t i make that folder the same as arduino lob folder?
Ivan Kravets
@ivankravets
@tzapu but we are working on PlatformIO 3.0 and it will receive huge updates to Library Manager.
d-anders
@d-anders
trying now, chose "upgrade platformio" from the menu but it seems nothing is happening
tzapu
@tzapu
i assume i can also install manually for that folder, and it will pick the lib up?
Ivan Kravets
@ivankravets
@tzapu of course, just place you library in the lib folder of the project. See https://github.com/platformio/platformio/tree/develop/examples/atmelavr-and-arduino/arduino-external-libs
tzapu
@tzapu
ok, thank you , thank you :D
tzapu
@tzapu
i ve taken too much of your time already :D
thanks
Ivan Kravets
@ivankravets
@d-anders go to Menu: PlatformIO > Settings > platformio-ide and check that version is 1.1.0
d-anders
@d-anders
it is not
must go soon
will download later
Ivan Kravets
@ivankravets
@d-anders click on update button
d-anders
@d-anders
upgrading from the menu doesnt work for me, nothing happens