Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Martin Ayotte
@martinayotte
Ouch ! even a L298N module will be too border line. Is this motor so big ?
Baruch Even
@baruch
I'm using the http upgrade mechanism and it works nicely but there is no info on progress or hooks to add them, would it be ok if I created a patch to add some hooks in there? I want serial prints but I would also be interested in my mqtt server updated with the status too for an over-the-network monitoring of sorts
Stavros Korokithakis
@skorokithakis
@martinayotte yes, it's an RC car so it has a lot of torque
i ordered an L298N, it says 3A peak, so hopefully it will work
it does 800 mA with no resistance, so it was working fine when the motor was free-spinning, but if it runs against a wall it surges to 3A
Ivan Grokhotkov
@igrr
@baruch it's not recommended to run other TCP connections while OTA is in progress
this may affect the OTA
Baruch Even
@baruch
I'm not looking for continuous updates, just a "upgrade checking", "upgrade not needed", "upgrade in progress" status
Stavros Korokithakis
@skorokithakis
can't you do that already?
Ivan Grokhotkov
@igrr
Okay, that makes sense
Baruch Even
@baruch
I saw the code already disables all TCP connections other than its own
Stavros Korokithakis
@skorokithakis
oh you're talking about the HTTP one?
Ivan Grokhotkov
@igrr
pull request is welcome then :)
Stavros Korokithakis
@skorokithakis
the direct one does have hooks
Baruch Even
@baruch
@skorokithakis, the http one has no hooks
Stavros Korokithakis
@skorokithakis
right
yeah, that'd be nice
i'm writing a small Go server to do the http serving
what do you use, @baruch?
Baruch Even
@baruch
I want a smart home and I want to upgrade the units remotely without going to them one by one manually, I will have a registry of them all and either use a single upgrade topic on mqtt or one per node and the server will loop through them one by one
Python
Stavros Korokithakis
@skorokithakis
ah right
Baruch Even
@baruch
This is in collaboration with a friend, he knows hardware and I know software
Stavros Korokithakis
@skorokithakis
i wrote something that you can run and point to a directory so things can request http://server.com/sensors and the server will check the version of sensors.2.4.1.fw and send it if it's newer than what's on the ESP
Baruch Even
@baruch
both know a bit of the other side as well
Stavros Korokithakis
@skorokithakis
hardware is nice
Martin Ayotte
@martinayotte
@skorokithakis , so, another 6 weeks before receiving your L298N ... :-(
Stavros Korokithakis
@skorokithakis
yes :(
the slow boat is so slow
it's too bad, i wrote a program to capture events so i could control the rc car from the pc's keyboard arrows and it was working fine when the car was in the air
wheels turning and everything
Martin Ayotte
@martinayotte
Light up some candles, maybe it will arrive in 4 weeks :-)
Stavros Korokithakis
@skorokithakis
set it down, bam, smoke
haha
i have a shrine :P
@martinayotte another issue is that the esp was getting disconnected from the wifi a lot
could it be interference from the motor?
Martin Ayotte
@martinayotte
I don't know ... maybe glitch on power. try adding more caps.
tzapu
@tzapu
i don t think i ve ever seen a discussion related to building something aroudn the ESP where more caps was not mentioned… moooore caps :P
Stavros Korokithakis
@skorokithakis
hahaha yes
hmm it might have been a power glitch, good call
thanks
the good thing about that is that it has a power supply by itself
so you give it 9v and it gives you 5 back, which his well in range of the ldo
Martin Ayotte
@martinayotte
Yes, If you remember, that was the one I've suggested 2 months ago, but at that time, you felt it was a bit too big.
Stavros Korokithakis
@skorokithakis
did i? well, sucks to be me :(
Ivan Kravets
@ivankravets
@tzapu of course, you should add #include <Arduino.h> on the top of file if use Arduino framework
Stavros Korokithakis
@skorokithakis
@martinayotte oh, it was because the one i got could drive two motors, i didn't notice the amperage