Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Bryant Eisenbach
    @fubuloubu
    The vyper package now exposes compile_code(src_code_str, output_format=['abi', 'bytecode', ...])
    And I also think a version for compiling multiple contracts
    arjuna sky kok
    @arjunaskykok_gitlab
    @fubuloubu Now that vyper have better and easier interfaces, does it mean developing framework like populus and twig-eth has lower priority?
    Mikko Ohtamaa
    @miohtama
    @arjunaskykok_gitlab Not sure if Vyper is production grade language any time soon - the most of the world still runs pretty much on Solidity
    Bryant Eisenbach
    @fubuloubu
    I would say it's starting to be, with UniSwap release and all
    we definitely need more exterior tooling and a way to compile with older versions
    but no, I would say the interface makes it easier to work with frameworks
    frameworks are supposed to take some of the orchestration weight off the SC developer IMO
    twig adds Vyper as a first class citizen
    Jacques Wagener
    @jacqueswww
    @arjunaskykok_gitlab ethereum/populus#484
    I created a fix for it when vyper changed it's interface (30 November 2018)
    The CI seems failed on the PR's
    So the bigger problem is no one is really merging/reviewing PR's on populus anymore : /
    arjuna sky kok
    @arjunaskykok_gitlab
    @jacqueswww Thank you for the fix! Could you merge the PR because @voith has retired? I am trying to avoid telling the readers to patch Populus in my book. :)
    Also there is still bug in Populus' setup.py because web3.py new version breaks compatibility. I mean I can avoid the bug by installing other packages first like:
    pip install eth-abi==1.2.2
    pip install eth-typing==1.1.0
    pip install web3==4.7.2
    But it's less polished.
    After finishing the book, I'll set some time to give some love to Populus.
    Jacques Wagener
    @jacqueswww
    I don't have merge rights sorry
    Voith Mascarenhas
    @voith
    I will try to review it today
    Voith Mascarenhas
    @voith
    before merging the jacques’s PR I want to drop python 3.5 support because vyper only supports python>=3.6 and there have been some compatibility issues with python3.5.
    Currently, vper tests in populus don’t run on CI. After dropping python3.5 support, I will add vyper as optional dependency to setup.py and will then enable the tests that are skipped.
    This will help test jacques PR.

    @voith has retired?

    I am not a memeber of the ethereum foundation. I was only contributing in my free time. I took some time off to pursue my hobby. [OFF TOPIC] you can find out what I was doing in my spare time here :D

    Voith Mascarenhas
    @voith
    I was planning to return back to ethereum this month, but was lacking motivation.
    @arjunaskykok_gitlab your ping should get me started.
    SiddharthMalhotra
    @SiddharthMalhotra
    FileNotFoundError: [Errno 2] No such file or directory: 'solc'
    How do I install version 0.4.17 for populus?
    subprocess.CalledProcessError: Command '['make']' returned non-zero exit status 2.
    arjuna sky kok
    @arjunaskykok_gitlab
    @SiddharthMalhotra What is your OS?
    @voith Glad to have you come back. I am waiting impatiently for your fix. After finishing my book, I can help you polish Populus. There are some features that I think would be useful for programmers.
    Voith Mascarenhas
    @voith
    @SiddharthMalhotra. The solc binary is not installed by default. Please read through the solidity docs for instructions on installing the solc compiler: https://solidity.readthedocs.io/en/v0.5.2/installing-solidity.html
    @SiddharthMalhotra Thank you. I will send a fix tonight(IST), I promise.
    Voith Mascarenhas
    @voith

    @SiddharthMalhotra Thank you. I will send a fix tonight(IST), I promise.

    * meant to ping @arjunaskykok_gitlab

    arjuna sky kok
    @arjunaskykok_gitlab
    @voith Hi Voith, any idea when you could commit the fix? Thanks before.
    SiddharthMalhotra
    @SiddharthMalhotra
    ImportError: cannot import name 'force_text'
    Please help
    Mikko Ohtamaa
    @miohtama
    @SiddharthMalhotra wrong package version somewher
    can you do pip freeze and also add full traceback
    SiddharthMalhotra
    @SiddharthMalhotra
    @miohtama I got it
    pip install eth-abi==1.2.2
    pip install eth-typing==1.1.0
    pip install web3==4.7.2
    pip install -e git+https://github.com/ethereum/populus#egg=populus
    It seems like only these version are accepted when running 0.4.25 solc
    Voith Mascarenhas
    @voith
    @arjunaskykok_gitlab So sorry mate, I totally forgot about the promise I made.
    Can’t do it today. Please ping me again if I don’t by next week.
    Thank you for your patience!
    @SiddharthMalhotra Check your eth-utils version
    Voith Mascarenhas
    @voith
    @arjunaskykok_gitlab Until I fix it, will it be possible for you to install populus from PR ethereum/populus#484
    avatar-lavventura
    @avatar-lavventura
    Can we still open a issue? //I was wondering how could we provide arguments to a constructor function as on the Greeter example, is it possible? something like: chain.provider.get_or_deploy_contract('Greeter', arguments=['Hello')
    Mikko Ohtamaa
    @miohtama
    @avatar-lavventura You can provide - AFAIK
    I have deployed many many contracts with constructor arguments
    avatar-lavventura
    @avatar-lavventura
    @SiddharthMalhotra I am getting following error: pkg_resources.ContextualVersionConflict: (eth-typing 1.1.0 (/Users/alper/env/lib/python3.7/site-packages), Requirement.parse('eth-typing<3.0.0,>=2.0.0'), {'eth-abi'}) The way I install populus is: pip install git+git://github.com/ethereum/populus.git@2ab03fea0d0e2881c80698d2a349a74cc6c953d3 hash refers the 2 commits behind the master
    Voith Mascarenhas
    @voith
    @avatar-lavventura The requirements have not been updated in a while. There might be some conflicting dependencies. populus is no longer maintained. And I don’t have the time to fix it myself either.
    avatar-lavventura
    @avatar-lavventura

    @voith :
    If you have a working requirement.txt for version v0.4.25 from your comment (https://github.com/ethereum/populus/issues/450#issuecomment-411283048) it will be pretty helpful. If not thanks anyway.

    The way I install the latest populus version is 2 commits behind the master: pip install git+git://github.com/ethereum/populus.git@2ab03fea0d0e2881c80698d2a349a74cc6c953d3

    Voith Mascarenhas
    @voith
    @avatar-lavventura I don’t have one. I no longer use it.
    Also looking at populus master the library has been sunsetted.
    avatar-lavventura
    @avatar-lavventura
    @voith okay
    avatar-lavventura
    @avatar-lavventura
    I will stick with using populus that only works v0.4.18 for populus=2.2.0