by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Feb 15 2018 02:52
    @jpitts banned @awdawdwawad
  • Nov 17 2017 21:02
    @jpitts banned @Muskyyyy
  • Nov 17 2017 21:02
    @jpitts banned @MuskyHusky1
  • Oct 21 2017 21:23
    @jpitts banned @Musk11
Daniel Hodali
@daniel_hodali_twitter
This message was deleted
Daniel Hodali
@daniel_hodali_twitter
I would like to run the example on https://github.com/ethereum/wiki/wiki/Ethash. I need the library, which contains the structure for the variable "block", "header", ...
Erika
@SkyLotus
Need help!
Nick Savers
@nicksavers
With what?
Erika
@SkyLotus
I'm trying to run an ethereum node through the pyethapp
when i follow the instructions here https://github.com/ethereum/pyethapp
I get this error
(pyeth) user@freegeekchicago:~/pyethapp$ pyethapp run
Traceback (most recent call last):
File "/home/user/.virtualenvs/pyeth/bin/pyethapp", line 6, in <module>
from pkg_resources import load_entry_point
File "/home/user/.virtualenvs/pyeth/local/lib/python2.7/site-packages/pkg_resources/init.py", line 3144, in <module>
@_call_aside
File "/home/user/.virtualenvs/pyeth/local/lib/python2.7/site-packages/pkg_resources/init.py", line 3128, in _call_aside
f(args, *kwargs)
File "/home/user/.virtualenvs/pyeth/local/lib/python2.7/site-packages/pkg_resources/init.py", line 3157, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/home/user/.virtualenvs/pyeth/local/lib/python2.7/site-packages/pkg_resources/init.py", line 668, in _build_master
return cls._build_from_requirements(requires)
File "/home/user/.virtualenvs/pyeth/local/lib/python2.7/site-packages/pkg_resources/init.py", line 681, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/home/user/.virtualenvs/pyeth/local/lib/python2.7/site-packages/pkg_resources/init.py", line 870, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'ipython<6.0.0,>=5.4.0' distribution was not found and is required by pyethapp
Nick Savers
@nicksavers
What have you tried?
Erika
@SkyLotus
I've tried
lemme see...
Erika
@SkyLotus
I looked at a couple issues in the pull requests
some other people had this problem and suggested updating the files in the requirements
requirements.txt
this didn't seem to fix it
Nick Savers
@nicksavers
Which version of ipython do you have installed?
Samuel Guyah.
@ChiefMateStarbuck
Hello everyone. I am curious to know if python3 support is under way or has even begun. I am a very new python3 developer and would like to give some time to this project. I understand that pyethhapp’s dependencies - pyethereum and pydevp2p - support python3, so I am very curious as to why the development of this app hasn’t moved in that direction as well. Any response is welcome. Thank you for your time.
Gget
@ggettsel_twitter
Hi. I can't find information how read data from contracts inside network. Can help me anyone?
Ilko
@kachar
Hey guys,
I'm hitting a hard rock here. Not being able to fulfill the dependencies on Ubuntu 16.04.3 LTS
$ pip install ethereum==2.1.1
Collecting ethereum==2.1.1
  Using cached ethereum-2.1.1.tar.gz
    Complete output from command python setup.py egg_info:
    error in ethereum setup command: 'tests_require' must be a string or list of strings containing valid project/version requirement specifiers; Unordered types are not allowed

Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-vbe7FL/ethereum/
Same issue as reported in ethereum/pyethapp#276
Gourav Pathela
@gpathela
@kachar Have you found any solution for the problem or not ?
Ilko
@kachar
@gpathela not really... I went with the geth after all...
eumend
@eumend
@kachar a bit late but I found the same problem and solved it by installing an alpha version, as described here: ethereum/pyethapp#275
Rishabh
@rishabh2d
Hey everyone. What resources (books/courses/guides) would you recommend I use, to begin using the ETH blockchain (or any other Blckchn) to develop decentralized applications?
Andrew Redden
@androolloyd
for the casper FFG testnet, I get WARNING:pow mining_hash does not match
everytime I find a nonce
Vikram Singh
@Gujjar95
Traceback (most recent call last):
File "/home/gujjar/pyethapp/bin/pyethapp", line 7, in <module>
from pyethapp.app import app
File "/home/gujjar/pyethapp/local/lib/python2.7/site-packages/pyethapp/app.py", line 19, in <module>
from ethereum import blocks
ImportError: cannot import name blocks
i am getting this error on run
fgadaleta
@fgadaleta
pyethapp (develop) is not syncing to main nor test (i am on pyethereum develop branch)
is there any known issue?
fgadaleta
@fgadaleta
@heikoheiko current pyethapp work on PV62. Is that the reason why it never sync as geth?
fgadaleta
@fgadaleta
pyethapp gets stuck on
NFO:eth.sync.task downloaded 123296 blockheaders start=#4370001 8a3fb8b4 end=#4246706 f4c72d28
same block even if i restart
gewuxy
@gewuxy
hello
gewuxy
@gewuxy
ImportError: cannot import name blocks
eyes
@buster2015
hello anybody
wo want to learn blockchain
i want to learn blockchain
eyes
@buster2015
do u have some files to instruct
richbram
@richbram
I know this is not everyone's favorite topic, but I have been hacking through getting pyethapp running on windows 10. I would say I am 90% there, but am having same problems get pyethash to build (using MGWIN) and for the setup script to recognize that I have a running leveldb environment and skip that build. I was able to find a bunch of helpful posts to get me this far, but I am still short. Anyone want to help me? I am willing to put together a HOWTO document once it works.
richbram
@richbram
i made some more progress today, got pyehash to build
now working on an error installing miniupnpc
richbram
@richbram
seems dead here, guess I'll go try with geth
Simran Kedia
@simrankedia

Hi,
I am trying to setup pyethapp development environment. I used
($ mkvirtualenv pyethapp)
$ git clone https://github.com/ethereum/pyethapp
$ cd pyethapp
$ USE_PYETHEREUM_DEVELOP=1 python setup.py develop

However, I am getting the error as:
Writing /var/folders/rp/l3y_m3392dqcgc_77m8f_ks00000gn/T/easy_install-9ohquD/ethereum-2.1.1/setup.cfg
Running ethereum-2.1.1/setup.py -q bdist_egg --dist-dir /var/folders/rp/l3y_m3392dqcgc_77m8f_ks00000gn/T/easy_install-9ohquD/ethereum-2.1.1/egg-dist-tmp-tW2_JB
error: Setup script exited with error in ethereum setup command: 'tests_require' must be a string or list of strings containing valid project/version requirement specifiers; Unordered types are not allowed

Can someone please help?

Muhammad Faizan
@faizan2590
@simrankedia Hi, I also tried am getting the same error. If you by any chance figure out the solution.
cai
@DevinCai
hi
Sai Chaitanya Tirumerla
@stirumer
hey @simrankedia , @faizan2590 - I manually installed ethereum == 2.3.0 from https://pypi.python.org/simple/ethereum/ and change requirements.txt file with ethereum=2.3.0 instead of 2.1.1 and pycryptodome=3.4.7. Try again to install
Kevin Carter
@tidymonkey81
is pyethapp:master the most stable branch?
Sai Chaitanya Tirumerla
@stirumer
@tidymonkey81 i would guess so - i used develop branch though , i havent had any problems.
alchemist
@pblin
Anyone knows about this problem?
running app.py from PyCharm
from . import config as app_config
ValueError: Attempted relative import in non-package
Sai Chaitanya Tirumerla
@stirumer
hey @pblin - how are you running it, do you see the same issue when you are running as python pyethapp/app.py or just running as python app.py