These are chat archives for ethereum/tutorials

4th
Nov 2018
Jeffrey Anthony
@jeffanthony
Nov 04 2018 22:01
@dave90dave nowadays the solidity compiler expects the contract to begin with pragma solidity ^0.4.25 //or whatever solidity version you're using.
as solidity matures as smart contract code (currently 0.5.0 iirc) the pragma number will tell the compiler which version of the compiler to use
@molive14 & @DAppster87 it's likely you're not passing the arguments correctly, not enough arguments, or not at all
Tip: it is simpler to initialize your attributes directly within the contract