These are chat archives for etlegacy/etlegacy

22nd
Dec 2016
Christophe Mateos
@Mateos81
Dec 22 2016 09:48
CMake:
Will build dynamic renderer libraries
CMake Error at cmake/ETLBuildRenderer.cmake:139 (MESSAGE):
The fallbackshader source file was not created due to "sed" missing. The
build would fail. :(
Call Stack (most recent call first):
CMakeLists.txt:161 (include)
I believe it isn't pointed that sed is required in readme.md
I guess?
IR4T4
@IR4T4
Dec 22 2016 09:53
I do remember it was mentioned somewhere ^^
Christophe Mateos
@Mateos81
Dec 22 2016 09:54
Forget about it, "If the build fails during libcurl compilation because of missing sed utility, download it from GnuWin"
the thing is it happens even earlier in fact, during cmake process x)
IR4T4
@IR4T4
Dec 22 2016 09:55
yepp found it too
Christophe Mateos
@Mateos81
Dec 22 2016 10:06
Another note for Windows: Add Sed to the PATH
Christophe Mateos
@Mateos81
Dec 22 2016 10:24
side note: cmake always had issues to download the ob zip package for some reason
stops around 7%
Christophe Mateos
@Mateos81
Dec 22 2016 10:44
Is there any reason I can't enable flags or FPS counter?
they just stay on No in the View menu
oh well the whole view menu is like this in fact
(I'm testing with the French language if that matters)
only the yes/no entries
rest looks ok
IR4T4
@IR4T4
Dec 22 2016 12:13
it's a bug ... gonna fix it
hmm YESNO field is bugged in general
Christophe Mateos
@Mateos81
Dec 22 2016 12:17
ok
IR4T4
@IR4T4
Dec 22 2016 12:17
please file it
Christophe Mateos
@Mateos81
Dec 22 2016 12:30
in the bug tracker?
IR4T4
@IR4T4
Dec 22 2016 12:32
jepp
IR4T4
@IR4T4
Dec 22 2016 12:53
@Mateos81 found and fixed ... no need to file it
Christophe Mateos
@Mateos81
Dec 22 2016 12:53
gut
Christophe Mateos
@Mateos81
Dec 22 2016 14:30
wasn't that raising some warning for type issue? x)
IR4T4
@IR4T4
Dec 22 2016 14:36
warning vs bug -> bug wins
:)
Christophe Mateos
@Mateos81
Dec 22 2016 14:36
:P
OK now some are on No while before I had all on yes, and I can switch them
IR4T4
@IR4T4
Dec 22 2016 14:37
foliage is created by shaders only ?
Christophe Mateos
@Mateos81
Dec 22 2016 14:37
the foliage tech used in Radar, yes$
IR4T4
@IR4T4
Dec 22 2016 14:37
and on other maps ?
Christophe Mateos
@Mateos81
Dec 22 2016 14:38
either manually placed models by the mapper or the shader instruction introduced in ET
Dominator56
@Dominator56
Dec 22 2016 14:38
some use the same thing and some maps use models I think
Christophe Mateos
@Mateos81
Dec 22 2016 14:38
Could someone check in Host menu if you can tick/untick FF/Antilag etc. on obj mode? ^^'
IR4T4
@IR4T4
Dec 22 2016 14:39
as far as I can see foliage shaders in r2 are buggy or not executed
Dominator56
@Dominator56
Dec 22 2016 14:39
how buggy?
IR4T4
@IR4T4
Dec 22 2016 14:39
they are not visible
it's an old known issue
Christophe Mateos
@Mateos81
Dec 22 2016 14:39
r_foliage on?
IR4T4
@IR4T4
Dec 22 2016 14:41
this var is not implemented
Christophe Mateos
@Mateos81
Dec 22 2016 14:41
(is snow atmospheric effect replaced by ash or wut)
oh
or r_drawfoliage I don't remember
Dominator56
@Dominator56
Dec 22 2016 14:41
atmospheric effects go throught walls now :D
Christophe Mateos
@Mateos81
Dec 22 2016 14:42
^ I don't have this on Rail Gun
IR4T4
@IR4T4
Dec 22 2016 14:42
same here
atm is fine
Dominator56
@Dominator56
Dec 22 2016 14:42
on radar
bunker
Christophe Mateos
@Mateos81
Dec 22 2016 14:45
nope
checked the 3 entrances, the rain is only outside
Dominator56
@Dominator56
Dec 22 2016 14:45
well for me the rain goes throught the bunker for some reason
let me compile latest again
twt_thunder
@thunderpwn
Dec 22 2016 16:39
foliage is prob a shader issue for r2.. I will find the shader and have a look at it
just need to grab some food first :)
Christophe Mateos
@Mateos81
Dec 22 2016 16:48
how/why
the shader system is an interface to opengl real shaders
it's a shorcut allowing mappers to do advanced stuff
if it works for the base, the instruction I mean, it should with OpenGL 2
or there's been some compatibility-breaking change between version 1 and 2
twt_thunder
@thunderpwn
Dec 22 2016 16:52
I dont know @Mateos81 , but I remember that some blendfuncs and some alpha stuff didnt work as expected when I troubled with mapobjects
Christophe Mateos
@Mateos81
Dec 22 2016 16:54
the same shader instruction, depending on the OpenGL version it runs on?
twt_thunder
@thunderpwn
Dec 22 2016 16:59
yep