These are chat archives for etorreborre/specs2

10th
Feb 2016
Ross A. Baker
@rossabaker
Feb 10 2016 05:58
Has anybody tried specs2 + scalaz-stream-0.8a yet? I'm getting incompatible class errors, and I suspect it's from specs2's dependency on scalaz-stream-0.8. I think the scalaz-7.2 build can depend on 0.8a now.
Ross A. Baker
@rossabaker
Feb 10 2016 07:25
It looks like there is also a problem with scalaz-scalacheck-binding (built on scalacheck-0.12) and specs2 (built on scalacheck-0.13).
Ross A. Baker
@rossabaker
Feb 10 2016 17:37
force() on scalaz-stream-0.8a dependency seems to have worked. I still don't yet understand what made my scalacheck problem disappear.
force() is necessary because 0.8a < 0.8.