These are chat archives for etorreborre/specs2

2nd
Aug 2018
vito-c
@vito-c
Aug 02 2018 03:27
3.9.5 specs2
Eric Torreborre
@etorreborre
Aug 02 2018 07:55
Can you upgrade then?
vito-c
@vito-c
Aug 02 2018 16:37
when I upgrade I get :
Symbol 'type org.specs2.time.NoTimeConversions' is missing from the classpath.
[error] This symbol is required by 'trait play.api.test.PlaySpecification'.
[error] Make sure that type NoTimeConversions is in your classpath and check for conflicting dependencies with `-Ylog-classpath`.
[error] A full rebuild may help if 'PlaySpecification.class' was compiled against an incompatible version of org.specs2.time.
[error] class FooSpec extends PlaySpecification {
[error]                  ^
Eric Torreborre
@etorreborre
Aug 02 2018 16:39
This means that you should upgrade your version of Play as well to something more recent
vito-c
@vito-c
Aug 02 2018 16:42
yah I'm working on doing that but it's a rather involved process
:)
Eric Torreborre
@etorreborre
Aug 02 2018 16:43
I guess,… good luck with your upgrade
vito-c
@vito-c
Aug 02 2018 16:56
thanks

i have an upgrade question for you though:

 type mismatch;
[error]  found   : org.specs2.matcher.SomeMatcher[MyClass]
[error]  required: org.specs2.matcher.Matcher[scala.concurrent.Future[Option[MyClass]]]
[error]       ) must beSome[MyClass] eventually
[error]                    ^

this used to work but doesn't after I upgraded to 3.9.5