These are chat archives for eventum/eventum

28th
Oct 2015
Elan Ruusamäe
@glensc
Oct 28 2015 09:11
did it (#83) get solved then? post some details!
Chuck
@cmiller1111
Oct 28 2015 16:11
no unfortunately not yet, I haven't been able to identify the problem as there are definitely email accounts attached to these issues
Craig
@cpinfold
Oct 28 2015 16:14
I suggest we troubleshoot bottom, up. The error you are getting appears to indicate there are no recipients. Are you able to run a SQL query?
Something like: select * from eventummail_queue order by maq_iss_id desc limit 1; (Note my table prefix is eventum and you may need to replace or eliminate this prefix)
OR select * from eventummail_queue order by maq_iss_id = 2184; (The specific issue that is not emailing) If you want to obfuscate domain info, please just replace text (not delete) I am assuming no special characters/unicode in the email addresses?
Not sure why, the chat client ate the _ between eventum and mail_queue.
Chuck
@cmiller1111
Oct 28 2015 17:34
here's what I received when running that query
mysql> select * from mail_queue order by maq_iss_id desc limit 1;
+--------+------------+---------------------+------------+---------------+-----------------------+---------------+-----------------------------------+---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+-----------+------------+-------------+
| maq_id | maq_iss_id | maq_queued_date | maq_status | maq_save_copy | maq_sender_ip_address | maq_recipient | maq_subject | maq_headers | maq_body | maq_type | maq_usr_id | maq_type_id |
+--------+------------+---------------------+------------+---------------+-----------------------+---------------+-----------------------------------+---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
won't let me post the whole thing here, i'll post it back in the forum
eventum/eventum#83
Craig
@cpinfold
Oct 28 2015 18:05
From what you provided the maq_recipient field is empty (unless you deleted the text?) That shouldn't be possible, however it means that _sendEmail isn't the issue. Bryan , Elan, any ideas?
Chuck - I don't know if this may be related.. but to check, did you run the database update scripts per the UPGRADE.md file? Ie. php upgrade/update-database.php
Elan Ruusamäe
@glensc
Oct 28 2015 18:10
well, i told to look here already yesterday: https://github.com/eventum/eventum/issues/83#issuecomment-151649173
and worth double checking if all db patches are applied, but imho those tables aren't updated for long time. but then 2.3 version is rather old too
Elan Ruusamäe
@glensc
Oct 28 2015 19:36
maq_recipient is empty, you need to figure out why