pretty much exactly the same, only difference being one acting roughly like a statement, the other being a dedicated branch in control flow, which most linting tools complain about if you have it all on one line :u
@Summertime I would probably just advise rewriting the above as
if (seen_count >= 30or ago(post.created) > 3 * months
ornot (hasattr(post, 'preview') and'images'in post.preview)):
I'm not averse to adding syntax like that to Coconut, but I wouldn't want to do so unless we could find use cases where it was clearly better than just using vanilla Python, and it doesn't seem to me like this clearly is.