These are chat archives for evhub/coconut

4th
Jul 2018
Jason O.
@puruzio
Jul 04 2018 01:12
Thanks @eindiran for looking into this. Yes, using the non-development branch, I get the same results as yours.
I’m not sure what you mean by “2.7 and 3.6 version of coconut(-develop)”.
The version I’m using is "coconut-develop-1.3.1.post0.dev28” Are there different versions of this for different python versions? (2.7 vs 3.6)?
Elliott Indiran
@eindiran
Jul 04 2018 01:21
That is also the version I was using. My comment about 2.7 versus 3.6 was that there is different python version information printed depending on which version of pip you used to install coconut. I had wondered if you could get the behavior to happen in one but not the other, but for me the behavior was identical.
balajeerc
@balajeerc
Jul 04 2018 02:53
Are there plans to improve the REPL? Basically, I expect that people using the lang would end up spending a lot of time in it and would need enhancements like arrow keys to recall previously invoked statements, shortcut to re-import the module once it has changed etc.
Jason O.
@puruzio
Jul 04 2018 03:54
@eindiran I see. thanks anyway.
yggdr
@yggdr
Jul 04 2018 12:49
@puruzio @eindiran I can reproduce this behaviour in coconut-develop "1.3.1-post_dev28 [Dead Parrot]" running on python 3.6.5 in a virtualenv, and in a virtual machine, both times installed via a pip version tied to python 3.6. I just ran the version from github, same bug. Elliott, how did you install coconut?
Jason O.
@puruzio
Jul 04 2018 14:28
@yggdr That’s good to know. Thanks for trying