These are chat archives for exceptionless/Discuss

15th
Jul 2015
rajan bhayana
@rajanbhayana
Jul 15 2015 04:07
@niemyjski way past tht. have UI and API working on same machine now. just struggling with the clients now. so to test, i have made a account using UI. then i check the same using swaggerUI to see if UI and API are connected and i get a token back. so i am assuming. that UI and API are well connected. now my client is trying to hit the api. no error thrown. but when I go to dashboard. nada. have updated API key and serverurl on my clients. tried sample console , web and window app. not working. so wondering where i am going wrong. is there any API log generated on server that i can check to see if messages were received and saved?
Blake Niemyjski
@niemyjski
Jul 15 2015 04:08
.You can enable logging via the nlog config
What I would check for is to see if the app data folder has queued items and check redis if you are using it for queued items
Are your running the jobs in process?
rajan bhayana
@rajanbhayana
Jul 15 2015 04:10
there is something in app_Date/q folder.
jobs. umm. no.
rajan bhayana
@rajanbhayana
Jul 15 2015 04:44
there is data in storage folder and its updated regularly. api show me data. i think the error is somewhere here. my API is on port 80 and ui on 8081. so its a cross origin error.
EventSource cannot load http://exceptionlessvm.cloudapp.net/api/v2/push/reconnect?transport=serverS…9syltJMKhs%3D&connectionData=%5B%7B%22name%22%3A%22messages%22%7D%5D&tid=0. No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://exceptionlessvm.cloudapp.net:8081' is therefore not allowed access. The response had HTTP status code 500.
rajan bhayana
@rajanbhayana
Jul 15 2015 05:26
2015-07-15 05:21:04.2008|ERROR|AppBuilder|Unable to load the insulation assembly.
2015-07-15 05:21:21.1239|INFO|AppBuilder|Starting api...
2015-07-15 05:21:22.4509|WARN|AppBuilder|Jobs running in process.
2015-07-15 05:25:06.5095|INFO|EventPostsJob|Processing post: id=5f29a5f1bf6948a89713a44537c30e56 path=q\d7214c4321f149cf854c7618dcb6f335.json project=55a5c4af02bbc40fc48feaf8 ip= v=2 agent=exceptionless/2.0.0
2015-07-15 05:25:06.7905|INFO|EventPostsJob|Parsed 10 events for post: id=5f29a5f1bf6948a89713a44537c30e56
2015-07-15 05:25:08.1487|ERROR|EventPostsJob|Error while processing event post "q\d7214c4321f149cf854c7618dcb6f335.json": MapperParsingException[failed to parse]; nested: ElasticsearchIllegalArgumentException[failed to execute script]; nested: ScriptException[scripts of type [inline], operation [mapping] and lang [groovy] are disabled];
Blake Niemyjski
@niemyjski
Jul 15 2015 11:32
Ahh two thinngs
You need to use our elastic search yml config that's in the repo
Dynamic scripting needs to be enabled for posts to be processed
The base url on the app.config.js needs to be your Ali end point and not the Ui project
Blake Niemyjski
@niemyjski
Jul 15 2015 15:50
@rajanbhayana where you able to get this working?
rajan bhayana
@rajanbhayana
Jul 15 2015 23:06
@niemyjski yes. thanks heap for all the help. got it working after moving yml file. the only issue i see is on the invite module. keep getting 404 so checking that. post that. all is good. just one question. i get redis and elasticSearch, but is mangoDB still required. it was on the article i followed for setup.