These are chat archives for exceptionless/Discuss

9th
Nov 2015
Adam Zolotarev
@adamzolotarev
Nov 09 2015 19:19
think there may be an issue with IE - the UI doesn't refresh itself unless you have Developer Tools open. Wonder if it's something like this - http://stackoverflow.com/questions/31251720/ie-11-signalr-not-working . No issues in Chrome
I'm using IE 11 and the latest release of Exceptionless
Blake Niemyjski
@niemyjski
Nov 09 2015 19:21
Hmm any errors ?
Adam Zolotarev
@adamzolotarev
Nov 09 2015 19:22
Console shows SCRIPT5: Access is denied.
File: channel.html, Line: 1, Column: 1
and as soon as I open IE DevTools, everything starts working
Blake Niemyjski
@niemyjski
Nov 09 2015 19:26
Hmm what about edge?
What os?
I can try. Have you tried different machines
Adam Zolotarev
@adamzolotarev
Nov 09 2015 19:28
haven't tried edge. Using Windows 7 Professional
tried on a different machine as well (the same OS and IE 11)
Blake Niemyjski
@niemyjski
Nov 09 2015 19:29
Do you have any extensions?
Installed*?
Adam Zolotarev
@adamzolotarev
Nov 09 2015 19:32
Shockwave, OneNote, some SharePoint-related extensions
Blake Niemyjski
@niemyjski
Nov 09 2015 19:33
Any errors in the network tab?
Channel.html seems like an error with an extension I'll google it when I get back from lunch
Adam Zolotarev
@adamzolotarev
Nov 09 2015 19:36
hmm fiddler shows 401 when trying to access POST //api/v2/events?access_token=... .
if you can't reproduce, maybe it's just something with my local setup or IIS
Blake Niemyjski
@niemyjski
Nov 09 2015 19:59
That would be caused by the Ui trying to post exceptionless events to your server but the Api key is invalid
You can set that in app.config.js
Adam Zolotarev
@adamzolotarev
Nov 09 2015 20:02
Yeah, it iset (EXCEPTIONLESS_API_KEY) - the same value as in web.config
Blake Niemyjski
@niemyjski
Nov 09 2015 20:03
But does it match an Ali key of one of your projects
If create a new project called exceptionless and have them log there
Adam Zolotarev
@adamzolotarev
Nov 09 2015 20:06
oh, didn't realize that part. Does it matter which projects if I have multiple ones?
Adam Zolotarev
@adamzolotarev
Nov 09 2015 20:13
Ok, 401 went away. But IE is still not refreshing
Blake Niemyjski
@niemyjski
Nov 09 2015 20:13
Weird
Adam Zolotarev
@adamzolotarev
Nov 09 2015 20:15
it's IE for you. Alright, i'll keep digging. Thanks for your help!
Do you have web sockets enabled on your server?
Adam Zolotarev
@adamzolotarev
Nov 09 2015 20:17
yeap, checked that
Adam Zolotarev
@adamzolotarev
Nov 09 2015 20:27
So, I added Cache-Control:no-cache, no-store
and Pragma:no-cache
at the IIS level
that seemed to fix it
do you by chance know of any reason why I wouldn't want to add those?
Blake Niemyjski
@niemyjski
Nov 09 2015 20:31
Hmm
You wouldn't get any caching so you'd do more requests
Adam Zolotarev
@adamzolotarev
Nov 09 2015 20:39
But if you receive new exceptions say every 30 seconds or so, would you care about caching at all? Assuming you want to see new exceptions as soon as they happen. As I understand, it disables client-side caching only
Blake Niemyjski
@niemyjski
Nov 09 2015 21:12
yeah you have a good point
just speeds up the ui a bit
we do it to cut down on the number of requests and keep the ui fast
we just use restangular and it handles caching
Eric J. Smith
@ejsmith
Nov 09 2015 21:13
are you talking about the api responses?
Blake Niemyjski
@niemyjski
Nov 09 2015 21:13
but our websockets should be getting called and that will invalidate cache
Eric J. Smith
@ejsmith
Nov 09 2015 21:14
the api responses shouldn’t be cached.
Adam Zolotarev
@adamzolotarev
Nov 09 2015 21:17
i think that's what was happening in IE for me (api responses were getting cached).
Blake Niemyjski
@niemyjski
Nov 09 2015 21:20
we only cache some api repsonses
we rely on the message bus to clear these caches
/signalr
do you have web sockets enabled?
Adam Zolotarev
@adamzolotarev
Nov 09 2015 21:22
As far as I can tell - I went to Server Roles - Web Server (IIS) - Web Server - Application Development - WebSocket Protocol - it's checked
Blake Niemyjski
@niemyjski
Nov 09 2015 21:25
yeah that should be fine
your running 3.1?
Adam Zolotarev
@adamzolotarev
Nov 09 2015 21:26
yeap - the latest release. UI - 2.2.566
Blake Niemyjski
@niemyjski
Nov 09 2015 21:28
I’ll try and reproduce
It’s working over here on windows 10 ie11
nothing in console
can you try in a add-in free environment
Adam Zolotarev
@adamzolotarev
Nov 09 2015 21:37
do you by chance have the dev tools closed when you try it? It works fine when the dev tools is open.
I'll try it in add-in free browser. Probably tomorrow. Thanks!
Blake Niemyjski
@niemyjski
Nov 09 2015 21:40
yeah
never opeend them
please keep me updated
I don’t have any addins installed
still works (multi instances)