These are chat archives for fgrehm/vagrant-lxc

9th
Mar 2016
LeyluIAA
@LeyluIAA
Mar 09 2016 08:20
Hi all, i have difficulties to install the vagrant-lxc plugin:

vagrant plugin install vagrant-lxc give me an error :

Bundler, the underlying system used to manage Vagrant plugins,
is reporting that a plugin or its dependency can't be found.
This is usually caused by manual tampering with the 'plugins.json'
file in the Vagrant home directory. To fix this error, please
remove that file and reinstall all your plugins using vagrant plugin install.
/opt/vagrant/embedded/gems/gems/bundler-1.7.9/lib/bundler/resolver.rb:368:in resolve': Could not find gem 'vagrant-lxc (>= 0) ruby' in the gems available on this machine. (Bundler::GemNotFound) from /opt/vagrant/embedded/gems/gems/bundler-1.7.9/lib/bundler/resolver.rb:166:instart'
from /opt/vagrant/embedded/gems/gems/bundler-1.7.9/lib/bundler/resolver.rb:129:in resolve' from /opt/vagrant/embedded/gems/gems/bundler-1.7.9/lib/bundler/definition.rb:193:inresolve'
from /opt/vagrant/embedded/gems/gems/bundler-1.7.9/lib/bundler/definition.rb:132:in specs' from /opt/vagrant/embedded/gems/gems/bundler-1.7.9/lib/bundler/definition.rb:177:inspecs_for'
from /opt/vagrant/embedded/gems/gems/vagrant-1.7.1/lib/vagrant.rb:76:in <top (required)>' from /opt/vagrant/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:135:inrequire'
from /opt/vagrant/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:135:in rescue in require' from /opt/vagrant/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:144:inrequire'
from /opt/vagrant/bin/../embedded/gems/gems/vagrant-1.7.1/bin/vagrant:105:in `<main>'

I tried to rm plugins.json and reinstall the plugins but it does not change anything. Does someone has an idea ?