These are chat archives for fieldpapers/fieldpapers

29th
Mar 2016
Ian Ross
@ian-ross
Mar 29 2016 11:58
@mojodna Message from rbanick that appeared in our Gitter room: hi field papers lovers. we're getting an "Atlas Creation Failed" error when we try to create an atlas. Could someone look into it? It's a little urgent as we have some field surveys starting tomorrow.
Robert Banick
@rbanick
Mar 29 2016 12:28
hi @ian-ross sorry -- internet problems at my previous location meant I thought I was posting to here
and yes, our team is reporting some atlas creation problems
Alan McConchie
@almccon
Mar 29 2016 13:32
@rbanick @ian-ross @mojodna I'm about to get on a plane, but I'll try to restart the server now
Okay, I think I just triggered a restart. Let us know if it starts working again in a few minutes. If not, @mojodna can probably debug in a couple hours.
Robert Banick
@rbanick
Mar 29 2016 14:45
I'm still getting an "Atlas Creation Failed" with this: http://fieldpapers.org/atlases/2zigye1o
wah wah :(
a couple hours is OK though, don't panic. we have backup plans.
Alan McConchie
@almccon
Mar 29 2016 15:09
I'm not sure if an in-process atlas would survive reboots. The depth of my knowledge ends about there. Does it work if you try to recreate an atlas with similar settings?
Robert Banick
@rbanick
Mar 29 2016 15:10
that's actually what I did
sorry that wasn't clear above
Alan McConchie
@almccon
Mar 29 2016 15:26
oh, I see
hmm. And I don't think there's any way to figure out the parameters that caused the failure, without diving into the database (and maybe not even then). What, roughly, were the settings you were using?
Like, the extent, the tile layer, etc.
Robert Banick
@rbanick
Mar 29 2016 15:28
I had a 4x3 tile grid in a very small (500m x 500m or less) area of Sri Lanka
standard OSM basemap
this is more or less standard for the areas our team creates. sometimes they go a little larger
Alan McConchie
@almccon
Mar 29 2016 15:30
So, like something like this? http://fieldpapers.org/compose#15/7.4695/80.6253 (picking a random spot it Sri Lanka)
So you're probably around zoom 15?
Robert Banick
@rbanick
Mar 29 2016 15:30
actually probably z17 for us
sorry if I seem vague, I am always relaying requests from our team here and they are very resistant to providing details about errors
"it is broken robert"
Okay, it's failing for me, too.
Well, to be fair, the error message doesn't give your team very much info to work with! It seems like we should print out the parameters on that error page, at least.
Robert Banick
@rbanick
Mar 29 2016 15:36
that would be lovely! for us and you both
Alan McConchie
@almccon
Mar 29 2016 15:37
Actually, my z17 tests are still running... the z15 test failed pretty quickly.
I'll see if we can get more info queued up for @mojodna, since I'm pretty sure I won't be able to fix it myself.
Alan McConchie
@almccon
Mar 29 2016 15:52
@rbanick I think it's the default OSM style that's failing, or is too slow. I just got it to work with satellite, with toner, and with humanitarian
You might want to tell your team to use the Humanitarian style for now
I'm not sure what's wrong with OSM right now. Now I'm going to be AFK for a bit, hopefully this helps!
Seth Fitzsimmons
@mojodna
Mar 29 2016 16:29

nick and i were wrestling with this in DC a couple weeks ago and basically decided that anything that uses a web-based tile service is inevitably going to have problems

(OSM + the humanitarian style are the 2 biggest offenders)

my inclination is to fetch extracts from Overpass that match the size of the atlas and use that to locally render the OSM style

that way we have a bit more control over things (though not Overpass)

Robert Banick
@rbanick
Mar 29 2016 17:07
@mojodna that seems a pretty fair appraisal. I like the local overpass rendering fix although it does sound more labor intensive
@almccon thanks for troubleshooting! I will send my team the tip re: humanitarian style