Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Kate Chapman
    @wonderchook
    we can make sure to talk through as many channels as possible in one day
    Ian Ross
    @ian-ross
    I've not sent you a pigeon yet.
    Kate Chapman
    @wonderchook
    I figured it was still flying
    Seth Fitzsimmons
    @mojodna
    i’m back from Ecuador on Saturday, so i’ll be able to make the next one.
    quality field observations (including a semi-fix for @lukasHD’s problem) that i’ll be writing up early next week.
    @lukasHD if the TMS you’re using supports higher zoom tiles, the artifacts improve
    they’re fundamentally from attempting to shrink the PDF (after it’s been created by pycairo) using JPEG compression of images
    agreed that it’s ugly. we can’t easily fix it now (other than feeding it higher zooms—it defaults to 18 for unregistered sources and uses https://github.com/fieldpapers/fp-web/blob/master/config/providers.json otherwise), but will definitely include it once we’re able to tackle updating the renderer
    Kate Chapman
    @wonderchook
    is anyone thinking about proposing Field Papers talks to State of the Map US? http://stateofthemap.us/
    we have a bit of time proposals are due on April 17th
    Ian Ross
    @ian-ross
    @mojodna Message from rbanick that appeared in our Gitter room: hi field papers lovers. we're getting an "Atlas Creation Failed" error when we try to create an atlas. Could someone look into it? It's a little urgent as we have some field surveys starting tomorrow.
    Robert Banick
    @rbanick
    hi @ian-ross sorry -- internet problems at my previous location meant I thought I was posting to here
    and yes, our team is reporting some atlas creation problems
    Alan McConchie
    @almccon
    @rbanick @ian-ross @mojodna I'm about to get on a plane, but I'll try to restart the server now
    Okay, I think I just triggered a restart. Let us know if it starts working again in a few minutes. If not, @mojodna can probably debug in a couple hours.
    Robert Banick
    @rbanick
    I'm still getting an "Atlas Creation Failed" with this: http://fieldpapers.org/atlases/2zigye1o
    wah wah :(
    a couple hours is OK though, don't panic. we have backup plans.
    Alan McConchie
    @almccon
    I'm not sure if an in-process atlas would survive reboots. The depth of my knowledge ends about there. Does it work if you try to recreate an atlas with similar settings?
    Robert Banick
    @rbanick
    that's actually what I did
    sorry that wasn't clear above
    Alan McConchie
    @almccon
    oh, I see
    hmm. And I don't think there's any way to figure out the parameters that caused the failure, without diving into the database (and maybe not even then). What, roughly, were the settings you were using?
    Like, the extent, the tile layer, etc.
    Robert Banick
    @rbanick
    I had a 4x3 tile grid in a very small (500m x 500m or less) area of Sri Lanka
    standard OSM basemap
    this is more or less standard for the areas our team creates. sometimes they go a little larger
    Alan McConchie
    @almccon
    So, like something like this? http://fieldpapers.org/compose#15/7.4695/80.6253 (picking a random spot it Sri Lanka)
    So you're probably around zoom 15?
    Robert Banick
    @rbanick
    actually probably z17 for us
    sorry if I seem vague, I am always relaying requests from our team here and they are very resistant to providing details about errors
    "it is broken robert"
    Alan McConchie
    @almccon
    Okay, it's failing for me, too.
    Well, to be fair, the error message doesn't give your team very much info to work with! It seems like we should print out the parameters on that error page, at least.
    Robert Banick
    @rbanick
    that would be lovely! for us and you both
    Alan McConchie
    @almccon
    Actually, my z17 tests are still running... the z15 test failed pretty quickly.
    I'll see if we can get more info queued up for @mojodna, since I'm pretty sure I won't be able to fix it myself.
    Alan McConchie
    @almccon
    @rbanick I think it's the default OSM style that's failing, or is too slow. I just got it to work with satellite, with toner, and with humanitarian
    You might want to tell your team to use the Humanitarian style for now
    I'm not sure what's wrong with OSM right now. Now I'm going to be AFK for a bit, hopefully this helps!
    Seth Fitzsimmons
    @mojodna

    nick and i were wrestling with this in DC a couple weeks ago and basically decided that anything that uses a web-based tile service is inevitably going to have problems

    (OSM + the humanitarian style are the 2 biggest offenders)

    my inclination is to fetch extracts from Overpass that match the size of the atlas and use that to locally render the OSM style

    that way we have a bit more control over things (though not Overpass)

    Robert Banick
    @rbanick
    @mojodna that seems a pretty fair appraisal. I like the local overpass rendering fix although it does sound more labor intensive
    @almccon thanks for troubleshooting! I will send my team the tip re: humanitarian style
    Seth Fitzsimmons
    @mojodna
    This message was deleted
    Alan McConchie
    @almccon
    Hey @/all, do the scanned maps look really bad in iD on Retina screens for anybody else? I'm not sure if this is a known issue, or something new, but I don't remember noticing it before.
    For example, here's a scan that I'm testing with (it's pretty good quality): http://fieldpapers.org/snapshots/1pkbvagg#19/43.59052/-116.19452