Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Olivier Burri
    @lacan
    Hi I have mentioned a part of it here fiji/Colocalisation_Analysis#65
    OK, but I cannot supply a binary mask programatically right now, at least to the best of my knowledge.
    I agree that the whole point of auto-threshold is to remove the bias, but what happens to this threshold when there is no coloc, but noise and an eventual offset? The method fails. If we are measuring some sort of dose-response, it can happen that in some conditions the thresholds can vary a lot because the correlation levels change in the image.
    We do not set the thresholds by hand for fum. we test them against negative controls to make sure that what we are capturing above the threshold is not some biological background which happens a lot with real images
    Olivier Burri
    @lacan
    At the very least manual thresholds are a way of testing the robustness of the results. The auto threshold will always find correlation, it's the way it's built. I find it odd that to measure correlation level, you need to set a threshold based on correlation level to get the correlation level :smile:
    We sometimes also make use of separate auto-thresholds (like the ones already in Fiji) in order to detect an object or features in which we want to measure the colocalization metrics (Pearson's, Manders, etc...).
    Finally we noticed that in most cases, people are not measuring 'colocalization' but merely co-occurrence, where Manders can be very useful, despite their shortcomings. Example would me a vesicle marker vs some protein of interest. The vesicle marker signal will always be close to the same, whereas the protein of interest will vary with the experiment. Using the auto threshold tends to modify the membrane maker threshold value, where using some auto-threshold from Fiji, we see that it is not varying as much from dataset to dataset.
    Hope I was able to clear a few things up, let me know if I am not making sense :worried:
    Ellen TA Dobson
    @etadobson
    @lacan and @chalkie666 sorry - i'm late to the game... have been focusing on manuscript revisions... will chime in on github. this whole thing might be an issue no? now that we are moving things to Ops? but like i said - will read more and get back to you guys...
    dan white
    @chalkie666
    @lacan @etarena Fiji auto thresholds methods to be usable as threshold methods in coloc2 was always an idea we liked, we just never did it. So whatever way works best for that , bearing in mind ops and the GUI being separated concerns is all good. if the single image channel autothreshold methods are nowe all ops, then goosd to use those. Need GUI to be able to select either 2 channel autothreshold method like costes, or same or two different single channel autothreshold methods for channel 1 and 2.
    so needs new logic in GUI
    Gustavo Scola
    @GScola_Scola_twitter
    Hello, I was wondering if you guys know how to install the coloc2 plugin using ImageJ. I tried several times but I can not succeed. Many thanks.
    Stephan Grein
    @stephanmg
    w/o any error message this is hard to judge
    Curtis Rueden
    @ctrueden
    @GScola_Scola_twitter Use Fiji.
    Gustavo Scola
    @GScola_Scola_twitter
    It basically does not install the plugin. I will try to use Fiji. Many thanks
    Stephan Grein
    @stephanmg
    well okay.
    Isn't Coloc2 included in Fiji?
    which OS?
    Ellen TA Dobson
    @etadobson
    Yes - just download the Fiji distribution of ImageJ here ... Coloc 2 is included automatically.
    Gustavo Scola
    @GScola_Scola_twitter
    Hello guys, I was able to download Fiji and have access to coloc2. However, I am learning how to use this tool. I am selecting the ROIs and tried to play with background subtraction but I still receive the same outcome. For my first test I received the following message: y-intercept far from zero
    The ratio of the y-intercept of the auto threshold regression line to the mean value of Channel 2 is high. This means the y-intercept is far from zero, implying a significant positive or negative zero offset in the image data intensities. Maybe you should use a ROI. Maybe do a background subtraction in both channels. Make sure you didn't clip off the low intensities to zero. This might not affect Pearson's correlation values very much, but might harm other results.
    Threshold of ch. 1 too high
    Too few pixels are taken into account for above-threshold calculations. The threshold is above the channel's mean.
    Threshold of ch. 2 too high
    Too few pixels are taken into account for above-threshold calculations. The threshold is above the channel's mean.
    Ellen TA Dobson
    @etadobson
    @GScola_Scola_twitter
    opps.. hit enter too soon on that one - sorry! Would you be able to post this on the ImageJ Forum? it's a more appropriate (and better trafficked place) for this type of question...
    Gustavo Scola
    @GScola_Scola_twitter
    @etarena Thank you. I will post there ;)
    Ellen TA Dobson
    @etadobson
    @GScola_Scola_twitter Super! Thanks!
    Gustavo Scola
    @GScola_Scola_twitter
    @etarena Thank YOU for all the help :)
    Ellen TA Dobson
    @etadobson
    Hey @chalkie666 !!! We have a visiting scientist working with us and she is tackling some Coloc 2 issues... she needs a bit of input/direction from you if you have the time.
    @nafisahis will be posting here soon with more info... specifically - she is first looking at #14 to start
    and has a few questions on how to best add the regression line to the PDFWriter...
    dan white
    @chalkie666
    Totally go for it!
    Ellen TA Dobson
    @etadobson
    Thanks! @chalkie666 - she'll write here soon! :)
    Nafisah Islam
    @nafisahis

    Thank you so much @etarena ! :)
    Hi @chalkie666 , thank you for your time in this matter. #14 is the issue where the regression line is drawn in result GUI but is not reflected after it is saved as PDF. For this issue I was mainly looking into SingleWindowDisplay and PDFWriter codes.

    Mainly I found that SingleWindowDisplay class adds the regression line to the image to be displayed if it finds that image is a histogram and then it redraws the image which is finally displayed in GUI. PDFWriter class doesn't add the line if the image to be drawn is a histogram. I have tried to add the line inside handleHistogram method just before adding the image to the addImageToList. I am surely missing something and thus it is not reflected. I was hoping you can give me a direction on how to best deal with this. :)

    dan white
    @chalkie666
    @nafisahis sorry, sounds like you have a good idea what to try as I might. So just keep hacking, I bet you can do it!
    Ellen TA Dobson
    @etadobson
    we'll figure it out dude... no worries!
    :)
    Nafisah Islam
    @nafisahis
    Thanks Dan.. :)
    qqq6595291
    @qqq6595291
    hello guys. when i start coloc2, "plugin or class not found:“sc.fiji.coloc.coloc_2" "these words appears, who can tell me what's the problem?
    Ellen TA Dobson
    @etadobson
    @qqq6595291 ... would you mind posting this on the imaging forum instead? you can also share a snapshot or copy/paste the error message you see. Also - let us know there what version of ImageJ/Fiji you are running...
    qqq6595291
    @qqq6595291
    捕获.PNG
    @etarena like this
    @etarena i'm using imagej 1.52m
    @etarena And the version of Fiji is 3.0.5
    qqq6595291
    @qqq6595291
    捕获.PNG
    @etarena i also checked this file, but it is there!
    Ellen TA Dobson
    @etadobson
    post this on the imaging forum that i linked above...
    Curtis Rueden
    @ctrueden
    @qqq6595291 You need to use Fiji, not plain ImageJ 1.x.
    (I deduce that you are not using Fiji, based on your screenshot above, which has the ImageJ 1.x icon, and the title bar does not say “Fiji”, and there is no search bar from ImageJ2.)
    @qqq6595291 Happy to give more detailed advice if you paste a link here to a forum post on forum.image.sc as @etarena recommended.
    Jan Eglinger
    @imagejan
    For the record, this was posted here on the forum.
    Ellen TA Dobson
    @etadobson
    :thumbsup:
    sepideh
    @sepideh_prs_twitter
    folks I have an issue in colocalization plugin. imagine I have a series of images z-stack, of red channel only and a series of the same sample in the green channel imported to FIJI by imageseq. I cant run colocalization on z-stack. anyone knows how to do it? on one single plane it is all fine but what about the whole volume? need the help of an expert Need to report the result by Monday and I am clueless what is the issue...
    Curtis Rueden
    @ctrueden
    @sepideh_prs_twitter Did you post on forum.image.sc? Could you please link the thread here?