These are chat archives for fiji/fiji

27th
Oct 2015
Jean-Yves Tinevez
@tinevez
Oct 27 2015 14:37
@tpietzsch @ctrueden I would like to release TrackMate v2.8.0. But I would need imglib2-algorithm-0.3.3 to be deployed. Is this envisageable?
Curtis Rueden
@ctrueden
Oct 27 2015 14:39
@tinevez I'm on it.
Jean-Yves Tinevez
@tinevez
Oct 27 2015 14:41
@ctrueden thanks!
I'm preparing a News item on the Fiji wiki. We still do that right?
Jean-Yves Tinevez
@tinevez
Oct 27 2015 15:55
Ok TrackMate v2.8.0 is not uploaded yet, but the announcement is out:
There is also an informal part to it, that mentions Benoit, Thorsten and Ronny.
Jean-Yves Tinevez
@tinevez
Oct 27 2015 16:04
Done, uploaded.
Ellen T Arena
@etarena
Oct 27 2015 16:48
@tinevez dude - love the ROI editor! ;) Ah... memories.
Curtis Rueden
@ctrueden
Oct 27 2015 17:22
@tinevez Sorry for the delay. I have released imglib2-algorithm 0.3.3, and a new pom-scijava and new pom-imagej. The problem is that the new pom-imagej reference net.imagej:ij:1.50d, but 1.50c and 1.50d were not deployed properly to Maven. So I am fixing that.
After that, I will cut a new net.imagej:imagej, then cut the new pom-fiji which also bumps TrackMate to 2.8.0. Then update sc.fiji:fiji to the new pom-fiji.
@tinevez So FYI: the TrackMate 2.8.0 release you cut does not actually depend on the fixed imglib2-algorithms 0.3.3—it still depends on 0.3.2. It would have been ideal to make its dependencies require that, if that is really a fix that TrackMate 2.8.0 needs.
It won't matter for Fiji end users because of course we will upload the latest versions of everything later today.
But it would matter if someone adds a dep on TrackMate itself in their code, because then a too-old imglib2-algorithms would be pulled in.