These are chat archives for fiji/fiji

16th
Nov 2017
Varun Kapoor
@kapoorlab
Nov 16 2017 08:29
Hey, My imglib2-algorithm pom has problems resolving these dependencies when I tried to clone it fresh on the computer, does anybody knows how to resolve this? These two dependencies in pom.xml are the problem dependencies:
                  <dependency>
        <groupId>net.imglib2</groupId>
        <artifactId>imglib2-roi</artifactId>


    <!-- ImageJ dependencies -->
    <dependency>

        <groupId>net.imagej</groupId>
        <artifactId>imagej-common</artifactId>
    </dependency>
Richard Domander
@rimadoma
Nov 16 2017 12:48
@kapoorlab there's at least a </dependency> missing
Varun Kapoor
@kapoorlab
Nov 16 2017 14:06
Ah sorry, copy paste error here, but in the original pom the lines appear as shown below: It is the same pom as imglib2-algorithm: The roi part of the dependency is problematic.
<dependency>
<groupId>net.imglib2</groupId>
<artifactId>imglib2-roi</artifactId>
</dependency>
<dependency>
<groupId>net.imglib2</groupId>
<artifactId>imglib2-realtransform</artifactId>
</dependency>
    <!-- ImageJ dependencies -->
    <dependency>
        <groupId>net.imagej</groupId>
        <artifactId>imagej-common</artifactId>
    </dependency>
Varun Kapoor
@kapoorlab
Nov 16 2017 14:20
[ERROR] Failed to execute goal on project imglib2-algorithm: Could not resolve dependencies for project net.imglib2:imglib2-algorithm:jar:0.8.2-SNAPSHOT: Failed to collect dependencies at net.imglib2:imglib2-roi:jar:0.4.5: Failed to read artifact descriptor for net.imglib2:imglib2-roi:jar:0.4.5: Could not transfer artifact net.imglib2:imglib2-roi:pom:0.4.5 from/to imagej.public (https://maven.imagej.net/content/groups/public): sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 1]
When I run Maven build on pom.xml of imglib2-algorithm
tpietzsch
@tpietzsch
Nov 16 2017 14:22
maybe something is wrong with you ~/.m2 directory?
could you try deleting ~/.m2/repository/net/imglib2/imglib2-roi/
and then retry?
Curtis Rueden
@ctrueden
Nov 16 2017 15:00
@kapoorlab What version of Java do you use? You need a recent-ish version of Java 8 or else the https: will fail because old Java does not recognize the Let's Encrypt cert we use.
Newer than 1.8.0_91 IIRC.
Varun Kapoor
@kapoorlab
Nov 16 2017 15:19
Ah,I have 1.8.0_73, so let me update then.