These are chat archives for fiji/fiji

5th
Feb 2018
Ulrik Günther
@skalarproduktraum
Feb 05 2018 12:44
@amirffff have a look at http://imagej.net/Jython_Scripting
@ctrueden is there already some kind of timeline to switch fiji to java9? (i hope i’m not poking any wounds here :D )
Curtis Rueden
@ctrueden
Feb 05 2018 13:03
@skalarproduktraum Why do you need Java 9?
Ulrik Günther
@skalarproduktraum
Feb 05 2018 13:04
@ctrueden just gauging at the moment, but java 9 introduces Math.fma() e.g., which is very useful for me
Curtis Rueden
@ctrueden
Feb 05 2018 13:06
We recently fixed the ImageJ launcher so that you can at least start ImageJ with Java 9 successfully. Planning to iron that out more this year. But no plans yet for when to start requiring Java 9 (or 10) for core libs.
If Scenery/SciView continues to ship on its own update site then it certainly would be possible for it to start requiring Java 9 soon.
Ulrik Günther
@skalarproduktraum
Feb 05 2018 13:09
okay, thanks, i’ll try to investigate a bit deeper whether we gain enough from the improvements so warrant requiring java 9