These are chat archives for fiji/fiji

15th
Aug 2018
Stephan Preibisch
@StephanPreibisch
Aug 15 2018 14:13
Hi, the multiview-reconstruction Travis CI jobs throws an error that I am not sure how to interpret, does anybody have an idea? It seems to not be related to the relatively simple changes I made:
[INFO] --- imagej-maven-plugin:0.7.0:copy-jars (copy-jars) @ multiview-reconstruction ---
[WARNING] Error injecting: net.imagej.maven.CopyJarsMojo
java.lang.NoClassDefFoundError: org/apache/maven/shared/artifact/filter/resolve/TransformableFilter
Thanks so much in advance!
Curtis Rueden
@ctrueden
Aug 15 2018 15:48
@StephanPreibisch I have seen this error before, but don't remember under what conditions, unfortunately. I'll do a little digging right now. CC @stelfrich
Stephan Preibisch
@StephanPreibisch
Aug 15 2018 15:59
Maybe it’ll also self-heal at some point … thanks so much @ctrueden
By the way, I just realized that the Travis CI office is just one block down from my home … funny coincidence.
Curtis Rueden
@ctrueden
Aug 15 2018 16:00
Haha that is cool.
Stephan Preibisch
@StephanPreibisch
Aug 15 2018 16:00
So if you ever need somebody to express any kind of opinion in person, I am available :)
Stefan Helfrich
@stelfrich
Aug 15 2018 16:25
@StephanPreibisch Have you tried to restart the build manually again?
Stephan Preibisch
@StephanPreibisch
Aug 15 2018 16:26
Yes
Same result
Stefan Helfrich
@stelfrich
Aug 15 2018 16:26
I wonder why build #147 has passed..
There’s no changes to the POM between multiview-reconstruction-0.2.12 and multiview-reconstruction-0.2.13 that would explain the failing
Curtis Rueden
@ctrueden
Aug 15 2018 16:50
@stelfrich I diffed the complete logs between 147 and 152, but don't see anything that would explain it.
Ulrik Günther
@skalarproduktraum
Aug 15 2018 16:59
@StephanPreibisch @ctrueden i got such weird errors sometimes due to corrupted travis caches, maybe clean the cache of the build and restart it
Curtis Rueden
@ctrueden
Aug 15 2018 18:07
@skalarproduktraum Good idea—I cleared the caches and restarted the build. We'll see how it goes.
Passed this time.
Ulrik Günther
@skalarproduktraum
Aug 15 2018 18:11
@ctrueden yeehaw!
Stephan Preibisch
@StephanPreibisch
Aug 15 2018 18:29
Thanks a lot @ctrueden ... is there any way I can do this myself if it happens again? Hate to bother people if it’s not necessary...
Curtis Rueden
@ctrueden
Aug 15 2018 18:32
Sure, just click on More Options (top right hamburger menu) and then Caches and then "Delete all repository caches"
Jan Eglinger
@imagejan
Aug 15 2018 18:32
@StephanPreibisch on your project page on travis-ci.org: More options > Caches, then Delete all repository caches
oops :)
Curtis Rueden
@ctrueden
Aug 15 2018 18:32
@imagejan Jinx :-P
Stefan Helfrich
@stelfrich
Aug 15 2018 19:11
Whew! I thought that I had screwed up.. Thanks for the pointer @skalarproduktraum!