Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Matan Shukry
@matanshukry
@Aashishm178 Can't; it seems to complain about missing size
I/flutter (28464): The following RenderObject was being processed when the exception was fired: _RenderListTile#4453c relayoutBoundary=up20 NEEDS-LAYOUT NEEDS-PAINT NEEDS-COMPOSITING-BITS-UPDATE:
I/flutter (28464):   creator: _ListTile ← MediaQuery ← Padding ← SafeArea ← Semantics ← _PointerListener ← Listener ←
I/flutter (28464):     _GestureSemantics ← RawGestureDetector ← GestureDetector ← _RawMouseRegion ← MouseRegion ← ⋯
I/flutter (28464):   parentData: offset=Offset(0.0, 0.0) (can use size)
I/flutter (28464):   constraints: BoxConstraints(unconstrained)
I/flutter (28464):   size: MISSING
I/flutter (28464): This RenderObject had the following descendants (showing up to depth 5):
I/flutter (28464):     title: RenderParagraph#94145 NEEDS-LAYOUT NEEDS-PAINT
I/flutter (28464):       text: TextSpan
Kemal
@kemalturk03
Ekran Alıntısı.PNG
My question is while we are working with firebase in flutter, updating something to its newer version is important? Or how much is it important, if it is?
I mean, If I don't update the code just like above (highlighted with yellow line ), it cause an error?
Aashishm178
@Aashishm178
No it will not cause any error or problem
Omega Prime
@Omega_Primus_twitter
Is anyone aware of a method of doing autocomplete with flutter web? Seems there is a bug in all of the packages where it doesn't allow a user to select anything
Mayank Janmejay
@mayankjanmejay
@Omega_Primus_twitter are you able to make http post requests on flutter web?
Omega Prime
@Omega_Primus_twitter
not yet, that was stage 2, i am just working with local data right now
is that also buggy then?
@mayankjanmejay forgot to tag you
Mayank Janmejay
@mayankjanmejay
Yea, i built a app using firebase and google firestore. That with flutter works perfectly on android and web but now i am trying to move the data source to a different api and i cant do simple post get requests.
Autofill has been rather buggy in my tests, hopefully someone else has had better luck with it
@Omega_Primus_twitter I have 3 android apps with flutter, i tried porting 1 to web and after not great success i am thinking of ditching the framework for web.
Omega Prime
@Omega_Primus_twitter
@mayankjanmejay Hmm, i hope it doesn't have issues, I had spent a good bit of time on my app. I will give it a go then, I was just going to use wiki for now as an autocomplete example as there is a lot of data from it https://en.wikipedia.org/w/api.php?action=opensearch&search=$query&limit=20&format=json
Matan Shukry
@matanshukry
I have columns 2 children: listview (reversed) and a container
I want the listview to start at the top though. how can I do that?
Naveen yadav
@naveenyadav15
@matanshukry FIrst define the container and then define listview respectively in column children
Matan Shukry
@matanshukry
@naveenyadav15 What container are you talking about? the issue is the listview is reversed, so the content starts from bottom
Naveen yadav
@naveenyadav15
okay i understood now so a workaround is you reverse the items list rather than reversing the listview
Matan Shukry
@matanshukry
I'm reversing the listview because of scrollling not because of the content, so I can't do that either
Cloud_Kiddo
@kevinlalkalathingal

$ flutter run
Launching lib\main.dart on Redmi Note 8 Pro in debug mode...
Running Gradle task 'assembleDebug'... 41.2s
Exception: Gradle task assembleDebug failed with exit code -1

what should i do??

Naveen yadav
@naveenyadav15
@kevinlalkalathingal try : flutter run -v
Matan Shukry
@matanshukry
if that still doesn't work, go to androiddirectory and run ./gradlew assembleDebug
Cloud_Kiddo
@kevinlalkalathingal
it didnt work i guess..
Jitendra
@jitendrahpatwa
Hi all,
I updated android studio with flutter and dart plugin but when running the application get stuck with emulator always says:
"Emulator: Warning: Quick Boot / Snapshots not supported on this machine. A CPU with EPT + UG features is currently needed. We will address this in a future release."
Please suggest how this can resolve. System configuration is 64bit Core2Duo Processor with enabled Virtualization and UEFI from BIOS, but the same red line appears in android studio Event Log.
kakyoism
@kakyoism

Hi all, I was able to make a flutter ffi plugin run with the generated example project on iOS, but when doing so on Android, I seem to have JDK/gradle configuration issues, such as the following in my MainActivity.kt

Check your module classpath for missing or conflicting dependencies
Error running 'libmynative': No JDK specified for module 'mynative_example_android'
Cannot access 'android.app.Activity' which is a supertype of 'com.my.app'. Check your module classpath or conflicting dependencies

How should I go about this?

I do have the following dependencies specified in my build.gradle for the Android example app

dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
implementation 'androidx.appcompat:appcompat:1.0.2'
implementation 'androidx.core:core-ktx:1.0.2'
implementation 'androidx.constraintlayout:constraintlayout:1.1.3'
testImplementation 'junit:junit:4.12'
androidTestImplementation 'androidx.test.ext:junit:1.1.0'
androidTestImplementation 'androidx.test.espresso:espresso-core:3.1.1'
}

So I assume that the system will find the JDK for me. On the other hand, I built another kotlin/NDK Android project, with the same version of Android Studio 3.6.3, which runs perfectly. I basically copied most Gradle settings from there.
NithinPrabhu24
@NithinPrabhu24

onTap: navigationTapped,
currentIndex: _page,
```void navigationTapped(int page) {
// Animating to the page.
// You can use whatever duration and curve you like
setState(() {
_pageController.animateToPage(page,
duration: const Duration(milliseconds: 50), curve: Curves.ease);

});

}

void onPageChanged(int page) {
setState(() {
this._page = page;
});
}```

@Aashishm178
JRamos29
@JRamos29
Hi, its possible to save the result image of an image using the colorBlendMode property of Image.file?
Shipofsea
@shipofsea
Hello, everyone!
Flutter JSON Serialization - Not generating *.g.dart files
I tried to build project to receive json object by using json_annotation
but there is error Not generating *.g.dart files
what is the reason?
Sachin Goud
@Sachin-Goud-9
Hi
I am getting error "ImageFilter isn't defined for the class Paint' could anyone of you resolve the error
Shipofsea
@shipofsea
error_g_dart.jpg
what is the reason?
Shipofsea
@shipofsea
[WARNING] json_serializable:json_serializable on lib/model/movie.dart:
Missing "part 'movie.g.dart';".
oh, I fixed it myself.
commend : flutter packages pub run build_runner watch
then write part 'movie.g.dart';
next compile
matrixbot
@matrixbot
workerspartywayne Hello flutter people!
Shipofsea
@shipofsea
Hello
FlutterBluePlugin.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
why does this message appear?
axilaris
@axilaris
Stream<NavigationStates> mapEventToState(NavigationEvents event) async* {
switch (event) {
case NavigationEvents.HomePageClickedEvent:
yield HomePage(); <-- HomePage I changed from StatelessWidget to StatefulWidget and it doesnt work
break;
yield does not work anymore when changed from StatelessWidget to StatefulWidget
how can i get it to work
matrixbot
@matrixbot
w Why is the official recommended using the Provider instead of Redux?