Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Ghost
    @ghost~5d254470d73408ce4fc5ac40

    Do you perhaps have

    dev_dependencies:
    build_daemon: ^1.0.0
    build_runner: ^1.4.0
    build_web_compilers: ^2.0.0

    in your pubspec.yaml?

    Or would these not be necessary anymore?

    Jonah Williams
    @jonahwilliams
    The build_runner dependencies are not necessary if you are using the flutter tool (in fact, they are completely ignored). There does seem to be an issue with windows though, I'm looking at that currently
    Ghost
    @ghost~5d254470d73408ce4fc5ac40
    @jonahwilliams Ah I see, thank you for the notice. Guess I will wait a little longer then.

    @jonahwilliams As I couldn't run the flutter run -d chrome, I tried to debug it with by running pub run build_runner daemon . . .which then gave me the following error;

    Could not find a file named "pubspec.yaml" in "C:\Users\guest3\AppData\Roaming\Pub\Cache\hosted\pub.dartlang.org\petitparser-2.4.0".

    Jonah Williams
    @jonahwilliams
    you won't be able to run it with build runner manually
    Ghost
    @ghost~5d254470d73408ce4fc5ac40
    @jonahwilliams Hm... So I guess the best action I can take for the moment is to wait for the windows issue to be fixed? Or is there anything that I can do on my side to make it work?
    Ephenodrom
    @Ephenodrom
    @RandalSchwartz I switched from the flutter web to the normal flutter
    create a new web project and compared the files
    before i had a /web/main.dart file
    with flutter create --web
    there is no /web/main.dart file ... any idea if this file is not necessary anymore ?
    Ghost
    @ghost~5d254470d73408ce4fc5ac40
    @Ephenodrom Are you able to flutter run -d chrome tho?
    Ephenodrom
    @Ephenodrom
    yeah its working
    but i am on Ubunto 18.04
    Ghost
    @ghost~5d254470d73408ce4fc5ac40

    but i am on Ubunto 18.04

    I see ;3 tnx for the info.

    Ephenodrom
    @Ephenodrom

    but i normally started the app with

    webdev serve --auto restart

    So i can use any other browser

    but that seems not to work anymore after switching to flutter instead of flutter_web
    Ephenodrom
    @Ephenodrom
    flutter pub global run webdev serve
    webdev could not run for this project.
    You have a dependency on `flutter` which is not supported for flutter_web tech preview. See https://flutter.dev/web for more details.
    pub finished with exit code 78
    Ephenodrom
    @Ephenodrom
    someone knows the alternativ to webdev serve --auto restart it is anoying to always start an extra instance of chrome with flutter run -d chrome
    Dima Rostopira
    @rostopira
    Could anyone bring some light on this PR flutter/flutter#37819 ?
    It's not merging 19 days already, I'm tired explaining to my PM such delay
    Ephenodrom
    @Ephenodrom
    how can i add chromium as a device ?
    or Firefox ?
    thomashbailey
    @thomashbailey

    Does anyone know of a good way to share mobile code with flutter_web?
    I am wanting something like

    ifdef FLUTTER_WEB

    import 'package:flutter_web/material.dart';

    else

    import 'package:flutter/material.dart';

    endif

    Randal L. Schwartz
    @RandalSchwartz
    and package:flutter_web is going away.
    it’ll all be just package:flutter soon.
    thomashbailey
    @thomashbailey
    ok I'll check that out.
    I knew it was going away when it is out of the preview. Any idea when that will be?
    Randal L. Schwartz
    @RandalSchwartz
    google cannot tell us.
    but watch the burn-down rate of the issues.
    thomashbailey
    @thomashbailey
    That's going to work. Thanks Randal
    RandalSchwartz @RandalSchwartz bows
    RandalSchwartz @RandalSchwartz hits head on desk
    Randal L. Schwartz
    @RandalSchwartz
    ouch!
    Ephenodrom
    @Ephenodrom
    but you can already switch to flutter
    as randal mention a few lines above
    Randal L. Schwartz
    @RandalSchwartz
    yeah, flutter is being folded into the core on the master branch.
    flutter-web
    might have some issues during the integration, but I used it the other day.
    Ephenodrom
    @Ephenodrom
    works quite good
    just having some problems with hot reload
    Randal L. Schwartz
    @RandalSchwartz
    yeah, hot reload not yet available for flutter-web
    just hot-restart
    and I’ve found that to be a bit dicey
    Ephenodrom
    @Ephenodrom
    sometimes i got Another exception was thrown: NoSuchMethodError: invalid member on null: 'findRenderObject' and i have to restart the app with flutter run -d
    Dima Rostopira
    @rostopira
    @thomashbailey there is conditional import feature
    import 'io_impl.dart'
      if (dart.library.js) 'html_impl.dart';
    Export keyword supports this as well
    both imported files should have same classes names/methods/arguments if they are used in target file
    thomashbailey
    @thomashbailey
    That's nice to know. Thanks all.