Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Randal L. Schwartz
    @RandalSchwartz
    looks like webdev is still the preferred path
    Atakan Mert Kaya
    @Sekaiichi4

    Hm... but webdev doesn't allow any dependencies on flutter, only if I migrate my project back to the flutter_web repository I can use it. But as now flutter_web is merged with normal flutter, using only flutter build should do the trick.

    all my .dart files do get compiled into .js and .map files, but my assets just don't get included in the build.

    Randal L. Schwartz
    @RandalSchwartz
    If you have an old project, flutter create and move your files into it.
    Atakan Mert Kaya
    @Sekaiichi4
    It's a brand new project
    Randal L. Schwartz
    @RandalSchwartz
    and you created it with flutter web enabled?
    and you have updated webdev recently?
    follow the instructions here https://github.com/flutter/flutter_web
    and the hello world app should work.
    Atakan Mert Kaya
    @Sekaiichi4
    Yes, flutter run -d chrome also works perfectly. All my assets do get included in that case, just when I want to make a build my assets don't get included
    Randal L. Schwartz
    @RandalSchwartz
    I’ve not had any problems following that.
    yes, try webdev build
    that should know how to move all the assets into your build directory
    yichen
    @unicreators
    Hi, How to build an Flutter app & web generic package?
    I have an Flutter app package now. https://pub.dev/packages/mvvm
    it's work great with flutter web.
    yichen
    @unicreators
    just need change
    小李
    @asjqkkkk
    hey,guys, I think it's a good idea to build a ThemeData tool by flutter_web
    But now flutter_web's ecology is very poor,many features are incomplete , It will be difficult to complete the web tool , What's your opinion?
    Göran Krampe
    @gokr
    Am I correct that... there is no support for plain dart:io sockets in flutter for web, right? And... websockets? Or http requests is the way to go right now?
    I am ... supposed to whip up a demo in a day or two here ;) and the flutter code I have relies on a plain socket - but... I do have power over the backend so.
    Lee Shindong
    @ShindongLee
    Hello, I'm developing a web app using flutter_web. It works good with stable channel importing flutter_web with webdev. I was using dart:js and dart:html library. But they don't work after i change the dependency from flutter_web to flutter using master channel where flutter_web has been merge into flutter. Is this normal?
    Ricardo Chen
    @ricardochen
    @Sekaiichi4 Thanks, I have instascan in my bookmarks, but the issue I'm facing now is how to actually use instascan or any JS library that involves a camera with flutter code
    Green Appers, Inc.
    @GreenAppers
    Wow. Flutter web merged! %fireworks% Thanks, Google! That fixes it!
    Atakan Mert Kaya
    @Sekaiichi4

    Hello, I'm developing a web app using flutter_web. It works good with stable channel importing flutter_web with webdev. I was using dart:js and dart:html library. But they don't work after i change the dependency from flutter_web to flutter using master channel where flutter_web has been merge into flutter. Is this normal?

    Yeah I kinda have this issue as well, as I was calling Javascript methods through Dart on my web version of the app. Tell me if you found a way to fix this issue.

    Randal L. Schwartz
    @RandalSchwartz
    I think the merge was more about not needing conditional imports.
    That was a hassle.
    Randal L. Schwartz
    @RandalSchwartz
    But now any conditional code is buried in the framework.
    Atakan Mert Kaya
    @Sekaiichi4

    Hello, I'm developing a web app using flutter_web. It works good with stable channel importing flutter_web with webdev. I was using dart:js and dart:html library. But they don't work after i change the dependency from flutter_web to flutter using master channel where flutter_web has been merge into flutter. Is this normal?

    Ok... just figured out that indeed dart:js dart:html don't get recognized in VSCode and that an error will show, but if you ignore that...you are actually able to make a web build and/or debug with flutter run -d chrome.

    Randal L. Schwartz
    @RandalSchwartz
    If it breaks it, don't change it!
    Göran Krampe
    @gokr
    I have smashed my head against websockets - unfortunately I get ... really frustrating errors.
    I keep getting the... well, this one: flutter/flutter#34858
    I's closed but.. I dunno, keep getting hit in the head with it.
    Oh well, will let this wait for a day ;)
    ChaitanyaHarde
    @Chaitanyaha
    hello
    how to save a image or video file name as the geo-location cordinates in Flutter is there any API.. basic idea I want to implement is of geotagging
    any idea
    ?
    NicolasDionB
    @NicolasDionB
    So with the latest version of Flutter SDK you get web support as it is now merged with the main SDK. No need for dedicated imports like "package:flutter_web/..." :)
    NicolasDionB
    @NicolasDionB
    Some instructions to get started: https://flutter.dev/docs/get-started/web
    Fahim Shariar Shoumik
    @sh0umik
    Anybody getting this error while building for web
    Dart2Js finished with:                                                  
    
    packages/http/src/multipart_file.dart:14:8:
    Error: Error when reading 'packages/http/src/multipart_file_stub.dart': Error reading 'packages/http/src/multipart_file_stub.dart'  (No such file or directory)
    import 'multipart_file_stub.dart'
           ^
    packages/http/src/multipart_file.dart:93:7:
    Error: Method not found: 'multipartFileFromPath'.
          multipartFileFromPath(field, filePath,
    flutter run -d chrome works well but flutter build web failed. I am using protobuffer and grpc-web as dependency
    Jacob MacDonald
    @jakemac53
    Ah it is possible we resolved this issue for DDC but not Dart2Js
    I would file an issue
    flutter/flutter#40228 is related but different (for DDC)
    jld3103
    @jld3103
    I actually got the same error: dart-lang/http#286
    Jacob MacDonald
    @jakemac53
    That one should have been resolved, are you on flutter dev channel or stable?
    It might be only resolved on dev and not stable or something like that, I am not sure