by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jun 01 12:31
    pomadchin closed #59
  • Jun 01 12:31
    pomadchin commented #59
  • Oct 19 2017 05:09
    AlexanderShniperson commented #60
  • Oct 19 2017 04:51
    fomkin commented #60
  • Oct 18 2017 19:03
    AlexanderShniperson opened #60
  • Apr 28 2017 10:37
    pomadchin synchronize #59
  • Apr 28 2017 10:36
    pomadchin synchronize #59
  • Apr 27 2017 10:41
    pomadchin edited #59
  • Apr 27 2017 10:41
    pomadchin edited #59
  • Apr 27 2017 10:40
    pomadchin edited #59
  • Apr 27 2017 10:40
    pomadchin synchronize #59
  • Mar 21 2017 09:33
    fomkin edited #59
  • Mar 21 2017 09:01
    pomadchin synchronize #59
  • Mar 21 2017 08:57
    pomadchin synchronize #59
  • Mar 21 2017 08:55
    pomadchin synchronize #59
  • Mar 21 2017 08:54
    pomadchin edited #59
  • Mar 21 2017 08:49
    pomadchin synchronize #59
  • Mar 21 2017 08:23
    pomadchin edited #59
  • Mar 21 2017 08:17
    pomadchin synchronize #59
  • Mar 21 2017 08:10
    pomadchin synchronize #59
Alexander Shniperson
@AlexanderShniperson
когда можно ожидать ? fomkin/pushka#36
Aleksey Fomkin
@fomkin
@AlexanderShniperson English please. I released 0.6.1 with Array[T] support. BTW I strongly recommend to use immutabale collections inside case classes.
@LMnet thanks for PR!
Aleksey Fomkin
@fomkin
This message was deleted
Otto Chrons
@ochrons
trying to update Boopickle perf tests to Pushka 0.7.1 but getting errors
[error] D:\work\boopickle\perftests\shared\src\main\scala\boopickle\perftests\TestData.scala:8: type mismatch;
[error]  found   : Some[A]
[error]  required: Option[pushka.HasDefault.Default[String]]
[error] @pushka case class Book(id: String, name: String, author: String, publicationYear: Int)
[error]  ^
with 0.7.0 I get,
[error] D:\work\boopickle\perftests\shared\src\main\scala\boopickle\perftests\TestData.scala:10: exception during macro expansion:
[error] java.lang.StackOverflowError
[error] @pushka
[error]  ^
0.6.1 works ok
Aleksey Fomkin
@fomkin
@ochrons Hi! This is very strange. Created an issue fomkin/pushka#55