These are chat archives for fossasia/open-event-server

11th
May 2016
Shivam Mamgain
@shivamMg
May 11 2016 06:28
@aditya1702 why have you deleted previous migrations?
Avi Aryan
@aviaryan
May 11 2016 06:51
yes @aditya1702 please don't delete the migrations, specially the initial migration https://github.com/aditya1702/open-event-orga-server/blob/275eddac4efffaaffb793ca85791fd34d2993514/migrations/versions/30ca70296a1c_.py . The other collaborators can use the new migration created by you to update their databases but that will only happen if other old migrations are in place
Avi Aryan
@aviaryan
May 11 2016 08:45
@juslee @rafalkowalski please add codeclimate pull request integration https://docs.codeclimate.com/docs/github-pull-request-integration That would be nice :smile:
Aditya Vyas
@aditya1702
May 11 2016 10:20
@aviaryan @shivamMg Yes I understood. Initially i was not able to do python manage db upgrade or manage...so i made a completely new migrations folder.But I have the previous folder...I will update my branch with changes :smile:
Aayush Arora (angularboy)
@aayusharora
May 11 2016 17:07
@aditya1702 , where are the front end files , Static folder is empty .
I have successfully setup the project.
Aditya Vyas
@aditya1702
May 11 2016 17:43
@aayusharora they are in the folder open_event/templates/admin folder
Aayush Arora (angularboy)
@aayusharora
May 11 2016 17:48
@aditya1702 ,thanks
Aayush Arora (angularboy)
@aayusharora
May 11 2016 19:47
@aditya1702 , after running orga again , this error is coming
error.png
Aayush Arora (angularboy)
@aayusharora
May 11 2016 19:53
Finding error for this command python create_db.py . I think something is wrong with db migrations.
Aayush Arora (angularboy)
@aayusharora
May 11 2016 20:58
Its done by pip install -r requirements.txt after running cd /vagrant .
But it should be mentioned in Readme.md @aditya1702
Shivam Mamgain
@shivamMg
May 11 2016 21:39
@aayusharora you'll need to do a pip install --upgrade -r requirements.txt after every requirements update
Aayush Arora (angularboy)
@aayusharora
May 11 2016 21:40
@shivamMg , Initailly setting of project also need the same
mentioned here for initial setup fossasia/open-event-orga-server#285
Shivam Mamgain
@shivamMg
May 11 2016 21:41
you used install.sh for initially setting up the project, right?
Aayush Arora (angularboy)
@aayusharora
May 11 2016 21:42
@shivamMg , I followed the readme.md line by line from installing vagrant and other
and got that error .
Aayush Arora (angularboy)
@aayusharora
May 11 2016 21:51
Install.sh is not mentioned in readme
@shivamMg fossasia/open-event-orga-server#285 seems correct to you ?
Shivam Mamgain
@shivamMg
May 11 2016 21:59
The Vagrantfile has been configured to run install.sh link. So install.sh will run when setting up vagrant for the first time, and it contains the pip install command so doing a pip install again might not be needed.
On a side note pip install --upgrade -r requirements.txt is now exiting with an error status. It can't build wheel for cryptography and cffi
Aayush Arora (angularboy)
@aayusharora
May 11 2016 22:08
@shivamMg , I am trying it first time but I have followed readme , if vagrant includes it , as it is shown in the link , it should not point me for the error . The solution I have done is pip install -r requirements.txt . The error came while using command "python create _db.py" as shown in snaphot .
error.png
as it is shown it was not taking flask_debugtoolbar
Shivam Mamgain
@shivamMg
May 11 2016 22:37
@aayusharora you are probably running the same box ('ubuntu/trusty64'). By first time I meant: creating the entire box again. Do a vagrant box list, "ubuntu/trusty64" would be on that list. To do a complete new installation you need to build this box again. You can remove it and then do a vagrant up for a fresh install. For that do a vagrant box remove ubuntu/trusty64 (or don't else you'll lose every other change you have in your current installation, and a fresh install would mean installing every package from python to postgres again).
If you remember the first time you installed the box you didn't have to install postgres manually. Bz it was installed by running install.sh post vagrant-box creation.
Shivam Mamgain
@shivamMg
May 11 2016 22:42
The error above is occurring on the same box.
don't remove the box though, just do a pip upgrade
Aayush Arora (angularboy)
@aayusharora
May 11 2016 22:43
cool let me try