These are chat archives for fossasia/open-event-server

3rd
Oct 2016
Aditya
@addiittya2006
Oct 03 2016 11:43
This message was deleted
New Installation for orga-server crashes at pip install for cryptography.
gives:
Command "/usr/local/bin/python2 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-p9I3rW/cryptography/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-R4Tajk-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-p9I3rW/cryptography/
Saptak Sengupta
@SaptakS
Oct 03 2016 11:45
@addiittya2006 can you paste the error in fpaste or somewhere or put a screenshot? This is very difficult to understand
Aditya
@addiittya2006
Oct 03 2016 11:45
Adding pycparser==2.13 as a dependency to common.txt resolves this issue.
Should this issue be opened in the repo?
Please review.
Screen Shot 2016-10-03 at 17.18.28.png
Saptak Sengupta
@SaptakS
Oct 03 2016 11:52
if pycparser is a dependency of cryptography then it should get installed automatically..
Aditya
@addiittya2006
Oct 03 2016 11:56
But the Issue still exists, add pycparser as a dependency for now.
In pip the dependencies need to be specified and installed first.
See this- pyca/cryptography#3187.
Saptak Sengupta
@SaptakS
Oct 03 2016 12:17
hmmm.. seems like a problem with pycparser.. if adding it fixes the error, then u may add I think...
But it works perfectly in my system..
what is cryptography version?
Niranjan Rajendran
@niranjan94
Oct 03 2016 12:19

But it works perfectly in my system..

Yep. Works fine here too. Tested on Ubuntu 16 and CentOS 7.

Saptak Sengupta
@SaptakS
Oct 03 2016 12:20
tested in Fedora 24 as well..
That's why I am not sure
maybe the latest version of cryptography breaks..
Niranjan Rajendran
@niranjan94
Oct 03 2016 12:20
Okay @addiittya2006 ... Let's not add the pycparser dependency until we are sure what the issue is

maybe the latest version of cryptography breaks..

That might be a reason. But we have set the version in requirements as cryptography==1.4 right ?

Saptak Sengupta
@SaptakS
Oct 03 2016 12:23
hmmm then it shudnt be problem I think
Niranjan Rajendran
@niranjan94
Oct 03 2016 12:26
@SaptakS but this is causing travis build to fail ... I guess we have no choice but to add pycparser dep until eliben/pycparser#148 is resolved
Saptak Sengupta
@SaptakS
Oct 03 2016 12:26
cool.. lets add it
Aditya
@addiittya2006
Oct 03 2016 13:47
We need to add it. The problem occurs on a new setup on docker-compose build
Shall i open an issue?
Niranjan Rajendran
@niranjan94
Oct 03 2016 13:48
@addiittya2006 this has been added.
Aditya
@addiittya2006
Oct 03 2016 13:52
okay. which one?