These are chat archives for fossasia/open-event-server

7th
Jan 2017
Thien Hoang
@hoangvanthien
Jan 07 2017 03:57
Hello... I have a question
I'm new to this repo so I wonder how each event page is generated and where can I change its content e.g. call for speakers form?
Thien Hoang
@hoangvanthien
Jan 07 2017 04:03
What I want now is adding an upload progression bar in the CFS form.
Mario Behling
@mariobehling
Jan 07 2017 04:38
@arpitn30 The feature sometimes does not work on the dev branch as it uses the free public tier of sendgrid, whereas eventyay uses a sendgrid api that is part of the google cloud deployment. However, it is also possible that there is an issue, but we need to look into the detail.
Arpit Nandwani
@arpitn30
Jan 07 2017 04:45
@mariobehling Thanks 😀
pipix51
@pipix51
Jan 07 2017 05:47
@hoangvanthien You can look at the open-event-orga-server/app/models section
Tarun Kumar
@meets2tarun
Jan 07 2017 10:13
while installing i struck at installation of dependencies
. "$NVM_DIR/nvm.sh"
says no such file
?
Satwik Kansal
@satwikkansal
Jan 07 2017 10:15
@meets2tarun you'll have to export NVM_DIR first in your bash configuration
Tarun Kumar
@meets2tarun
Jan 07 2017 10:15
how to do that ?
Satwik Kansal
@satwikkansal
Jan 07 2017 10:16
First try restarting the bash and try again
Tarun Kumar
@meets2tarun
Jan 07 2017 10:17
@satwikkansal thanks it worked
Satwik Kansal
@satwikkansal
Jan 07 2017 10:17
If that doesn't works try export NVM_DIR = PATH_WHERE_NVM_IS_INSTALLED
Oh fine :)
Tarun Kumar
@meets2tarun
Jan 07 2017 10:31
python create_db.py
says
Traceback (most recent call last): File "create_db.py", line 5, in <module> from app import current_app File "/home/sucode/GSoC/open-event-orga-server/app/__init__.py", line 4, in <module> from flask.exthook import ExtDeprecationWarning ImportError: No module named flask.exthook
Satwik Kansal
@satwikkansal
Jan 07 2017 10:32
Did you execute sudo -H pip install -r requirements.txt successfully?
Tarun Kumar
@meets2tarun
Jan 07 2017 10:33
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-x0o50Y/psycopg2/
this was the only error in the last while executing
Satwik Kansal
@satwikkansal
Jan 07 2017 10:34
It didn't execute successfully that's why your python dependencies are not installed
Tarun Kumar
@meets2tarun
Jan 07 2017 10:44
what to do now ?
Satwik Kansal
@satwikkansal
Jan 07 2017 10:44
Can you show the complete logs?
Satwik Kansal
@satwikkansal
Jan 07 2017 10:49
Ah.. Even I faced this error and wasted a lot of time debugging it :(
See this pypa/pip#3943
However, reinstalling pip worked for me. You can also try
apt-get remove python-pip python3-pip
wget https://bootstrap.pypa.io/get-pip.py
python get-pip.py
python3 get-pip.py
Parag Jain
@PARAG00991
Jan 07 2017 10:50
@meets2tarun Try upgrading pip via the 'pip install --upgrade pip' command as came out in the last line of the log.
Tarun Kumar
@meets2tarun
Jan 07 2017 10:51
        @PARAG00991 i done but it stilll comes
Satwik Kansal
@satwikkansal
Jan 07 2017 10:51
try reinstalling then
Arpit Nandwani
@arpitn30
Jan 07 2017 10:52
You might be using pip for python 3
Can you post the output of
pip --version
Tarun Kumar
@meets2tarun
Jan 07 2017 10:55
@arpitn30 bash: /usr/bin/pip: No such file or directory
have python 2.7.12+
Satwik Kansal
@satwikkansal
Jan 07 2017 10:57
@meets2tarun your paths are messed up
Try reinstalling to see if that works
pipix51
@pipix51
Jan 07 2017 10:58
@meets2tarun You could try updating to Python 3.x
Satwik Kansal
@satwikkansal
Jan 07 2017 10:58
you can also consider setting up the project in virtualenv
Saptak Sengupta
@SaptakS
Jan 07 2017 11:10
@pipix51 the project is right now in Python 2.7.x... so Python 3.x might not work in all cases...
It is not fully exported to 3.x till now...
pipix51
@pipix51
Jan 07 2017 11:15
@SaptakS Oh I see thanks! @satwikkansal @meets2tarun Sorry for the confusion
Satwik Kansal
@satwikkansal
Jan 07 2017 11:16
@pipix51 Even I didn't knew that :P
Tarun Kumar
@meets2tarun
Jan 07 2017 11:16
pip 9.0.1 is installed but getting
sudo: pip: command not found
on
sudo -H pip install -r requirements.txt
Saptak Sengupta
@SaptakS
Jan 07 2017 11:17
Tarun Kumar... your pip symlink must be in some other directory...
tell me the output of which pip
which pip
@meets2tarun
Tarun Kumar
@meets2tarun
Jan 07 2017 11:18
/home/sucode/.local/bin/pip
Saptak Sengupta
@SaptakS
Jan 07 2017 11:19
yes... you can either copy this to /usr/bin/pip and try doing..
if that doesn't solve, uninstall pip...
I am guessing you installed pip using pip install -U pip to upgrade or something.. however you did, remove pip and install using apt-get... considering you use debian linux... if you use RHEL, use dnf...
Tarun Kumar
@meets2tarun
Jan 07 2017 11:23
copied
now getting
Traceback (most recent call last): File "/usr/bin/pip", line 7, in <module> from pip import main ImportError: No module named pip
on
sudo -H pip install -r requirements.txt
Saptak Sengupta
@SaptakS
Jan 07 2017 11:24
okay... try doing sudo apt-get install pip
Tarun Kumar
@meets2tarun
Jan 07 2017 11:27
E: Unable to locate package pip
Parag Jain
@PARAG00991
Jan 07 2017 11:32
do sudo apt-get install python-pip
Tarun Kumar
@meets2tarun
Jan 07 2017 11:49
now getting
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-urSrlm/colour/
on
sudo -H pip install -r requirements.txt
Saptak Sengupta
@SaptakS
Jan 07 2017 11:50
@meets2tarun there is something called google to search your errors and you will get a number of solutions in stack overflow..
Please google first and if you don't get an answer message here...
All these errors I believe are already answered in some link in stackoverflow..
Please check once first
Tarun Kumar
@meets2tarun
Jan 07 2017 12:31
@pipix51 yeah installed
pipix51
@pipix51
Jan 07 2017 12:32
@meets2tarun Did you pip upgrade the setuptools or installed ez_setup?
pipix51
@pipix51
Jan 07 2017 12:49
@meets2tarun Ok this is strange... I updated pip to 9.0.1 and I did not meet any of the errors you faced. Maybe you can try launching in on Heroku if you really want the application...you would not face much errors there
Tarun Kumar
@meets2tarun
Jan 07 2017 12:54
i get the following
Traceback (most recent call last): File "create_db.py", line 5, in <module> from app import current_app File "/vagrant/app/__init__.py", line 4, in <module> from flask.exthook import ExtDeprecationWarning File "/usr/local/lib/python2.7/dist-packages/flask/__init__.py", line 17, in <module> from werkzeug.exceptions import abort ImportError: No module named werkzeug.exceptions
on
'python create_db.py`
in vagrant
pipix51
@pipix51
Jan 07 2017 12:59
@meets2tarun I think you should delete and redownload your Python 2.7 as it seems all the problems faced are located there
You may not have downloaded aome components of the Python application when you first installed it
Satwik Kansal
@satwikkansal
Jan 07 2017 13:36
Hi, After pulling recently from development branch, I'm getting INTERNAL SERVER ERROR when I try to do any db related stuff.
I found this blog-post on fossaisia's blog but it didn't work either http://blog.fossasia.org/migrations-makes-us-crazy/
ProgrammingError: (psycopg2.ProgrammingError) column speaker.country does not exist
^ This is the error when I tried to use speaker api
pipix51
@pipix51
Jan 07 2017 13:51
@ what db related stuff did you do? I could try to help
@satwikkansal
Satwik Kansal
@satwikkansal
Jan 07 2017 13:53
I was playing with api
Satwik Kansal
@satwikkansal
Jan 07 2017 13:58
Didn't do any changes to the code
pipix51
@pipix51
Jan 07 2017 14:00
@satwikkansal Oh I see I can't do much about that
Arpit Nandwani
@arpitn30
Jan 07 2017 15:31
Which folder is the server root?
OEOS folder, app folder or the Views folder?
Niranjan Rajendran
@niranjan94
Jan 07 2017 15:33
@arpitn30 app/__init__.py is the starting point for the server
Mario Behling
@mariobehling
Jan 07 2017 16:41
Screenshot from 2017-01-07 17-40-34.png
@/all Amazing work! 1500 pull requests have been closed in this project. Thanks to all contributors. This is a truly fantastic achievement and we are getting closer to a Beta release every day!
Satwik Kansal
@satwikkansal
Jan 07 2017 16:42
Cheers! :sparkles:
Medo
@magdalenesuo
Jan 07 2017 19:20
:smile:
Saptak Sengupta
@SaptakS
Jan 07 2017 19:29
Thanks @mariobehling for guiding us through. Thanks to all new contributors for helping us soo much....
:smiley:
Satwik Kansal
@satwikkansal
Jan 07 2017 19:33
:) btw does anyone knows the solution of INTERNAL SERVER ERROR issue I'm not able to resolve it :pensive:
Saptak Sengupta
@SaptakS
Jan 07 2017 19:35
Which internal server error?
Satwik Kansal
@satwikkansal
Jan 07 2017 19:35
@SaptakS please see the messeges above in this channel
Saptak Sengupta
@SaptakS
Jan 07 2017 19:36
try doing python manage.py db upgrade
Satwik Kansal
@satwikkansal
Jan 07 2017 19:38
cursor.execute(statement, parameters)
sqlalchemy.exc.IntegrityError: (psycopg2.IntegrityError) column "country" contains null values
 [SQL: 'ALTER TABLE speaker ADD COLUMN country VARCHAR NOT NULL']
Getting this error
After the pull there were 2 db-heads , so as mentioned in this http://blog.fossasia.org/migrations-makes-us-crazy/ blog-post I merged them but still the issue persists
Saptak Sengupta
@SaptakS
Jan 07 2017 19:46
did the upgrade work fine after merging the heads?
Satwik Kansal
@satwikkansal
Jan 07 2017 19:48
Yes, it worked fine for once. But when I tried to login again I got an INTERNAL SERVER ERROR
Saptak Sengupta
@SaptakS
Jan 07 2017 19:49

```
cursor.execute(statement, parameters)
sqlalchemy.exc.IntegrityError: (psycopg2.IntegrityError) column "country" contains null values
[SQL: 'ALTER TABLE speaker ADD COLUMN country VARCHAR NOT NULL']

```

when you got this error??

on doing upgrade? or on login?
Satwik Kansal
@satwikkansal
Jan 07 2017 19:49
on doing upgrade
Actually I get a similar error while doing login as well
Saptak Sengupta
@SaptakS
Jan 07 2017 19:50

do this...

python create_db.py
python manage.py db stamp head

see if this solves...
and do this in a completely new DB
Satwik Kansal
@satwikkansal
Jan 07 2017 20:02
@SaptakS Thanks a lot! It worked :)
Saptak Sengupta
@SaptakS
Jan 07 2017 20:02
glad
Satwik Kansal
@satwikkansal
Jan 07 2017 20:03
btw should I do merge when I face this multiple db heads issue again?
Saptak Sengupta
@SaptakS
Jan 07 2017 20:04
Yes. But where did you face this multiple db heads problem?? can you tell me the 2 heads??
Satwik Kansal
@satwikkansal
Jan 07 2017 20:04
wait
Saptak Sengupta
@SaptakS
Jan 07 2017 20:05
We shud clean the migrations a little to merge such heads and reduce migration files... once we are in beta-release
Satwik Kansal
@satwikkansal
Jan 07 2017 20:06
@SaptakS 2339564f5dc7 6b937dbf3768
Saptak Sengupta
@SaptakS
Jan 07 2017 20:09
ok