These are chat archives for fossasia/open-event-server

13th
Jan 2017
Himanshi-Khandelwal
@Himanshi-Khandelwal
Jan 13 2017 17:22
the installation procedure given on the github doesn't work as the pages are not opening.
Saptak Sengupta
@SaptakS
Jan 13 2017 17:22
@Himanshi-Khandelwal can you check the terminal and share the error log?
Himanshi-Khandelwal
@Himanshi-Khandelwal
Jan 13 2017 17:23
(.venv)himanshi@himanshi-HP-Notebook:~/open-event-orga-server$ python manage.py runserver
Traceback (most recent call last):
File "manage.py", line 1, in <module>
from app.helpers.data import save_to_db
File "/home/himanshi/open-event-orga-server/app/init.py", line 19, in <module>
from app.helpers.scheduled_jobs import send_mail_to_expired_orders, empty_trash, send_after_event_mail, \
File "/home/himanshi/open-event-orga-server/app/helpers/scheduled_jobs.py", line 7, in <module>
from app.helpers.data import DataManager, delete_from_db, save_to_db
File "/home/himanshi/open-event-orga-server/app/helpers/data.py", line 14, in <module>
from PIL import Image
File "/home/himanshi/open-event-orga-server/.venv/local/lib/python2.7/site-packages/PIL/Image.py", line 67, in <module>
from PIL import _imaging as core
ImportError: libopenjp2.so.7: cannot open shared object file: No such file or directory
Saptak Sengupta
@SaptakS
Jan 13 2017 17:27
@Himanshi-Khandelwal I don't think it is some problem of documentation.
There is some path or symlink problems in your system.
Are there more than one PIL or python versions installed or something like that..
Or maybe permission problems??
Try and check these links...
It is basically that the installation of PIL doesn't happen properly in your system... Not an error in documentation I think
Himanshi-Khandelwal
@Himanshi-Khandelwal
Jan 13 2017 17:36
so for PIL installation what to do
i ll remove all this and again clone it
then pip install -r requirements.txt
anything else>
?
Saptak Sengupta
@SaptakS
Jan 13 2017 17:37
deactivate your virtualenv and do a pip freeze
See what all python dependencies are installed.
Then create a new virtualenv and do pip install -r requirements.txt
See the google links I sent.... one of the solutions will work
Himanshi-Khandelwal
@Himanshi-Khandelwal
Jan 13 2017 17:40
ok
i'll check
Saptak Sengupta
@SaptakS
Jan 13 2017 17:40
:+1:
Himanshi-Khandelwal
@Himanshi-Khandelwal
Jan 13 2017 17:45
i have created new virtual environment and pip install -r requirements.txt
now ImportError: No module named werkzeug.exceptions
these import errors are coming
so do I have to install this all similar import errors one by one manually?
Rishav Sapahia
@Rishav09
Jan 13 2017 17:46
try sudo -H pip install requirements.txt
Himanshi-Khandelwal
@Himanshi-Khandelwal
Jan 13 2017 17:47
ok
now also
same thing
Rishav Sapahia
@Rishav09
Jan 13 2017 17:54
I got the same error while installing but it was solved by using sudo -h pip command,so I guess you have to install them manually
Himanshi-Khandelwal
@Himanshi-Khandelwal
Jan 13 2017 17:55
oh
main installation problem is with PIL , pillow
Rishav Sapahia
@Rishav09
Jan 13 2017 17:57
I had the similar problem with pillow,asked this http://stackoverflow.com/questions/41416054/getting-cant-roll-back-pillowwas-not-uninstalled ,got no response ,in the end was solved using sudo -H pip command
Himanshi-Khandelwal
@Himanshi-Khandelwal
Jan 13 2017 17:59
I searched a lot , but in my case this sudo -H pip command not working
only this PIL installation is giving the problem
Himanshi-Khandelwal
@Himanshi-Khandelwal
Jan 13 2017 18:13
import PIL
ImportError: No module named PIL
Himanshi-Khandelwal
@Himanshi-Khandelwal
Jan 13 2017 18:42
please help me install PIL
Saptak Sengupta
@SaptakS
Jan 13 2017 18:51
@Himanshi-Khandelwal all other python modules are installed?
How did you create your virtualenv?
Rishav Sapahia
@Rishav09
Jan 13 2017 19:04
@niranjan94 Still the server is running too slow
@arpitn30 I tried it both and now with flask server too
Shubham Padia
@shubham-padia
Jan 13 2017 19:23
Selection_074.png
I am unable create an event and nothing in the logs, is it just me or can someone please confirm this please?
Saptak Sengupta
@SaptakS
Jan 13 2017 19:26
@shubham-padia I can see some errors in the console.
Need to check.. Can you also check please?
Shubham Padia
@shubham-padia
Jan 13 2017 19:30
:+1:
@SaptakS No errors found in the logs ( using gunicorn ), can you please post the errors you are getting.
Saptak Sengupta
@SaptakS
Jan 13 2017 19:34
I mean console in inspect element.
It's a javascript error
Shubham Padia
@shubham-padia
Jan 13 2017 19:35
Yeah, found it :+1:
Shubham Padia
@shubham-padia
Jan 13 2017 20:20
^^ fixed this at #2943