These are chat archives for fossasia/open-event-server

1st
Jun 2017
Afroz Ahamad
@enigmaeth
Jun 01 2017 14:36

I am getting this error when running sudo pip install -r requirements.txt

Obtaining flask-rest-jsonapi from git+git://github.com/shubham-padia/flask-rest-jsonapi.git@master#egg=flask-rest-jsonapi (from -r requirements/common.txt (line 57))
  Complete output from command git rev-parse HEAD:
  fatal: ambiguous argument 'HEAD': unknown revision or path not in the working tree.
  Use '--' to separate paths from revisions, like this:
  'git <command> [<revision>...] -- [<file>...]'
  HEAD

Is this related to the flask-rest-jsonapi repo at shubham-padia/<repo> or something on my local installation.

Shubham Padia
@shubham-padia
Jun 01 2017 14:43
Just tried again, works fine for me, try installing it seperately once sudo pip install -e git://github.com/shubham-padia/flask-rest-jsonapi.git@master#egg=flask-rest-jsonapi
Afroz Ahamad
@enigmaeth
Jun 01 2017 14:45
This worked. :+1:
Saptak Sengupta
@SaptakS
Jun 01 2017 16:25
@/all since we are mainly working on the same files, there will be merge conflicts. Please be careful while resolving them and take care that you don't delete other's works.
Aseem Shrey
@LuD1161
Jun 01 2017 16:58
:+1: